Ryan Barnett | 1 Nov 19:33 2011

Re: modsecurity 2.6.1, significant memory leak when using ruleUpdateTargetById ?

There were some fixes in v2.6.2 related to updating target lists.  I would
test with v2.6.2 and see if you still have the same issues.

-Ryan

On 11/1/11 2:00 PM, "rp-modsec-list <at> bev.net" <rp-modsec-list <at> bev.net>
wrote:

>There appears to be a significant memory leak when using modsecurity 2.6.1
>with the new ruleUpdateTargetById directive.
>
>#####################
># Memory usage sample:
>#####################
>Memory usage(RSS) starts out at about 21m per apache child.
>That child process grew to >300m RSS after handling only about 240
>requests.
>
># apache child process: 319m = RSS
>31355 apache    15   0  345m 319m 2600 S  0.0  7.9   0:07.60 httpd
>
># from apache server status: 239 requests for this child.
>Srv    PID     Acc
>0-0    31355   0/239/239
>
>#####################
># Version info:
>#####################
>- apache version info:
>   RHEL 5 distributed apache: httpd-2.2.3-53.el5_7.3 , using the standard
(Continue reading)


Gmane