Ken Hagenow | 4 Aug 17:37 2013
Picon

Re: DHT22 Feuchtesensor / NETIO (Pollin)

Hallo, habe aktuell gleiches Problem. 
Gab es damals eine Lösung?

Habe heute mal ein Arduino MINI PRO mit Ethernet Shild aktiviert.
Extern mit 3.3V eingespeist.

Board läuft soweit gut. ( "ping ip -f" ergibt keine verluste bei den Packeten)

DHT11 angeschlossen (sollte ja einfach sein).
Kriege aber keine Daten. 
Gegengeprüft mit IO Schalten PD2 geht. Also korrekt angeschlossen.
Auch das Pinning nochmal überprüft.
Oszi sagt auch das dort was versucht wird.

Debug sagt das "DHT read timeout edge=0"

DHT11 habe ich 2 varianten 1x fertig mit passende Kabel  und 1x selbst zusammengestrickt(hier noch
zusätzlich nen 100nF zwischen vcc und gnd, 10k und 4k7 zwischen vcc und data getestet)

Vermute ja fast das ihm die 3.3v doch nicht reichen, aber auf 5v wollte ich nicht hoch wegen dem ENC (der mag
das nicht ;-) ).
Obwohl ja 3-5.5v laut Datenblatt funktionieren sollen.

Ideen?

Cu Ken

-----Ursprüngliche Nachricht-----
Von: ethersex-devel-bounces@...
[mailto:ethersex-devel-bounces <at> list.zerties.org] Im Auftrag von eku@...
(Continue reading)

Martin Jangowski | 4 Aug 18:16 2013
Picon

Re: DHT22 Feuchtesensor / NETIO (Pollin)

Am 04.08.2013 17:37, schrieb Ken Hagenow:
> Hallo, habe aktuell gleiches Problem. 
> Gab es damals eine Lösung?
>
> Habe heute mal ein Arduino MINI PRO mit Ethernet Shild aktiviert.
> Extern mit 3.3V eingespeist.
>
> Board läuft soweit gut. ( "ping ip -f" ergibt keine verluste bei den Packeten)
>
> DHT11 angeschlossen (sollte ja einfach sein).
> Kriege aber keine Daten. 
> Gegengeprüft mit IO Schalten PD2 geht. Also korrekt angeschlossen.
> Auch das Pinning nochmal überprüft.
> Oszi sagt auch das dort was versucht wird.
>
> Debug sagt das "DHT read timeout edge=0"
>
> DHT11 habe ich 2 varianten 1x fertig mit passende Kabel  und 1x selbst zusammengestrickt(hier noch
zusätzlich nen 100nF zwischen vcc und gnd, 10k und 4k7 zwischen vcc und data getestet)
>
> Vermute ja fast das ihm die 3.3v doch nicht reichen, aber auf 5v wollte ich nicht hoch wegen dem ENC (der mag
das nicht ;-) ).
> Obwohl ja 3-5.5v laut Datenblatt funktionieren sollen.
>
> Ideen?
>
> Cu Ken
>
Der ENC braucht 3.3V, verträgt aber laut Spec. 5V an den
Signalleitungen. Also Arduino mit 5V betreiben und den ENC mit 3.3V,
(Continue reading)

Tom Weber | 5 Aug 07:07 2013
Picon
Picon

Re: DHT22 Feuchtesensor / NETIO (Pollin)

Hallo, habe ebenfalls versucht, einen DHT22 ans NET-IO zu bekommen. Laut 
Datenblatt kann er ja 5V, DATA am ADC1 und entsprechend in der pinning 
angepasst. Bekomme ebenfalls keine Daten, Lösunf nie gefunden - wäre 
aber sehr daran interessiert ....

Am 04.08.2013 17:37, schrieb Ken Hagenow:
> Hallo, habe aktuell gleiches Problem.
> Gab es damals eine Lösung?
>
> Habe heute mal ein Arduino MINI PRO mit Ethernet Shild aktiviert.
> Extern mit 3.3V eingespeist.
>
> Board läuft soweit gut. ( "ping ip -f" ergibt keine verluste bei den Packeten)
>
> DHT11 angeschlossen (sollte ja einfach sein).
> Kriege aber keine Daten.
> Gegengeprüft mit IO Schalten PD2 geht. Also korrekt angeschlossen.
> Auch das Pinning nochmal überprüft.
> Oszi sagt auch das dort was versucht wird.
>
> Debug sagt das "DHT read timeout edge=0"
>
> DHT11 habe ich 2 varianten 1x fertig mit passende Kabel  und 1x selbst zusammengestrickt(hier noch
zusätzlich nen 100nF zwischen vcc und gnd, 10k und 4k7 zwischen vcc und data getestet)
>
> Vermute ja fast das ihm die 3.3v doch nicht reichen, aber auf 5v wollte ich nicht hoch wegen dem ENC (der mag
das nicht ;-) ).
> Obwohl ja 3-5.5v laut Datenblatt funktionieren sollen.
>
> Ideen?
(Continue reading)

Florian Asche | 5 Aug 08:32 2013
Picon

Re: DHT22 Feuchtesensor / NETIO (Pollin)

Hallo zusammen, 

habe einen DHT11 mit Erfolg am NETIO laufen. Der ist per 5V angeschlossen. Ansonsten halt GND und einen
Port. 

Liegt es denn an Soft- oder Hardware?

Habt ihr euch schon einmal an einem Bascom Code oder ähnlichem probiert?

Gruss Florian 

Am 05.08.2013 um 07:50 schrieb "Tom Weber" <tom.weber@...>:

> Hallo, habe ebenfalls versucht, einen DHT22 ans NET-IO zu bekommen. Laut 
> Datenblatt kann er ja 5V, DATA am ADC1 und entsprechend in der pinning 
> angepasst. Bekomme ebenfalls keine Daten, Lösunf nie gefunden - wäre 
> aber sehr daran interessiert ....
> 
> Am 04.08.2013 17:37, schrieb Ken Hagenow:
>> Hallo, habe aktuell gleiches Problem.
>> Gab es damals eine Lösung?
>> 
>> Habe heute mal ein Arduino MINI PRO mit Ethernet Shild aktiviert.
>> Extern mit 3.3V eingespeist.
>> 
>> Board läuft soweit gut. ( "ping ip -f" ergibt keine verluste bei den Packeten)
>> 
>> DHT11 angeschlossen (sollte ja einfach sein).
>> Kriege aber keine Daten.
>> Gegengeprüft mit IO Schalten PD2 geht. Also korrekt angeschlossen.
(Continue reading)


Gmane