Tomas Rusnak | 28 Feb 09:40 2008
Picon

virtio: kvm-62, lilo cannot be installed into virtio device

Hello

I test virtio block device. I can boot from vda as root partition, but 
if I want to install lilo into boot sector, lilo give me this error:

Fatal: Linux experimental device 0x04x needs to be defined.
Check 'man lilo.conf' under 'disk=' and 'max-partitions='

I boot it like this:

kvm -boot c -drive file=basic-virtio.qcow2,if=virtio,boot=on -m 512 -vnc 
:0 -net nic,model=virtio,vlan=0,macaddr=00:00:10:52:37:48 -net 
tap,vlan=0,ifname=tap0,script=no -daemonize -localtime

basic-virtio.qcow is with lilo in boot sector installed, because is 
image what I use before virtio testing. But with each boot I must 
manually add root=/dev/vda2 if I want to boot it.

Host: Gentoo, kernel with gentoo patchset 2.6.24-r3
Guest: Gentoo, kernel vanilla 2.6.25-rc3
KVM: 62
qemu: 0.9.1

Thank you for your job.

--

-- 
Tomas Rusnak, Korex Networks
____________________________

Korex s.r.o.
(Continue reading)

Chris Wedgwood | 28 Feb 09:54 2008

Re: virtio: kvm-62, lilo cannot be installed into virtio device

On Thu, Feb 28, 2008 at 09:40:00AM +0100, Tomas Rusnak wrote:

> I test virtio block device. I can boot from vda as root partition, but 
> if I want to install lilo into boot sector, lilo give me this error:
> 
> Fatal: Linux experimental device 0x04x needs to be defined.
> Check 'man lilo.conf' under 'disk=' and 'max-partitions='

lilo can't figure out what /dev/vda to the bios, does adding:

  disk=/dev/vda
    bios=0x80

help?

-------------------------------------------------------------------------
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2008.
http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
Tomas Rusnak | 28 Feb 10:11 2008
Picon

Re: virtio: kvm-62, lilo cannot be installed into virtio device

Chris Wedgwood napsal(a):
> On Thu, Feb 28, 2008 at 09:40:00AM +0100, Tomas Rusnak wrote:
> 
>> I test virtio block device. I can boot from vda as root partition, but 
>> if I want to install lilo into boot sector, lilo give me this error:
>>
>> Fatal: Linux experimental device 0x04x needs to be defined.
>> Check 'man lilo.conf' under 'disk=' and 'max-partitions='
> 
> lilo can't figure out what /dev/vda to the bios, does adding:
> 
>   disk=/dev/vda
>     bios=0x80
> 
> help?

Thank you for your quick answer, but this doesn't help. After i run 
lilo, it give me the same error message.

--

-- 
Tomas Rusnak, Korex Networks
____________________________

Korex s.r.o.
Pernikarska 8
010 01 Zilina
Slovak Republic
tel	+421 41 562 5648
email	tomas.rusnak <at> korex.sk
web	www.korex.sk
(Continue reading)

Chris Wedgwood | 28 Feb 10:17 2008

Re: virtio: kvm-62, lilo cannot be installed into virtio device

On Thu, Feb 28, 2008 at 10:11:30AM +0100, Tomas Rusnak wrote:

>>> Check 'man lilo.conf' under 'disk=' and 'max-partitions='

> Thank you for your quick answer, but this doesn't help. After i run
> lilo, it give me the same error message.

did you try adding 'max-partitions=16' or similar?

-------------------------------------------------------------------------
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2008.
http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
Tomas Rusnak | 28 Feb 10:25 2008
Picon

Re: virtio: kvm-62, lilo cannot be installed into virtio device

Chris Wedgwood napsal(a):
> On Thu, Feb 28, 2008 at 10:11:30AM +0100, Tomas Rusnak wrote:
> 
>>>> Check 'man lilo.conf' under 'disk=' and 'max-partitions='
> 
>> Thank you for your quick answer, but this doesn't help. After i run
>> lilo, it give me the same error message.
> 
> did you try adding 'max-partitions=16' or similar?
> 

Oh yes, i forgot it :)

But max-partitions=16 give you "bad value". After this I try 
max-partitions=7 and run lilo with following result:

Warning: /proc/partitions references Experimental major device 254.
Warning: /proc/partitions references Experimental major device 254.
Warning: /proc/partitions references Experimental major device 254.
Added Gentoo-25 *
3 warnings were issued.

Now I can boot it correctly. Thank you very much again.

--

-- 
Tomas Rusnak, Korex Networks
____________________________

Korex s.r.o.
Pernikarska 8
(Continue reading)

Chris Wedgwood | 28 Feb 10:49 2008

Re: virtio: kvm-62, lilo cannot be installed into virtio device

On Thu, Feb 28, 2008 at 10:25:49AM +0100, Tomas Rusnak wrote:

> But max-partitions=16 give you "bad value".

I suggested 16 because that's what the called to alloc_disk in the
virtio block driver is using.  I'm not sure why lilo dislikes that
value.

> Now I can boot it correctly. Thank you very much again.

It might be useful to put up a Wiki page now that you have it working
for this.

-------------------------------------------------------------------------
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2008.
http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
Tomas Rusnak | 28 Feb 11:52 2008
Picon

Re: virtio: kvm-62, lilo cannot be installed into virtio device

Chris Wedgwood napsal(a):
> On Thu, Feb 28, 2008 at 10:25:49AM +0100, Tomas Rusnak wrote:
> 
>> But max-partitions=16 give you "bad value".
> 
> I suggested 16 because that's what the called to alloc_disk in the
> virtio block driver is using.  I'm not sure why lilo dislikes that
> value.
> 
>> Now I can boot it correctly. Thank you very much again.
> 
> It might be useful to put up a Wiki page now that you have it working
> for this.

It's no problem to publish it for others, but did you mean to update 
this page?

http://kvm.qumranet.com/kvmwiki/Virtio?highlight=%28virtio%29/edit

or make a new page?

I don't know how, because I never put something onto kvm wiki. Can you 
point me to "right way"? :)

--

-- 
Tomas Rusnak, Korex Networks
____________________________

Korex s.r.o.
Pernikarska 8
(Continue reading)

H. Peter Anvin | 28 Feb 23:38 2008

Re: virtio: kvm-62, lilo cannot be installed into virtio device

Tomas Rusnak wrote:
> Chris Wedgwood napsal(a):
>> On Thu, Feb 28, 2008 at 10:11:30AM +0100, Tomas Rusnak wrote:
>>
>>>>> Check 'man lilo.conf' under 'disk=' and 'max-partitions='
>>> Thank you for your quick answer, but this doesn't help. After i run
>>> lilo, it give me the same error message.
>> did you try adding 'max-partitions=16' or similar?
>>
> 
> Oh yes, i forgot it :)
> 
> But max-partitions=16 give you "bad value". After this I try 
> max-partitions=7 and run lilo with following result:
> 
> Warning: /proc/partitions references Experimental major device 254.
> Warning: /proc/partitions references Experimental major device 254.
> Warning: /proc/partitions references Experimental major device 254.
> Added Gentoo-25 *
> 3 warnings were issued.
> 

max-partitions=7 sounds a bit confining, why are we using such a low number?

LILO is one of several reasons why using dynamic major really isn't such 
a great idea.  We don't have the 8:8 limitation anymore.

	-hpa

-------------------------------------------------------------------------
(Continue reading)


Gmane