Pedro Monteiro | 15 Mar 02:54 2010
Picon

ERROR after geos install

Hi, I'm writing to ask for help with some misbehaviour of my postgis database, after installing geos from EPEL on a Centos 5.2 server, getting this error.

"ERROR: could not load library "/usr/local/lib/liblwgeom.so": libgeos_c.so.1: cannot open shared object file: No such file or directory"

I have already removed geos, and confirmed that the file exists with

Thank you in advance.

Pedro Monteiro

_______________________________________________
postgis-users mailing list
postgis-users <at> postgis.refractions.net
http://postgis.refractions.net/mailman/listinfo/postgis-users
Paragon Corporation | 15 Mar 08:33 2010
Picon

Re: ERROR after geos install

Pedro,

I think this is a fairly common problem.

Most likely your liblwgeom.so is looking for geos in the wrong place or is
pointing at an older version of geos.

Do a 

ldd -d /usr/local/lib/liblwgeom.so 

or just to show the geos bindings
ldd -d /usr/local/lib/liblwgeom.so  | grep libgeos  

This will give you a clue where liblwgeom is looking.  Most likely it will
give a missing or something like that

Then you can symlink to the right location something like:
#To remove existing
rm /usr/lib/libgeos_c.so.1

#to link to right one -- change this accordingly to where you have geos
installed
ln -s /usr/local/lib/libgeos_c.so.1.6.0 /usr/lib/libgeos_c.so.1

Hope that helps,
Leo and Regina
http://www.postgis.us

________________________________

From: postgis-users-bounces <at> postgis.refractions.net
[mailto:postgis-users-bounces <at> postgis.refractions.net] On Behalf Of Pedro
Monteiro
Sent: Sunday, March 14, 2010 9:55 PM
To: postgis-users <at> postgis.refractions.net
Subject: [postgis-users] ERROR after geos install

Hi, I'm writing to ask for help with some misbehaviour of my postgis
database, after installing geos from EPEL on a Centos 5.2 server, getting
this error. 

"ERROR: could not load library "/usr/local/lib/liblwgeom.so":
libgeos_c.so.1: cannot open shared object file: No such file or directory"

I have already removed geos, and confirmed that the file exists with

Thank you in advance.

Pedro Monteiro
strk | 15 Mar 09:05 2010
Picon

Re: ERROR after geos install

On Mon, Mar 15, 2010 at 12:54:33AM -0100, Pedro Monteiro wrote:
> Hi, I'm writing to ask for help with some misbehaviour of my postgis
> database, after installing geos from EPEL on a Centos 5.2 server, getting
> this error.
> 
> "ERROR: could not load library "/usr/local/lib/liblwgeom.so":
> libgeos_c.so.1: cannot open shared object file: No such file or directory"

Try running ldconfig, as root.
Make sure /usr/local/lib is in your /etc/ld.so.conf

--strk;

  ()   Free GIS & Flash consultant/developer
  /\   http://strk.keybit.net/services.html
Pedro Monteiro | 15 Mar 12:51 2010
Picon

Re: ERROR after geos install

Thank you all.

I've solved the problem creating the biddings on ld.so.conf (don't know why they desapeared)

         echo '/usr/local/lib' >> /etc/ld.so.conf.d/local-lib.conf
         ldconfig

And my postgis instance is working again.





2010/3/15 strk <strk <at> keybit.net>
On Mon, Mar 15, 2010 at 12:54:33AM -0100, Pedro Monteiro wrote:
> Hi, I'm writing to ask for help with some misbehaviour of my postgis
> database, after installing geos from EPEL on a Centos 5.2 server, getting
> this error.
>
> "ERROR: could not load library "/usr/local/lib/liblwgeom.so":
> libgeos_c.so.1: cannot open shared object file: No such file or directory"

Try running ldconfig, as root.
Make sure /usr/local/lib is in your /etc/ld.so.conf

--strk;

 ()   Free GIS & Flash consultant/developer
 /\   http://strk.keybit.net/services.html
_______________________________________________
postgis-users mailing list
postgis-users <at> postgis.refractions.net
http://postgis.refractions.net/mailman/listinfo/postgis-users

_______________________________________________
postgis-users mailing list
postgis-users <at> postgis.refractions.net
http://postgis.refractions.net/mailman/listinfo/postgis-users

Gmane