Ralph Goers (JIRA | 1 May 06:10 2012
Picon

[jira] [Resolved] (LOG4J2-12) log4j 2.0 should provide an API that is generally source compatible with log4j 1.2


     [
https://issues.apache.org/jira/browse/LOG4J2-12?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Ralph Goers resolved LOG4J2-12.
-------------------------------

       Resolution: Fixed
    Fix Version/s: 2.0-alpha1
         Assignee: Ralph Goers

The log4j 1.x bridge provides compatibility with Log4j 1.2 as much as possible. 

> log4j 2.0 should provide an API that is generally source compatible with log4j 1.2
> ----------------------------------------------------------------------------------
>
>                 Key: LOG4J2-12
>                 URL: https://issues.apache.org/jira/browse/LOG4J2-12
>             Project: Log4j 2
>          Issue Type: Wish
>          Components: API
>            Reporter: Curt Arnold
>            Assignee: Ralph Goers
>             Fix For: 2.0-alpha1
>
>
> log4j 2.0 should provide an API that is generally source compatible with client code that currently uses
log4j 1.2.  This API would have a different package name to distinguish it from log4j 1.2 (see LOG4J2-10 for
a drop in emulation of log4j 1.2).  log4j 2.0 may provide other APIs in addition to the log4j 1.2 compatible
API. 
(Continue reading)


Gmane