Cody Zhang | 13 Dec 08:55 2010
Picon

maven 2.2.1 to 3.0.1 can't deploy jar to repository.

Hi,All
    from maven 2.2.1 to 3.0.1 can't deploy jar to repository.Can someone
help me?
[INFO]
[INFO] --- maven-deploy-plugin:2.5:deploy (default-deploy)  <at>  maven-iwlsvn
 ---
[INFO] ------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------
[INFO] Total time: 6.361s
[INFO] Finished at: Mon Dec 13 15:49:49 CST 2010
[INFO] Final Memory: 6M/11M
[INFO] ------------------------------------------------------------------
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-deploy-plug
deploy (default-deploy) on project maven-iwlsvn-plugin: Failed to deploy
ts/metadata: No connector available to access repository mycom-repo
(scp://192.168.0.41/var/www/html/maven2) of type default using the availa
tories WagonRepositoryConnectorFactory -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the
ch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, ple
d the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoExe
xception

    Best Regards,
        --Cody.Zhang
(Continue reading)

Jason van Zyl | 13 Dec 09:22 2010

Re: maven 2.2.1 to 3.0.1 can't deploy jar to repository.

For 3.0: https://cwiki.apache.org/MAVEN/maven-3x-compatibility-notes.html#Maven3.xCompatibilityNotes-TransportProtocols%2528Wagons%2529

On Dec 13, 2010, at 2:55 AM, Cody Zhang wrote:

> Hi,All
>    from maven 2.2.1 to 3.0.1 can't deploy jar to repository.Can someone
> help me?
> [INFO]
> [INFO] --- maven-deploy-plugin:2.5:deploy (default-deploy)  <at>  maven-iwlsvn
> ---
> [INFO] ------------------------------------------------------------------
> [INFO] BUILD FAILURE
> [INFO] ------------------------------------------------------------------
> [INFO] Total time: 6.361s
> [INFO] Finished at: Mon Dec 13 15:49:49 CST 2010
> [INFO] Final Memory: 6M/11M
> [INFO] ------------------------------------------------------------------
> [ERROR] Failed to execute goal org.apache.maven.plugins:maven-deploy-plug
> deploy (default-deploy) on project maven-iwlsvn-plugin: Failed to deploy
> ts/metadata: No connector available to access repository mycom-repo
> (scp://192.168.0.41/var/www/html/maven2) of type default using the availa
> tories WagonRepositoryConnectorFactory -> [Help 1]
> [ERROR]
> [ERROR] To see the full stack trace of the errors, re-run Maven with the
> ch.
> [ERROR] Re-run Maven using the -X switch to enable full debug logging.
> [ERROR]
> [ERROR] For more information about the errors and possible solutions, ple
> d the following articles:
> [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoExe
(Continue reading)

Cody Zhang | 13 Dec 10:09 2010
Picon

Re: maven 2.2.1 to 3.0.1 can't deploy jar to repository.

Thanks Jason!


    Best Regards,
        --Cody.Zhang


在 2010年12月13日 下午4:22,Jason van Zyl <jason <at> maven.org>写道:
For 3.0: https://cwiki.apache.org/MAVEN/maven-3x-compatibility-notes.html#Maven3.xCompatibilityNotes-TransportProtocols%2528Wagons%2529

On Dec 13, 2010, at 2:55 AM, Cody Zhang wrote:

> Hi,All
>    from maven 2.2.1 to 3.0.1 can't deploy jar to repository.Can someone
> help me?
> [INFO]
> [INFO] --- maven-deploy-plugin:2.5:deploy (default-deploy) <at> maven-iwlsvn
> ---
> [INFO] ------------------------------------------------------------------
> [INFO] BUILD FAILURE
> [INFO] ------------------------------------------------------------------
> [INFO] Total time: 6.361s
> [INFO] Finished at: Mon Dec 13 15:49:49 CST 2010
> [INFO] Final Memory: 6M/11M
> [INFO] ------------------------------------------------------------------
> [ERROR] Failed to execute goal org.apache.maven.plugins:maven-deploy-plug
> deploy (default-deploy) on project maven-iwlsvn-plugin: Failed to deploy
> ts/metadata: No connector available to access repository mycom-repo
> (scp://192.168.0.41/var/www/html/maven2) of type default using the availa
> tories WagonRepositoryConnectorFactory -> [Help 1]
> [ERROR]
> [ERROR] To see the full stack trace of the errors, re-run Maven with the
> ch.
> [ERROR] Re-run Maven using the -X switch to enable full debug logging.
> [ERROR]
> [ERROR] For more information about the errors and possible solutions, ple
> d the following articles:
> [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoExe
> xception
>
>    Best Regards,
>        --Cody.Zhang

Thanks,

Jason

----------------------------------------------------------
Jason van Zyl
Founder,  Apache Maven
http://twitter.com/jvanzyl
---------------------------------------------------------

We know what we are, but know not what we may be.

 -- Shakespeare




Juven Xu | 13 Dec 09:41 2010
Picon

Re: [Maven中文#1103] maven 2.2.1 to 3.0.1 can't deploy jar to repository.

you need to add wagon extension in maven 3:

  <build>
    <extensions>
      <extension>
        <groupId>org.apache.maven.wagon</groupId>
         <artifactId>wagon-ssh</artifactId>
         <version>1.0-beta-7</version>
      </extension>
    </extensions>
  </build>

see:
https://cwiki.apache.org/MAVEN/maven-3x-compatibility-notes.html#Maven3.xCompatibilityNotes-TransportProtocols%2528Wagons%2529

2010/12/13 Cody Zhang <codyzhang.work <at> gmail.com>

> Hi,All
>     from maven 2.2.1 to 3.0.1 can't deploy jar to repository.Can someone
> help me?
> [INFO]
> [INFO] --- maven-deploy-plugin:2.5:deploy (default-deploy)  <at>  maven-iwlsvn
>  ---
> [INFO] ------------------------------------------------------------------
> [INFO] BUILD FAILURE
> [INFO] ------------------------------------------------------------------
> [INFO] Total time: 6.361s
> [INFO] Finished at: Mon Dec 13 15:49:49 CST 2010
> [INFO] Final Memory: 6M/11M
> [INFO] ------------------------------------------------------------------
> [ERROR] Failed to execute goal org.apache.maven.plugins:maven-deploy-plug
> deploy (default-deploy) on project maven-iwlsvn-plugin: Failed to deploy
> ts/metadata: No connector available to access repository mycom-repo
> (scp://192.168.0.41/var/www/html/maven2) of type default using the availa
> tories WagonRepositoryConnectorFactory -> [Help 1]
> [ERROR]
> [ERROR] To see the full stack trace of the errors, re-run Maven with the
> ch.
> [ERROR] Re-run Maven using the -X switch to enable full debug logging.
> [ERROR]
> [ERROR] For more information about the errors and possible solutions, ple
> d the following articles:
> [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoExe
> xception
>
>     Best Regards,
>         --Cody.Zhang
>
> --
> 您收到此邮件是因为您订阅了 Google 网上论坛的“Maven中文”论坛。
> 要向此网上论坛发帖,请发送电子邮件至 maven-zh <at> googlegroups.com。
> 要取消订阅此网上论坛,请发送电子邮件至 maven-zh+unsubscribe <at> googlegroups.com<maven-zh%2Bunsubscribe <at> googlegroups.com>
> 。
> 若有更多问题,请通过 http://groups.google.com/group/maven-zh?hl=zh-CN 访问此网上论坛。
>

--

-- 
- Juven Xu
- http://www.juvenxu.com/

Gmane