King, Darren | 10 Aug 03:30 2007

Tellico not opening previous file

After an upgrade to Fedora 7 (not a smooth upgrade), Tellico no longer opens the previous file I was working on like it used to, despite the option being turned on in the configuration.  Every time Tellico opens up it just has a blank view and I have to re-open the file and also setup the view on the right, which only lists the name of the book.  Any ideas why is it's started doing this?  It's tellico version 1.2.10 on there.

Darren

_______________________________________________
tellico-users mailing list
tellico-users@...
http://forge.novell.com/mailman/listinfo/tellico-users
Robby Stephenson | 10 Aug 04:15 2007

Re: Tellico not opening previous file

On Thursday 09 August 2007, King, Darren wrote:
> After an upgrade to Fedora 7 (not a smooth upgrade), Tellico no longer
> opens the previous file I was working on like it used to, despite the
> option being turned on in the configuration.  Every time Tellico opens
> up it just has a blank view and I have to re-open the file and also
> setup the view on the right, which only lists the name of the book.  Any
> ideas why is it's started doing this?  It's tellico version 1.2.10 on
> there.

There have been a couple of reports from Fedora users about problems with 
the config file. Failing to open the previous data file is one of the 
prominent symptoms. Since I don't use Fedora, I've not been able to 
reproduce the issue. I'm a bit at a loss what could be causing it, 
particularly since other KDE apps don't seem to be affected. As far as I 
know, I don't use the KConfig class any different.

Robby
Vitor M. Pereira | 10 Aug 17:00 2007
Picon

Re: Tellico not opening previous file

Hi,

I've also reported this earlier in June. But seeing that it is a 
widespread phenomenon among F7 useres I decided to investigate a 
little bit more just now.

First, I found out that I actually know the person who currently 
builds the tellico rpms for Fedora (should have checked 
earlier :-) ). I'm going to tell him about this issue.

Second, I figured a temporary workaround that apparently restores the 
expected behavior with respect to the configs. Here's how it works.

Instead of running 

 $ tellico

run 

 $ tellico --config ~/.kde/share/config/tellicorc

The first time you will have the fresh config. Now you start to open 
files and setting your configs, and so on. Now close tellico and run 
again 

 $ tellico --config ~/.kde/share/config/tellicorc

In my case all configurations were honored, and the tellicorc was not 
overwritten. Needless to say, you should always invoke tellico as 
above (redefine the command in your shortcuts, set an alias, etc.), 
or else it will not work (you can also use any other path).

Now, I don't know how in hell it works like this and not without 
specifying the config file, because ~/.kde/share/config/tellicorc is 
the default config file !!!!

Best
Vitor

On Thursday 09 August 2007, Robby Stephenson wrote:
> On Thursday 09 August 2007, King, Darren wrote:
> > After an upgrade to Fedora 7 (not a smooth upgrade), Tellico no
> > longer opens the previous file I was working on like it used to,
> > despite the option being turned on in the configuration.  Every
> > time Tellico opens up it just has a blank view and I have to
> > re-open the file and also setup the view on the right, which only
> > lists the name of the book.  Any ideas why is it's started doing
> > this?  It's tellico version 1.2.10 on there.
>
> There have been a couple of reports from Fedora users about
> problems with the config file. Failing to open the previous data
> file is one of the prominent symptoms. Since I don't use Fedora,
> I've not been able to reproduce the issue. I'm a bit at a loss what
> could be causing it, particularly since other KDE apps don't seem
> to be affected. As far as I know, I don't use the KConfig class any
> different.
>
> Robby
> _______________________________________________
> tellico-users mailing list
> tellico-users@...
> http://forge.novell.com/mailman/listinfo/tellico-users
Jens Seidel | 10 Aug 18:37 2007
Picon

Re: Tellico not opening previous file

On Fri, Aug 10, 2007 at 11:00:24AM -0400, Vitor M. Pereira wrote:
> I've also reported this earlier in June. But seeing that it is a 
> widespread phenomenon among F7 useres I decided to investigate a 
> little bit more just now.

>  $ tellico --config ~/.kde/share/config/tellicorc
> 
> In my case all configurations were honored, and the tellicorc was not 
> overwritten. Needless to say, you should always invoke tellico as 
> above (redefine the command in your shortcuts, set an alias, etc.), 
> or else it will not work (you can also use any other path).
> 
> Now, I don't know how in hell it works like this and not without 
> specifying the config file, because ~/.kde/share/config/tellicorc is 
> the default config file !!!!

Could you call tellico with and without --config option via strace
("strace tellico 2> tellico.log") and compare the output? Does tellico
try to open ~/.kde/share/config/tellicorc or another file without
--config option?

Jens
King, Darren | 13 Aug 01:28 2007

RE: Tellico not opening previous file

I worked around it by setting up tellico the way I want it and then
making the tellicorc file read-only.  Tellico warns me that settings
won't be saved when it starts up but I can work on my library fine and
if I want to do anything, settings-wise, I can make it read-write as
long as I remember to make it read-only before I start tellico the next
time.

What is happening is that the tellicorc file is being overwritten with a
fresh one every time tellico starts.  I have no idea why but I think it
may have something to do with Kconfig, which is in kdelibs as other apps
have had this issue (not saving settings).  Even the fresh settings file
has the "open last file" option on but because the fresh file took any
mention of what file was opened last, tellico has no idea it has ever
been run before.

Darren 

-----Original Message-----
From: tellico-users-bounces@...
[mailto:tellico-users-bounces@...] On Behalf Of Vitor M.
Pereira
Sent: Saturday, 11 August 2007 1:00 AM
To: tellico-users@...
Subject: Re: Tellico not opening previous file

Hi,

I've also reported this earlier in June. But seeing that it is a
widespread phenomenon among F7 useres I decided to investigate a little
bit more just now.

First, I found out that I actually know the person who currently builds
the tellico rpms for Fedora (should have checked earlier :-) ). I'm
going to tell him about this issue.

Second, I figured a temporary workaround that apparently restores the
expected behavior with respect to the configs. Here's how it works.

Instead of running 

 $ tellico

run 

 $ tellico --config ~/.kde/share/config/tellicorc

The first time you will have the fresh config. Now you start to open
files and setting your configs, and so on. Now close tellico and run
again 

 $ tellico --config ~/.kde/share/config/tellicorc

In my case all configurations were honored, and the tellicorc was not
overwritten. Needless to say, you should always invoke tellico as above
(redefine the command in your shortcuts, set an alias, etc.), or else it
will not work (you can also use any other path).

Now, I don't know how in hell it works like this and not without
specifying the config file, because ~/.kde/share/config/tellicorc is the
default config file !!!!

Best
Vitor

On Thursday 09 August 2007, Robby Stephenson wrote:
> On Thursday 09 August 2007, King, Darren wrote:
> > After an upgrade to Fedora 7 (not a smooth upgrade), Tellico no 
> > longer opens the previous file I was working on like it used to, 
> > despite the option being turned on in the configuration.  Every time

> > Tellico opens up it just has a blank view and I have to re-open the 
> > file and also setup the view on the right, which only lists the name

> > of the book.  Any ideas why is it's started doing this?  It's 
> > tellico version 1.2.10 on there.
>
> There have been a couple of reports from Fedora users about problems 
> with the config file. Failing to open the previous data file is one of

> the prominent symptoms. Since I don't use Fedora, I've not been able 
> to reproduce the issue. I'm a bit at a loss what could be causing it, 
> particularly since other KDE apps don't seem to be affected. As far as

> I know, I don't use the KConfig class any different.
>
> Robby
> _______________________________________________
> tellico-users mailing list
> tellico-users@...
> http://forge.novell.com/mailman/listinfo/tellico-users

_______________________________________________
tellico-users mailing list
tellico-users@...
http://forge.novell.com/mailman/listinfo/tellico-users
Robby Stephenson | 13 Aug 02:46 2007

Re: Tellico not opening previous file

On Sunday 12 August 2007, King, Darren wrote:
> What is happening is that the tellicorc file is being overwritten with a
> fresh one every time tellico starts.  I have no idea why but I think it
> may have something to do with Kconfig, which is in kdelibs as other apps
> have had this issue (not saving settings).

Whoa, so the problem does indeed occur with an application other than 
Tellico? That's good to know, and rather significant. Do you know of any 
bugs filed with Fedora that may be relevant to this problem? Up to this 
point, I sorta thought it was a Tellico-specific issue.

Robby
King, Darren | 13 Aug 03:05 2007

RE: Tellico not opening previous file

No but I started searching on Sunday for solutions and came across a few
mentions of Kconfig issues with saving settings so that made me think
the problem may be outside tellico, at least partially.  I wish there
was a way to save web sessions so I can recall them (like a video or
something of it)....I don't know how many times I've found something on
the net only to look for it again and be unable to find it!

Darren 

-----Original Message-----
From: tellico-users-bounces@...
[mailto:tellico-users-bounces@...] On Behalf Of Robby
Stephenson
Sent: Monday, 13 August 2007 10:47 AM
To: tellico-users@...
Subject: Re: Tellico not opening previous file

On Sunday 12 August 2007, King, Darren wrote:
> What is happening is that the tellicorc file is being overwritten with

> a fresh one every time tellico starts.  I have no idea why but I think

> it may have something to do with Kconfig, which is in kdelibs as other

> apps have had this issue (not saving settings).

Whoa, so the problem does indeed occur with an application other than
Tellico? That's good to know, and rather significant. Do you know of any
bugs filed with Fedora that may be relevant to this problem? Up to this
point, I sorta thought it was a Tellico-specific issue.

Robby
_______________________________________________
tellico-users mailing list
tellico-users@...
http://forge.novell.com/mailman/listinfo/tellico-users

Gmane