Weber, Richard | 14 Dec 17:15 2006

Program won't Compile

I can't figure this one out.  I made a minor programming change to an RPGLE
program.  I set up my library list to compile it.  The compile fails.  The
spool file says: 

Errors were found during the binding step. See the job log for more
information. 

Ok so I go to the Joblog, like it says, and I see:

Message . . . . :   Job ended. Cancel message received at command processor.

Cause . . . . . :   A message with a severity equal to or exceeding the end

  severity was received at the command processor. Recovery  . . . :   See
the messages previously listed to determine the message that caused the job
to be ended. Correct the errors, and then try the request again.   

Unfortunately, there are no previously listed messages except the job
submitted message.  So, what's the problem??  The only thing I noticed is
that while the job was sitting on the qbatch subsystem, it was in LCKW state
and I can't figure out why and neither the joblog or listing want to give me
any helpful information.              

Rick Weber  |  TOYS 'Я' US International 

======================================================================== 
This email message is for the sole use of the intended recipient (s) and may
contain confidential and privileged information. Any unauthorized review,
use, disclosure or distribution is prohibited. If you are not the intended
recipient, please contact the sender by reply email and destroy all copies
(Continue reading)

Richard ECUYER | 14 Dec 17:35 2006
Picon

Re: Program won't Compile

When you get a binding error (unable to resole, more than one xxx proceudre
...) the explaination are in the QPJOBLOG not in the listing compil.
----- Original Message ----- 
From: "Weber, Richard" <Weberr <at> toysrus.com>
To: "'RPG programming on the AS400 / iSeries'" <rpg400-l <at> midrange.com>
Sent: Thursday, December 14, 2006 5:15 PM
Subject: Program won't Compile

> I can't figure this one out.  I made a minor programming change to an
RPGLE
> program.  I set up my library list to compile it.  The compile fails.  The
> spool file says:
>
> Errors were found during the binding step. See the job log for more
> information.
>
> Ok so I go to the Joblog, like it says, and I see:
>
> Message . . . . :   Job ended. Cancel message received at command
processor.
>
> Cause . . . . . :   A message with a severity equal to or exceeding the
end
>
>   severity was received at the command processor. Recovery  . . . :   See
> the messages previously listed to determine the message that caused the
job
> to be ended. Correct the errors, and then try the request again.
>
> Unfortunately, there are no previously listed messages except the job
(Continue reading)

Michael_Schutte | 14 Dec 17:38 2006

Re: Program won't Compile

If you compiled interactively, you can do a DSPJOBLOG and find the error
message there.  But only if you compiled interactively.

Ciao!
Michael Schutte
Classic Italian dishes with a Bob Evans Twist - Enjoy our new Homestyle
Pastas!

--

-- 
This is the RPG programming on the AS400 / iSeries (RPG400-L) mailing list
To post a message email: RPG400-L@...
To subscribe, unsubscribe, or change list options,
visit: http://lists.midrange.com/mailman/listinfo/rpg400-l
or email: RPG400-L-request@...
Before posting, please take a moment to review the archives
at http://archive.midrange.com/rpg400-l.

Richard ECUYER | 14 Dec 17:36 2006
Picon

Re: Program won't Compile

oups too fast answer, can you compile another pgm without change ?

----- Original Message ----- 
From: "Weber, Richard" <Weberr <at> toysrus.com>
To: "'RPG programming on the AS400 / iSeries'" <rpg400-l <at> midrange.com>
Sent: Thursday, December 14, 2006 5:15 PM
Subject: Program won't Compile

> I can't figure this one out.  I made a minor programming change to an
RPGLE
> program.  I set up my library list to compile it.  The compile fails.  The
> spool file says:
>
> Errors were found during the binding step. See the job log for more
> information.
>
> Ok so I go to the Joblog, like it says, and I see:
>
> Message . . . . :   Job ended. Cancel message received at command
processor.
>
> Cause . . . . . :   A message with a severity equal to or exceeding the
end
>
>   severity was received at the command processor. Recovery  . . . :   See
> the messages previously listed to determine the message that caused the
job
> to be ended. Correct the errors, and then try the request again.
>
> Unfortunately, there are no previously listed messages except the job
(Continue reading)

Alan Shore | 14 Dec 17:39 2006

Re: Program won't Compile

We had the same problem recently, with the same error.
Ours was due to somebody (the proverbial somebody) moving a service program
from one binding directory to another.
This was rectified by including the new binding directory in the H specs.



Alan Shore

NBTY, Inc
(631) 244-2000 ext. 5019
AShore <at> NBTY.com

rpg400-l-bounces <at> midrange.com wrote on 12/14/2006 11:15:43 AM:

> I can't figure this one out.  I made a minor programming change to an
RPGLE
> program.  I set up my library list to compile it.  The compile fails.
The
> spool file says:
>
> Errors were found during the binding step. See the job log for more
> information.
>
> Ok so I go to the Joblog, like it says, and I see:
>
> Message . . . . :   Job ended. Cancel message received at command
processor.
>
> Cause . . . . . :   A message with a severity equal to or exceeding the
(Continue reading)

Weber, Richard | 14 Dec 17:45 2006

RE: Program won't Compile

I don't have another program that I can compile just now.  But, after I sent
the message, the program compiled.  I guess someone might have been using
it, which would explain the LCKW.  It would have been nice if the spool file
and joblog messages came right out and said that instead of sending me in
circles.

Rick Weber  |  TOYS 'Я' US International 

-----Original Message-----
From: Richard ECUYER [mailto:recuyer <at> fram.fr] 
Sent: Thursday, December 14, 2006 11:37 AM
To: RPG programming on the AS400 / iSeries
Subject: Re: Program won't Compile

oups too fast answer, can you compile another pgm without change ?

----- Original Message ----- 
From: "Weber, Richard" <Weberr <at> toysrus.com>
To: "'RPG programming on the AS400 / iSeries'" <rpg400-l <at> midrange.com>
Sent: Thursday, December 14, 2006 5:15 PM
Subject: Program won't Compile

> I can't figure this one out.  I made a minor programming change to an
RPGLE
> program.  I set up my library list to compile it.  The compile fails.  The
> spool file says:
>
> Errors were found during the binding step. See the job log for more
> information.
>
(Continue reading)

Weber, Richard | 14 Dec 17:46 2006

RE: Program won't Compile

Simple program, no binding directory or service programs.

Rick Weber  |  TOYS 'Я' US International 

-----Original Message-----
From: Alan Shore [mailto:AlanShore <at> nbty.com] 
Sent: Thursday, December 14, 2006 11:39 AM
To: RPG programming on the AS400 / iSeries
Subject: Re: Program won't Compile

We had the same problem recently, with the same error.
Ours was due to somebody (the proverbial somebody) moving a service program
from one binding directory to another.
This was rectified by including the new binding directory in the H specs.

Alan Shore

NBTY, Inc
(631) 244-2000 ext. 5019
AShore <at> NBTY.com

rpg400-l-bounces <at> midrange.com wrote on 12/14/2006 11:15:43 AM:

> I can't figure this one out.  I made a minor programming change to an
RPGLE
> program.  I set up my library list to compile it.  The compile fails.
The
> spool file says:
>
> Errors were found during the binding step. See the job log for more
(Continue reading)

James H H Lampert | 14 Dec 17:58 2006

Re: Program won't Compile

"Weber, Richard" <Weberr@...> wrote:
> Simple program, no binding directory or service 
>programs.

Is there any way the existing *PGM object you're replacing 
(assuming you're replacing one) could be locked? e.g., is 
it a trigger program for some file?

--
JHHL
--

-- 
This is the RPG programming on the AS400 / iSeries (RPG400-L) mailing list
To post a message email: RPG400-L@...
To subscribe, unsubscribe, or change list options,
visit: http://lists.midrange.com/mailman/listinfo/rpg400-l
or email: RPG400-L-request@...
Before posting, please take a moment to review the archives
at http://archive.midrange.com/rpg400-l.

Weber, Richard | 14 Dec 18:03 2006

RE: Program won't Compile

Yes it is a trigger program and it was probably locked.  Like I said in
another reply, it's a shame the messages weren't more helpful.

Rick Weber  |  TOYS 'Я' US International 

-----Original Message-----
From: James H H Lampert [mailto:jamesl <at> hb.quik.com] 
Sent: Thursday, December 14, 2006 11:58 AM
To: RPG programming on the AS400 / iSeries
Subject: Re: Program won't Compile

"Weber, Richard" <Weberr <at> toysrus.com> wrote:
> Simple program, no binding directory or service 
>programs.

Is there any way the existing *PGM object you're replacing 
(assuming you're replacing one) could be locked? e.g., is 
it a trigger program for some file?

--
JHHL
--

-- 

======================================================================== 
This email message is for the sole use of the intended recipient (s) and may
contain confidential and privileged information. Any unauthorized review,
use, disclosure or distribution is prohibited. If you are not the intended
recipient, please contact the sender by reply email and destroy all copies
of the original message. To reply to our email administrator directly, send
an email to EmailAdmin <at> toysrus.com. 
(Continue reading)

James H H Lampert | 14 Dec 19:09 2006

Re: Program won't Compile

"Weber, Richard" <Weberr@...> wrote:
> Yes it is a trigger program and it was probably locked. 

That's the key piece of the puzzle.

Been there, done that, got the t-shirt and cap.

In general, if an attempt to add, remove, or recompile a 
trigger program goes into a *LCKW, it's almost always 
because some other job (or jobs) has an ODP on one or more 
files triggered to the program. The best thing to do at 
that point is a WRKOBJLCK on the *PGM (NOT the *FILE); 
that will locate the offending job(s).

--
JHHL
--

-- 
This is the RPG programming on the AS400 / iSeries (RPG400-L) mailing list
To post a message email: RPG400-L@...
To subscribe, unsubscribe, or change list options,
visit: http://lists.midrange.com/mailman/listinfo/rpg400-l
or email: RPG400-L-request@...
Before posting, please take a moment to review the archives
at http://archive.midrange.com/rpg400-l.

Weber, Richard | 14 Dec 18:18 2006

RE: Program won't Compile

In this case there wasn't an error message in the joblog other than the one
I listed which said to look for other non-existent messages in the joblog.
Had there been, I would have understood what was happening, sooner.

I do appreciate your help, though.  Thank you.

Rick Weber  |  TOYS 'Я' US International 

-----Original Message-----
From: Richard ECUYER [mailto:recuyer <at> fram.fr] 
Sent: Thursday, December 14, 2006 11:36 AM
To: RPG programming on the AS400 / iSeries
Subject: Re: Program won't Compile

When you get a binding error (unable to resole, more than one xxx proceudre
...) the explaination are in the QPJOBLOG not in the listing compil.
----- Original Message ----- 
From: "Weber, Richard" <Weberr <at> toysrus.com>
To: "'RPG programming on the AS400 / iSeries'" <rpg400-l <at> midrange.com>
Sent: Thursday, December 14, 2006 5:15 PM
Subject: Program won't Compile

> I can't figure this one out.  I made a minor programming change to an
RPGLE
> program.  I set up my library list to compile it.  The compile fails.  The
> spool file says:
>
> Errors were found during the binding step. See the job log for more
> information.
>
(Continue reading)


Gmane