Janek S. | 3 Oct 14:44 2012
Picon

Problems installing DPH

Dear list,

I ran into problems when installing DPH examples:

[root <at> GLaDOS : ~] cabal --global install dph-examples
Resolving dependencies...
Configuring dph-examples-0.6.1.3...
Building dph-examples-0.6.1.3...
Preprocessing executable 'dph-spectral-smvm' for dph-examples-0.6.1.3...
[1 of 3] Compiling Vectorised       ( examples/spectral/SMVM/dph/Vectorised.hs, 
dist/build/dph-spectral-smvm/dph-spectral-smvm-tmp/Vectorised.o )
exprType TYPE ghc-prim:GHC.Types.Double{(w) tc 3u}
exprType TYPE ghc-prim:GHC.Types.Double{(w) tc 3u}
exprType TYPE ghc-prim:GHC.Types.Double{(w) tc 3u}
exprType TYPE ghc-prim:GHC.Types.Double{(w) tc 3u}
exprType TYPE ghc-prim:GHC.Types.Double{(w) tc 3u}
exprType
    TYPE (ghc-prim:GHC.Types.Int{(w) tc 3J},
          ghc-prim:GHC.Types.Double{(w) tc 3u})
opt: Bitcode stream should be a multiple of 4 bytes in length
cabal: Error: some packages failed to install:
dph-examples-0.6.1.3 failed during the building phase. The exception was:
ExitFailure 1

Gogling the error message leads to various LLVM pages, which suggests that LLVM is the problem. 
I'm using Debian Squeeze with LLVM 2.6 and I'm thinking that maybe DPH needs newer version. What 
is the minimum required version of LLVM for DPH to work? Or is this problem caused by semthing 
else?

Janek
(Continue reading)

Erik de Castro Lopo | 4 Oct 02:25 2012

Re: Problems installing DPH

Janek S. wrote:

> Gogling the error message leads to various LLVM pages, which suggests that LLVM is the problem. 
> I'm using Debian Squeeze with LLVM 2.6 and I'm thinking that maybe DPH needs newer version.

From memory the first version of LLVM to support the GHC custom calling
convention was llvm-2.7.

Debian Squeeze is also quite old now (ghc-6.12?) and DPH performance has
been improved quite significantly in the 7 series of compilers.

HTH,
Erik
--

-- 
----------------------------------------------------------------------
Erik de Castro Lopo
http://www.mega-nerd.com/

Gmane