Ian | 19 Nov 23:13 2012
Picon
Picon

Reactive-Banana-Wx Install Trouble

Hi Everyone, 


I'm currently trying to install reactive-banana-wx on OSX.

Whenever I try to cabal install it though, I get this error back:

[1 of 1] Compiling Main             ( /var/folders/yy/k1kyw7252q1f_01xv4q5nnj40000gn/T/reactive-banana-wx-0.7.1.0-91555/reactive-banana-wx-0.7.1.0/Setup.hs, /var/folders/yy/k1kyw7252q1f_01xv4q5nnj40000gn/T/reactive-banana-wx-0.7.1.0-91555/reactive-banana-wx-0.7.1.0/dist/setup/Main.o )

/var/folders/yy/k1kyw7252q1f_01xv4q5nnj40000gn/T/reactive-banana-wx-0.7.1.0-91555/reactive-banana-wx-0.7.1.0/Setup.hs:10:22:
    Couldn't match expected type `Distribution.Simple.Setup.BuildFlags'
                with actual type `Cabal-1.16.0.3:Distribution.Simple.Setup.BuildFlags'
    Expected type: Args
                   -> Distribution.Simple.Setup.BuildFlags
                   -> Distribution.PackageDescription.PackageDescription
                   -> Distribution.Simple.LocalBuildInfo.LocalBuildInfo
                   -> IO ()
      Actual type: Cabal-1.16.0.3:Distribution.Simple.UserHooks.Args
                   -> Cabal-1.16.0.3:Distribution.Simple.Setup.BuildFlags
                   -> Cabal-1.16.0.3:Distribution.PackageDescription.PackageDescription
                   -> Cabal-1.16.0.3:Distribution.Simple.LocalBuildInfo.LocalBuildInfo
                   -> IO ()
    In the return type of a call of `appBundleBuildHook'
    In the `postBuild' field of a record
cabal: Error: some packages failed to install:
reactive-banana-wx-0.7.1.0 failed during the configure step. The exception
was:
ExitFailure 1

A couple of things; 

The version of cabal installed is:

cabal-install version 0.14.0
using version 1.14.0 of the Cabal library 

The version of GHC that I'm using is:

The Glorious Glasgow Haskell Compilation System, version 7.4.2

One other thing I should probably note is that I have cabal-macosx installed, but whenever I try to just call it by saying "cabal-macosx" it doesn't work, I have to tunnel down into the actual macosx-app to build any wx stuff. I'm not sure if I'm just using it wrong (I'm quite new to the wx stuff) or if it's a problem with the installation.

Any help on these two (possibly related) problems would be fantastic.

Cheers, 

Ian






_______________________________________________
Haskell-Cafe mailing list
Haskell-Cafe <at> haskell.org
http://www.haskell.org/mailman/listinfo/haskell-cafe
Brandon Allbery | 19 Nov 23:45 2012
Picon

Re: Reactive-Banana-Wx Install Trouble

On Mon, Nov 19, 2012 at 5:13 PM, Ian <fitzpaid <at> tcd.ie> wrote:
    Expected type: Args
                   -> Distribution.Simple.Setup.BuildFlags
                   -> Distribution.PackageDescription.PackageDescription
                   -> Distribution.Simple.LocalBuildInfo.LocalBuildInfo
                   -> IO ()
      Actual type: Cabal-1.16.0.3:Distribution.Simple.UserHooks.Args
                   -> Cabal-1.16.0.3:Distribution.Simple.Setup.BuildFlags
                   -> Cabal-1.16.0.3:Distribution.PackageDescription.PackageDescription
                   -> Cabal-1.16.0.3:Distribution.Simple.LocalBuildInfo.LocalBuildInfo
                   -> IO ()

You have multiple versions of the Cabal library installed and they are conflicting somehow.  Later on you show Cabal-1.14.0 as the one built into cabal-install; make sure you are running the right cabal-install.  (Likely either you don't have $HOME/Library/Haskell/bin on $PATH, or it comes after /usr/bin, or you forgot to "hash -r" in any open shells after installing an updated cabal-install.)

--
brandon s allbery kf8nh                               sine nomine associates
allbery.b <at> gmail.com                                  ballbery <at> sinenomine.net
unix/linux, openafs, kerberos, infrastructure          http://sinenomine.net

_______________________________________________
Haskell-Cafe mailing list
Haskell-Cafe <at> haskell.org
http://www.haskell.org/mailman/listinfo/haskell-cafe

Gmane