Johannes Waldmann | 19 Mar 23:18 2013
Picon

package show needs QuickCheck<2.6?

Hi, I noticed that compilation of mueval (recent: 0.8.2) breaks 
because show (0.5) cannot be built: 
it seems the type of Failure changed in QuickCheck (from 2.5 to 2.6).
The build succeeds with --constraint 'QuickCheck<2.6' .
James Cook | 21 Mar 00:37 2013
Picon

Re: package show needs QuickCheck<2.6?

The mueval build issue should be taken care of in a patch I just sent the maintainer which removes 'show' as a
dependency.  I believe the 'show' package itself is currently in a maintainer-less state, but I don't mind
taking it over.  It makes sense to do so since I am also taking over lambdabot, which used to contain "show" in
the same source tree.

If there are no objections, I'll do so and probably remove the QuickCheck dependency entirely.  It's used in
the "ShowQ" module, which is really a part of lambdabot's "check" plugin and should be moved to lambdabot.

-- James

On Mar 19, 2013, at 3:18 PM, Johannes Waldmann <waldmann <at> imn.htwk-leipzig.de> wrote:

> Hi, I noticed that compilation of mueval (recent: 0.8.2) breaks 
> because show (0.5) cannot be built: 
> it seems the type of Failure changed in QuickCheck (from 2.5 to 2.6).
> The build succeeds with --constraint 'QuickCheck<2.6' .
> 
> 
> 
> _______________________________________________
> Haskell-Cafe mailing list
> Haskell-Cafe <at> haskell.org
> http://www.haskell.org/mailman/listinfo/haskell-cafe
> 

Gmane