Jacques Carette | 18 Jun 19:57 2013
Picon
Picon

Strange cabal failure

In trying to install the lens package, it eventually tries to install 
transformers-compat-0.1.1.1 which in turn depends on 
transformers-0.3.0.0 -- however that asksk for
transformers-0.3.0.0-3006d6ea13a2c10770bffd4de7a96dc9
which 1) is weird, and 2) doesn't exist!'

What gives?

Jacques
Brandon Allbery | 18 Jun 20:52 2013
Picon

Re: Strange cabal failure

On Tue, Jun 18, 2013 at 1:57 PM, Jacques Carette <carette <at> mcmaster.ca> wrote:
In trying to install the lens package, it eventually tries to install transformers-compat-0.1.1.1 which in turn depends on transformers-0.3.0.0 -- however that asksk for
transformers-0.3.0.0-3006d6ea13a2c10770bffd4de7a96dc9
which 1) is weird, and 2) doesn't exist!'

What gives?

The large blob at the end is an ABI hash which is computed when you install a package. So it would appear that you had transformers-0.3.0.0 installed and then removed it, but it's still indexed for some reason.

--
brandon s allbery kf8nh                               sine nomine associates
allbery.b <at> gmail.com                                  ballbery <at> sinenomine.net
unix, openafs, kerberos, infrastructure, xmonad        http://sinenomine.net
_______________________________________________
Haskell-Cafe mailing list
Haskell-Cafe <at> haskell.org
http://www.haskell.org/mailman/listinfo/haskell-cafe

Gmane