Thomas Hallgren | 7 Aug 14:32 2013
Picon
Picon

Hackage upload problem

Hi,

I get the following error when I try to upload gf-3.5.tar.gz [1] to Hackage.

	400 Error in upload
        could not extract gf-3.5 directory from gf-3.5.tar.gz

I get the same error when I try to Check the previous version, gf-3.4.tar.gz
[2], which was uploaded without problems 6 months ago [3], so it seems that
something has changed on the server.

Does anyone know what it could be that is going wrong? Is there a way to get a
more informative error message?

Thomas H

[1] http://www.grammaticalframework.org/download/gf-3.5.tar.gz
[2] http://www.grammaticalframework.org/download/gf-3.4.tar.gz
[3] http://hackage.haskell.org/package/gf-3.4
Duncan Coutts | 7 Aug 17:06 2013

Re: Hackage upload problem

On Wed, 2013-08-07 at 14:32 +0200, Thomas Hallgren wrote:
> Hi,
> 
> I get the following error when I try to upload gf-3.5.tar.gz [1] to Hackage.
> 
> 	400 Error in upload
>         could not extract gf-3.5 directory from gf-3.5.tar.gz
> 
> 
> I get the same error when I try to Check the previous version, gf-3.4.tar.gz
> [2], which was uploaded without problems 6 months ago [3], so it seems that
> something has changed on the server.
> 
> Does anyone know what it could be that is going wrong? Is there a way to get a
> more informative error message?

You're welcome to try uploading it to the new-hackage.haskell.org and
see if that gives a more informative error message. If it's a poor error
message there then we can fix that.

Duncan
Thomas Hallgren | 7 Aug 18:35 2013
Picon
Picon

Re: Hackage upload problem

On 2013-08-07 17:06 , Duncan Coutts wrote:
> On Wed, 2013-08-07 at 14:32 +0200, Thomas Hallgren wrote:
>> Hi,
>>
>> I get the following error when I try to upload gf-3.5.tar.gz [1] to Hackage.
>>
>> 	400 Error in upload
>>         could not extract gf-3.5 directory from gf-3.5.tar.gz
>>
>>
>> I get the same error when I try to Check the previous version, gf-3.4.tar.gz
>> [2], which was uploaded without problems 6 months ago [3], so it seems that
>> something has changed on the server.
>>
>> Does anyone know what it could be that is going wrong? Is there a way to get a
>> more informative error message?
> 
> You're welcome to try uploading it to the new-hackage.haskell.org and
> see if that gives a more informative error message. If it's a poor error
> message there then we can fix that.
> 
> Duncan
> 

new-hackage.haskell.org didn't work either, it says:

    Reached disk quota of 1000000 bytes.

gf-3.5.tar.gz is a lot bigger than 1000000 bytes. I am guessing this restriction
only applies on new-hackage, and that there is a different problem on old hackage...
(Continue reading)

Jason Dagit | 12 Aug 07:59 2013
Picon

Fwd: [Haskell-cafe] Hackage upload problem

I noticed this on Haskell-Cafe.

Sounds like new-hackage might have some quota issues and possibly
hackage has the same policy or a different error.

Thanks in adavance,
Jason

---------- Forwarded message ----------
From: Thomas Hallgren <hallgren@...>
Date: Wed, Aug 7, 2013 at 9:35 AM
Subject: Re: [Haskell-cafe] Hackage upload problem
To: haskell-cafe@...

On 2013-08-07 17:06 , Duncan Coutts wrote:
> On Wed, 2013-08-07 at 14:32 +0200, Thomas Hallgren wrote:
>> Hi,
>>
>> I get the following error when I try to upload gf-3.5.tar.gz [1] to Hackage.
>>
>>      400 Error in upload
>>         could not extract gf-3.5 directory from gf-3.5.tar.gz
>>
>>
>> I get the same error when I try to Check the previous version, gf-3.4.tar.gz
>> [2], which was uploaded without problems 6 months ago [3], so it seems that
>> something has changed on the server.
>>
>> Does anyone know what it could be that is going wrong? Is there a way to get a
>> more informative error message?
(Continue reading)

Thomas Hallgren | 13 Aug 14:14 2013
Picon
Picon

Fwd: Hackage upload problem

Hi,

I tried uploading gf-3.5 again today and this problem persists. Since this also
affects the gf-3.4 package that has previously been uploaded successfully, it
seems like a server-side regression.

It is not nice to have outdated information on Hackage, so any help resolving
this problem would be appreciated.

Thomas Hallgren
Picon Picon
From: Thomas Hallgren <hallgren@...>
Subject: Hackage upload problem
Newsgroups: gmane.comp.lang.haskell.cafe
Date: 2013-08-07 12:32:38 GMT
Hi,

I get the following error when I try to upload gf-3.5.tar.gz [1] to Hackage.

	400 Error in upload
        could not extract gf-3.5 directory from gf-3.5.tar.gz

I get the same error when I try to Check the previous version, gf-3.4.tar.gz
(Continue reading)


Gmane