Henning Thielemann | 21 Aug 08:57 2013
Picon

GHC and backwards compatibility

If you use

$ cabal install --constraint="array installed"

then cabal-install is forced to use the installed version of array. If a 
package conflicts with this version, then it will report the conflicting 
packages.

Gmane