Mateusz Kowalczyk | 29 Aug 06:08 2013
Picon

Building recent Cabal/cabal-install

Greetings café,

There are some problems in Haddock to do with Template Haskell that I
believe are being caused by Cabal. These were apparently addressed in
1.18 which came out recently. ‘Great!’, I thought.

My problem is that I'm unsure how to use 1.18. I'm using GHC HEAD (well,
3 days old now) which is meant to come with Cabal 1.18 (the library) and
in fact it seems to ship with it. Running ‘cabal --version’ however:

> cabal-install version 1.17.0
> using version 1.17.0 of the Cabal library

I'm unsure how to get it to use 1.18. I tried to build cabal-install
from git but that just complains about dependencies not being possible
to resolve: it depends on HTTP which depends on base <4.7 but 4.7 comes
with GHC HEAD!

I am baffled as to how I should go about using 1.18 and would love to
hear from some people who have this up and running.
--

-- 
Mateusz K.
Johan Tibell | 29 Aug 16:22 2013
Picon

Re: [Haskell-cafe] Building recent Cabal/cabal-install

Hi,

Cabal 1.18 is still in the release candidate stage so it has in fact not been released yet. We could either bump the dependency on base to <4.8 before the 1.8 release or we could make a Cabal-1.8.0.1 release together with the GHC release that bumps the dependency.

-- Johan


On Wed, Aug 28, 2013 at 9:08 PM, Mateusz Kowalczyk <fuuzetsu-OrALX9hehsC9FHfhHBbuYA@public.gmane.org> wrote:
Greetings café,

There are some problems in Haddock to do with Template Haskell that I
believe are being caused by Cabal. These were apparently addressed in
1.18 which came out recently. ‘Great!’, I thought.

My problem is that I'm unsure how to use 1.18. I'm using GHC HEAD (well,
3 days old now) which is meant to come with Cabal 1.18 (the library) and
in fact it seems to ship with it. Running ‘cabal --version’ however:

> cabal-install version 1.17.0
> using version 1.17.0 of the Cabal library

I'm unsure how to get it to use 1.18. I tried to build cabal-install
from git but that just complains about dependencies not being possible
to resolve: it depends on HTTP which depends on base <4.7 but 4.7 comes
with GHC HEAD!

I am baffled as to how I should go about using 1.18 and would love to
hear from some people who have this up and running.
--
Mateusz K.

_______________________________________________
Haskell-Cafe mailing list
Haskell-Cafe <at> haskell.org
http://www.haskell.org/mailman/listinfo/haskell-cafe

_______________________________________________
ghc-devs mailing list
ghc-devs@...
http://www.haskell.org/mailman/listinfo/ghc-devs

Gmane