Kazu Yamamoto | 6 Sep 07:29 2013
Picon

ghc-mod v3.0.0

Hi all,

I have just uploaded ghc-mod v3.0.0 to Hackage. In this version,
ghc-mod supports the sandbox feature of "cabal-install". Instead, it
stopped supporting "cabal-dev".

If you want to use ghc-mod v3.0.0, I would recommand to install
cabal-install 1.18. The sandbox in your package is automatically
detected by ghc-mod if exists.

--Kazu
AlanKim Zimmerman | 6 Sep 09:16 2013
Picon

Re: ghc-mod v3.0.0

Is this backward compatible with older versions of Cabal? I am considering whether to migrate HaRe to use this, I would prefer not to have it then fail to work on older systems that are constrained not to be able to update Cabal.

Alan


On Fri, Sep 6, 2013 at 7:29 AM, Kazu Yamamoto <kazu <at> iij.ad.jp> wrote:
Hi all,

I have just uploaded ghc-mod v3.0.0 to Hackage. In this version,
ghc-mod supports the sandbox feature of "cabal-install". Instead, it
stopped supporting "cabal-dev".

If you want to use ghc-mod v3.0.0, I would recommand to install
cabal-install 1.18. The sandbox in your package is automatically
detected by ghc-mod if exists.

--Kazu

_______________________________________________
Haskell-Cafe mailing list
Haskell-Cafe <at> haskell.org
http://www.haskell.org/mailman/listinfo/haskell-cafe

_______________________________________________
Haskell-Cafe mailing list
Haskell-Cafe <at> haskell.org
http://www.haskell.org/mailman/listinfo/haskell-cafe
Kazu Yamamoto | 6 Sep 09:52 2013
Picon

Re: ghc-mod v3.0.0

Alan,

> Is this backward compatible with older versions of Cabal? I am considering
> whether to migrate HaRe to use this, I would prefer not to have it then
> fail to work on older systems that are constrained not to be able to update
> Cabal.

The sandbox is a feature of cabal-install, not Cabal lib.

I carefully implemented this version not using Cabal 1.18.

--Kazu
AlanKim Zimmerman | 6 Sep 09:53 2013
Picon

Re: ghc-mod v3.0.0

Ok, thanks.


On Fri, Sep 6, 2013 at 9:52 AM, Kazu Yamamoto <kazu <at> iij.ad.jp> wrote:
Alan,

> Is this backward compatible with older versions of Cabal? I am considering
> whether to migrate HaRe to use this, I would prefer not to have it then
> fail to work on older systems that are constrained not to be able to update
> Cabal.

The sandbox is a feature of cabal-install, not Cabal lib.

I carefully implemented this version not using Cabal 1.18.

--Kazu

_______________________________________________
Haskell-Cafe mailing list
Haskell-Cafe <at> haskell.org
http://www.haskell.org/mailman/listinfo/haskell-cafe

Gmane