Magicloud Magiclouds | 10 Feb 11:35 2013
Picon

I cannot compile ghc-7.6.2

Hi,
  Linuxmint Nadia, ghc-7.6.1 was built and running OK.
  Just downloaded ghc-7.6.2, without changing anything and environment, and boot and configure returned OK, I got these. What happened?

20130210Sun183147magicloud <at> ctu-9986008283~/s/ghc-7.6.2
$ make
+ test -f mk/config.mk.old
+ cp -p mk/config.mk mk/config.mk.old
touch -r mk/config.mk.old mk/config.mk
+ test -f mk/project.mk.old
+ cp -p mk/project.mk mk/project.mk.old
touch -r mk/project.mk.old mk/project.mk
+ test -f compiler/ghc.cabal.old
+ cp -p compiler/ghc.cabal compiler/ghc.cabal.old
touch -r compiler/ghc.cabal.old compiler/ghc.cabal
===--- building phase 0
make -r --no-print-directory -f ghc.mk phase=0 phase_0_builds
libraries/hpc/ghc.mk:3: libraries/hpc/dist-boot/package-data.mk: No such file or directory
libraries/Cabal/Cabal/ghc.mk:3: libraries/Cabal/Cabal/dist-boot/package-data.mk: No such file or directory
libraries/binary/ghc.mk:3: libraries/binary/dist-boot/package-data.mk: No such file or directory
libraries/bin-package-db/ghc.mk:3: libraries/bin-package-db/dist-boot/package-data.mk: No such file or directory
libraries/hoopl/ghc.mk:3: libraries/hoopl/dist-boot/package-data.mk: No such file or directory
compiler/ghc.mk:450: compiler/stage1/package-data.mk: No such file or directory
utils/hsc2hs/ghc.mk:14: utils/hsc2hs/dist/package-data.mk: No such file or directory
ghc/ghc.mk:106: ghc/stage1/package-data.mk: No such file or directory
mkdir inplace
mkdir inplace/bin
"rm" -f utils/ghc-pkg/Version.hs
mkdir inplace/lib
echo "module Version where"                    >> utils/ghc-pkg/Version.hs
"rm" -f inplace/bin/mkdirhier
echo "version, targetOS, targetARCH :: String" >> utils/ghc-pkg/Version.hs
echo "version    = \"7.6.2\""      >> utils/ghc-pkg/Version.hs
echo '#!/bin/sh'                 >> inplace/bin/mkdirhier
echo "targetOS   = \"linux\""        >> utils/ghc-pkg/Version.hs
cat utils/mkdirhier/mkdirhier.sh >> inplace/bin/mkdirhier
echo "targetARCH = \"x86_64\""      >> utils/ghc-pkg/Version.hs
chmod +x inplace/bin/mkdirhier
"inplace/bin/mkdirhier" utils/ghc-cabal/dist/build/tmp//.
"inplace/bin/mkdirhier" bootstrapping/.
"inplace/bin/mkdirhier" inplace/bin//.
"inplace/bin/mkdirhier" compiler/stage1/build//.
"inplace/bin/mkdirhier" utils/ghc-pkg/dist/build/tmp//.
"inplace/bin/mkdirhier" inplace/lib/package.conf.d/.
"/usr/local/bin/ghc" -H32m -O --make utils/ghc-cabal/Main.hs -o utils/ghc-cabal/dist/build/tmp/ghc-cabal \
               -no-user-package-db \
               -Wall \
               -DCABAL_VERSION=1,16,0 \
               -odir  bootstrapping \
               -hidir bootstrapping \
               -ilibraries/Cabal/Cabal \
               -ilibraries/filepath \
               -ilibraries/hpc \

"rm" -f compiler/stage1/build/Config.hs
Creating compiler/stage1/build/Config.hs ...
done.

libraries/Cabal/Cabal/Distribution/ParseUtils.hs:88:18:
    Could not find module `Data.Map'
    It is a member of the hidden package `containers-0.5.0.0'.
    Use -v to see a list of the files searched for.
make[1]: *** [utils/ghc-cabal/dist/build/tmp/ghc-cabal] Error 1
make: *** [all] Error 2

--
竹密岂妨流水过
山高哪阻野云飞

And for G+, please use magiclouds#gmail.com.
_______________________________________________
Glasgow-haskell-users mailing list
Glasgow-haskell-users <at> haskell.org
http://www.haskell.org/mailman/listinfo/glasgow-haskell-users
Ian Lynagh | 11 Feb 22:29 2013

Re: I cannot compile ghc-7.6.2

On Sun, Feb 10, 2013 at 06:35:25PM +0800, Magicloud Magiclouds wrote:
>
>   Linuxmint Nadia, ghc-7.6.1 was built and running OK.
>   Just downloaded ghc-7.6.2, without changing anything and environment, and
> boot and configure returned OK, I got these. What happened?
> 
> "/usr/local/bin/ghc" -H32m -O --make utils/ghc-cabal/Main.hs -o
> utils/ghc-cabal/dist/build/tmp/ghc-cabal \
>                -no-user-package-db \
>                -Wall \
>                -DCABAL_VERSION=1,16,0 \
>                -odir  bootstrapping \
>                -hidir bootstrapping \
>                -ilibraries/Cabal/Cabal \
>                -ilibraries/filepath \
>                -ilibraries/hpc \
> 
> "rm" -f compiler/stage1/build/Config.hs
> Creating compiler/stage1/build/Config.hs ...
> done.
> 
> libraries/Cabal/Cabal/Distribution/ParseUtils.hs:88:18:
>     Could not find module `Data.Map'
>     It is a member of the hidden package `containers-0.5.0.0'.
>     Use -v to see a list of the files searched for.
> make[1]: *** [utils/ghc-cabal/dist/build/tmp/ghc-cabal] Error 1
> make: *** [all] Error 2

It looks like there is a problem with your bootstrapping compiler,
possibly caused by having more than one copy of containers installed.
"ghc-pkg check" or "ghc-pkg list" might help.

Thanks
Ian
Magicloud Magiclouds | 12 Feb 17:30 2013
Picon

Re: I cannot compile ghc-7.6.2

Thank you.
I thought the "no such file" lines were the problem. In fact my global container was hidden some how.


On Tue, Feb 12, 2013 at 5:29 AM, Ian Lynagh <ian <at> well-typed.com> wrote:
On Sun, Feb 10, 2013 at 06:35:25PM +0800, Magicloud Magiclouds wrote:
>
>   Linuxmint Nadia, ghc-7.6.1 was built and running OK.
>   Just downloaded ghc-7.6.2, without changing anything and environment, and
> boot and configure returned OK, I got these. What happened?
>
> "/usr/local/bin/ghc" -H32m -O --make utils/ghc-cabal/Main.hs -o
> utils/ghc-cabal/dist/build/tmp/ghc-cabal \
>                -no-user-package-db \
>                -Wall \
>                -DCABAL_VERSION=1,16,0 \
>                -odir  bootstrapping \
>                -hidir bootstrapping \
>                -ilibraries/Cabal/Cabal \
>                -ilibraries/filepath \
>                -ilibraries/hpc \
>
> "rm" -f compiler/stage1/build/Config.hs
> Creating compiler/stage1/build/Config.hs ...
> done.
>
> libraries/Cabal/Cabal/Distribution/ParseUtils.hs:88:18:
>     Could not find module `Data.Map'
>     It is a member of the hidden package `containers-0.5.0.0'.
>     Use -v to see a list of the files searched for.
> make[1]: *** [utils/ghc-cabal/dist/build/tmp/ghc-cabal] Error 1
> make: *** [all] Error 2

It looks like there is a problem with your bootstrapping compiler,
possibly caused by having more than one copy of containers installed.
"ghc-pkg check" or "ghc-pkg list" might help.


Thanks
Ian




--
竹密岂妨流水过
山高哪阻野云飞

And for G+, please use magiclouds#gmail.com.
_______________________________________________
Glasgow-haskell-users mailing list
Glasgow-haskell-users <at> haskell.org
http://www.haskell.org/mailman/listinfo/glasgow-haskell-users

Gmane