Mark Lentczner | 11 May 19:55 2013
Picon

HP 2013.2 home stretch, RC2 installers

We are in the home stretch for Haskell Platform 2013.2!

The Mac OS X RC2 installers are up:

Only real difference in these from RC1 is packaging: the Cabal doc is now included. There is no update to source tarball RC1, which is still there too. I expect these to be renamed the official release within a week.

Packagers: Please produce Release Candidates. The package version list shouldn't change, unless any of you find an issue.

- Mark

_______________________________________________
Libraries mailing list
Libraries <at> haskell.org
http://www.haskell.org/mailman/listinfo/libraries
George Colpitts | 15 May 02:41 2013
Picon

Re: HP 2013.2 home stretch, RC2 installers

64 bit OS X installer worked great for me. 

Mac OS 10.8.3
 gcc -version
i686-apple-darwin11-llvm-gcc-4.2:

Also with the previous 2012 HP, despite uninstalling and reinstalling I was unable to install criterion, threadscope and Simon Marlow's code (parconc...) for his forthcoming book. With HP 2013 I was able to compile those plus hlint, pandoc, ghc-mod, diagrams, hakyll etc.

I assume the ghc-pkg check warnings below about haddock for the platform are not important.

 ghc-pkg check
Warning: haddock-interfaces: /Users/gcolpitts/Library/Haskell/ghc-7.6.3/lib/diagrams-0.6/doc/html/diagrams.haddock doesn't exist or isn't a file
Warning: haddock-interfaces: /Library/Haskell/ghc-7.6.3/lib/random-1.0.1.1/doc/html/random.haddock doesn't exist or isn't a file
Warning: haddock-interfaces: /Library/Haskell/ghc-7.6.3/lib/primitive-0.5.0.1/doc/html/primitive.haddock doesn't exist or isn't a file
Warning: haddock-interfaces: /Library/Haskell/ghc-7.6.3/lib/network-2.4.1.2/doc/html/network.haddock doesn't exist or isn't a file
Warning: haddock-interfaces: /Library/Haskell/ghc-7.6.3/lib/haskell-platform-2013.2.0.0/doc/html/haskell-platform.haddock doesn't exist or isn't a file
Warning: haddock-html: /Library/Haskell/ghc-7.6.3/lib/haskell-platform-2013.2.0.0/doc/html doesn't exist or isn't a directory

Thanks
George

On Sat, May 11, 2013 at 1:55 PM, Mark Lentczner <mark.lentczner-Re5JQEeQqe8AvxtiuMwx3w@public.gmane.org> wrote:
We are in the home stretch for Haskell Platform 2013.2!

The Mac OS X RC2 installers are up:

Only real difference in these from RC1 is packaging: the Cabal doc is now included. There is no update to source tarball RC1, which is still there too. I expect these to be renamed the official release within a week.

Packagers: Please produce Release Candidates. The package version list shouldn't change, unless any of you find an issue.

- Mark


_______________________________________________
Haskell-platform mailing list
Haskell-platform <at> projects.haskell.org
http://projects.haskell.org/cgi-bin/mailman/listinfo/haskell-platform


_______________________________________________
Haskell-platform mailing list
Haskell-platform@...
http://projects.haskell.org/cgi-bin/mailman/listinfo/haskell-platform
Mark Lentczner | 15 May 17:03 2013
Picon

Re: HP 2013.2 home stretch, RC2 installers

Thanks for the report.

Oh! That's a bug - though not a huge one.... It means that doc didn't generate for the packages random, primitive, and network.

Looking into this (I have the build logs), they are all failures in finding #include files when Haddock is compiling the sources with GHC. Haven't found why those three cases are different from all the other projects haddock processed where the source uses #include....

I'm not worried that haskell-platform.haddock doesn't exist - it doesn't have any doc.
But I'm not sure what the next missing message is about.

Looking into this, and it might mean an RC3 for Mac OS X. It won't mean a turn for the source installers, or Windows. And the only difference for Mac will be the extra source.

— Mark



On Tue, May 14, 2013 at 5:41 PM, George Colpitts <george.colpitts <at> gmail.com> wrote:
64 bit OS X installer worked great for me. 

Mac OS 10.8.3
 gcc -version
i686-apple-darwin11-llvm-gcc-4.2:

Also with the previous 2012 HP, despite uninstalling and reinstalling I was unable to install criterion, threadscope and Simon Marlow's code (parconc...) for his forthcoming book. With HP 2013 I was able to compile those plus hlint, pandoc, ghc-mod, diagrams, hakyll etc.

I assume the ghc-pkg check warnings below about haddock for the platform are not important.

 ghc-pkg check
Warning: haddock-interfaces: /Users/gcolpitts/Library/Haskell/ghc-7.6.3/lib/diagrams-0.6/doc/html/diagrams.haddock doesn't exist or isn't a file
Warning: haddock-interfaces: /Library/Haskell/ghc-7.6.3/lib/random-1.0.1.1/doc/html/random.haddock doesn't exist or isn't a file
Warning: haddock-interfaces: /Library/Haskell/ghc-7.6.3/lib/primitive-0.5.0.1/doc/html/primitive.haddock doesn't exist or isn't a file
Warning: haddock-interfaces: /Library/Haskell/ghc-7.6.3/lib/network-2.4.1.2/doc/html/network.haddock doesn't exist or isn't a file
Warning: haddock-interfaces: /Library/Haskell/ghc-7.6.3/lib/haskell-platform-2013.2.0.0/doc/html/haskell-platform.haddock doesn't exist or isn't a file
Warning: haddock-html: /Library/Haskell/ghc-7.6.3/lib/haskell-platform-2013.2.0.0/doc/html doesn't exist or isn't a directory

Thanks
George

On Sat, May 11, 2013 at 1:55 PM, Mark Lentczner <mark.lentczner <at> gmail.com> wrote:
We are in the home stretch for Haskell Platform 2013.2!

The Mac OS X RC2 installers are up:

Only real difference in these from RC1 is packaging: the Cabal doc is now included. There is no update to source tarball RC1, which is still there too. I expect these to be renamed the official release within a week.

Packagers: Please produce Release Candidates. The package version list shouldn't change, unless any of you find an issue.

- Mark


_______________________________________________
Haskell-platform mailing list
Haskell-platform <at> projects.haskell.org
http://projects.haskell.org/cgi-bin/mailman/listinfo/haskell-platform



_______________________________________________
Libraries mailing list
Libraries <at> haskell.org
http://www.haskell.org/mailman/listinfo/libraries
Peter Simons | 12 May 15:35 2013
Picon

Re: HP 2013.2 home stretch, RC2 installers

Hi,

 > Packagers: Please produce Release Candidates. The package version list
 > shouldn't change, unless any of you find an issue.

I'm not sure how important this issue is, but the test suite for
unordered-containers-0.2.3.0 cannot be compiled within the platform,
because the ChasingBottoms library doesn't accept QuickCheck-2.6 as a
build input.

Also, I wonder we don't use unordered-containers-0.2.3.1?

Similarly, I wonder why we use case-insensitive-1.0.0.1 instead of
1.0.0.2?

Take care,
Peter
Mikhail Glushenkov | 13 May 23:09 2013
Picon

Re: HP 2013.2 home stretch, RC2 installers

Hi,

On Sun, May 12, 2013 at 3:35 PM, Peter Simons <simons@...> wrote:
> I'm not sure how important this issue is, but the test suite for
> unordered-containers-0.2.3.0 cannot be compiled within the platform,
> because the ChasingBottoms library doesn't accept QuickCheck-2.6 as a
> build input.

There is a new version of ChasingBottoms out now that fixes this.

--

-- 
()  ascii ribbon campaign - against html e-mail
/\  www.asciiribbon.org   - against proprietary attachments
Mark Lentczner | 14 May 00:10 2013
Picon

Re: HP 2013.2 home stretch, RC2 installers

We use unordered-containers-0.2.3.0 and case-insensitive-1.0.0.1 because those are the versions the maintainers of those packages told the platform to use.

I note that both updated versions you mention are newer than the point at which we called for version numbers from the maintainers. I don't automatically bump, because it often leads to last minute insanity!

- Mark


On Mon, May 13, 2013 at 2:09 PM, Mikhail Glushenkov <the.dead.shall.rise-Re5JQEeQqe8AvxtiuMwx3w@public.gmane.org> wrote:
Hi,

On Sun, May 12, 2013 at 3:35 PM, Peter Simons <simons-1y1sJ47scdg@public.gmane.org> wrote:
> I'm not sure how important this issue is, but the test suite for
> unordered-containers-0.2.3.0 cannot be compiled within the platform,
> because the ChasingBottoms library doesn't accept QuickCheck-2.6 as a
> build input.

There is a new version of ChasingBottoms out now that fixes this.

--
()  ascii ribbon campaign - against html e-mail
/\  www.asciiribbon.org   - against proprietary attachments

_______________________________________________
Haskell-platform mailing list
Haskell-platform <at> projects.haskell.org
http://projects.haskell.org/cgi-bin/mailman/listinfo/haskell-platform

_______________________________________________
Haskell-platform mailing list
Haskell-platform@...
http://projects.haskell.org/cgi-bin/mailman/listinfo/haskell-platform
Peter Simons | 14 May 21:49 2013
Picon

Re: HP 2013.2 home stretch, RC2 installers

Hi Mikhail,

 > On Sun, May 12, 2013 at 3:35 PM, Peter Simons <simons@...> wrote:
 >> I'm not sure how important this issue is, but the test suite for
 >> unordered-containers-0.2.3.0 cannot be compiled within the platform,
 >> because the ChasingBottoms library doesn't accept QuickCheck-2.6 as a
 >> build input.
 >
 > There is a new version of ChasingBottoms out now that fixes this.

yeah, I contacted Nils and asked him to please release that update. He
responded super quickly!

Take care,
Peter

Gmane