Re: doesFileExist and doesDirectoryExist overly verbose?
Erik Hesselink <hesselink <at> gmail.com>
2013-06-05 13:06:20 GMT
Those names suggest checks to see if something is a file or directory,
not existence checks.
Regarding the original question: I don't think this should be changed,
because the current names aren't that bad, and changing them would
break a lot of code.
On Wed, Jun 5, 2013 at 2:49 PM, Michael Snoyman <michael <at> snoyman.com> wrote:
> I'm personally quite fond of system-fileio's naming scheme: isFile and
> isDirectory. Actually, I generally find system-fileio and system-filepath to
> be a great set of libraries for most file operations.
> On Wed, Jun 5, 2013 at 3:41 PM, harry <voldermort <at> hotmail.com> wrote:
>> doesFileExist and doesDirectoryExist seem overly verbose - wouldn't
>> fileExists and directoryExists be better?
>> Not a major issue, but easily fixed.
>> View this message in context:
>> Sent from the Haskell - Libraries mailing list archive at Nabble.com.
>> Libraries mailing list
>> Libraries <at> haskell.org
> Libraries mailing list
> Libraries <at> haskell.org