Xiaofan Chen | 6 May 02:31 2012
Picon

libusb-compat auto-tools warnings

I am using automake 1.12 and autoconf 2.69 and there
are quite some warnings for libusb-compat. Not so sure
how to fix them though since I know very little of
auto-tools.

mymacmini:libusb-compat-0.1 xiaofanc$ ./autogen.sh
glibtoolize: putting auxiliary files in `.'.
glibtoolize: copying file `./ltmain.sh'
glibtoolize: putting macros in AC_CONFIG_MACRO_DIR, `m4'.
glibtoolize: copying file `m4/libtool.m4'
glibtoolize: copying file `m4/ltoptions.m4'
glibtoolize: copying file `m4/ltsugar.m4'
glibtoolize: copying file `m4/ltversion.m4'
glibtoolize: copying file `m4/lt~obsolete.m4'
/usr/local/share/aclocal/log4shib.m4:7: warning: underquoted
definition of AM_PATH_LOG4SHIB
/usr/local/share/aclocal/log4shib.m4:7:   run info Automake 'Extending aclocal'
/usr/local/share/aclocal/log4shib.m4:7:   or see
http://www.gnu.org/software/automake/manual/automake.html#Extending-aclocal
configure.ac:55: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call
detected in body
../../lib/autoconf/lang.m4:197: AC_LANG_CONFTEST is expanded from...
../../lib/autoconf/general.m4:2598: _AC_COMPILE_IFELSE is expanded from...
../../lib/autoconf/general.m4:2608: AC_COMPILE_IFELSE is expanded from...
configure.ac:55: the top level
configure.ac:55: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call
detected in body
../../lib/autoconf/lang.m4:197: AC_LANG_CONFTEST is expanded from...
../../lib/autoconf/general.m4:2598: _AC_COMPILE_IFELSE is expanded from...
../../lib/autoconf/general.m4:2608: AC_COMPILE_IFELSE is expanded from...
(Continue reading)

Xiaofan Chen | 6 May 02:34 2012
Picon

Re: libusb-compat auto-tools warnings

On Sun, May 6, 2012 at 8:31 AM, Xiaofan Chen <xiaofanc <at> gmail.com> wrote:
> I am using automake 1.12 and autoconf 2.69 and there
> are quite some warnings for libusb-compat. Not so sure
> how to fix them though since I know very little of
> auto-tools.

Just for comparison, libusb.git is much better under the
same setup (Mac OS X 10.7.3).

mymacmini:libusb xiaofanc$ ./autogen.sh
glibtoolize: putting auxiliary files in `.'.
glibtoolize: copying file `./ltmain.sh'
glibtoolize: putting macros in AC_CONFIG_MACRO_DIR, `m4'.
glibtoolize: copying file `m4/libtool.m4'
glibtoolize: copying file `m4/ltoptions.m4'
glibtoolize: copying file `m4/ltsugar.m4'
glibtoolize: copying file `m4/ltversion.m4'
glibtoolize: copying file `m4/lt~obsolete.m4'
/usr/local/share/aclocal/log4shib.m4:7: warning: underquoted
definition of AM_PATH_LOG4SHIB
/usr/local/share/aclocal/log4shib.m4:7:   run info Automake 'Extending aclocal'
/usr/local/share/aclocal/log4shib.m4:7:   or see
http://www.gnu.org/software/automake/manual/automake.html#Extending-aclocal
checking for a BSD-compatible install... /usr/local/bin/ginstall -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /usr/local/bin/gmkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... yes
checking whether make supports nested variables... yes
(Continue reading)

Ludovic Rousseau | 6 May 09:51 2012
Picon

Re: libusb-compat auto-tools warnings

2012/5/6 Xiaofan Chen <xiaofanc <at> gmail.com>:
> I am using automake 1.12 and autoconf 2.69 and there
> are quite some warnings for libusb-compat. Not so sure
> how to fix them though since I know very little of
> auto-tools.
>
> mymacmini:libusb-compat-0.1 xiaofanc$ ./autogen.sh
> glibtoolize: putting auxiliary files in `.'.
> glibtoolize: copying file `./ltmain.sh'
> glibtoolize: putting macros in AC_CONFIG_MACRO_DIR, `m4'.
> glibtoolize: copying file `m4/libtool.m4'
> glibtoolize: copying file `m4/ltoptions.m4'
> glibtoolize: copying file `m4/ltsugar.m4'
> glibtoolize: copying file `m4/ltversion.m4'
> glibtoolize: copying file `m4/lt~obsolete.m4'
> /usr/local/share/aclocal/log4shib.m4:7: warning: underquoted
> definition of AM_PATH_LOG4SHIB
> /usr/local/share/aclocal/log4shib.m4:7:   run info Automake 'Extending aclocal'
> /usr/local/share/aclocal/log4shib.m4:7:   or see
> http://www.gnu.org/software/automake/manual/automake.html#Extending-aclocal
> configure.ac:55: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call
> detected in body

It is a common warning with autoconf 2.68 (and later)

See http://www.flameeyes.eu/autotools-mythbuster/forwardporting/autoconf.html

Bye

--

-- 
(Continue reading)


Gmane