Jenaro Centeno Gómez | 22 Dec 18:48 2006
Picon

Re: Proxy error

"Even faster falls a than a blind one"

And a few minutes after I send the message the server began to stop 
responding, I checked at the runing processes with top and there it was, 
squi-graph with 96% of memory used, proxy service down. So, I made the 
changes suggested by William, then I restared the server and bingo, 
problem solved.

I've been checking with top, the squid-graph still gets 96% of memory, 
but after it does this, the process goes down to 0%.

This is the content of messages log:
---------------------------------------------------------------------------------------------------------------------------------------------------------------------
Dec 22 11:35:00 ipcop fcron[532]: Job /usr/local/bin/timecheck > 
/dev/null 2>&1 started for user root (pid 535)
Dec 22 11:35:00 ipcop fcron[533]: Job /usr/local/bin/makegraphs 
 >/dev/null started for user root (pid 536)
Dec 22 11:35:00 ipcop fcron[534]: Job [ -f "/var/ipcop/red/active" ] && 
/usr/local/bin/setddns.pl started for user root (pid 538)
Dec 22 11:35:06 ipcop kernel: INPUT IN=eth1 OUT= 
MAC=xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xxSRC=xx.xx.xx.xxDST=x.x.x.x 
LEN=393 TOS=0x00 PREC=0x00 TTL=48 ID=21750 PROTO=UDP SPT=30552 DPT=1026 
LEN=373
Dec 22 11:35:25 ipcop kernel: __alloc_pages: 0-order allocation failed 
(gfp=0x1d2/0)
Dec 22 11:35:25 ipcop kernel: VM: killing process squid-graph
Dec 22 11:36:38 ipcop kernel: NEW not SYN? IN=eth0 OUT= 
MAC=xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xxSRC=xx.xx.xx.xxDST=x.x.x.x  
LEN=40 TOS=0x00 PREC=0x00 TTL=128 ID=16771 DF PROTO=TCP SPT=1228 DPT=800 
WINDOW=0 RES=0x00 ACK RST URGP=0
(Continue reading)

Jenaro Centeno Gómez | 22 Dec 19:21 2006
Picon

Re: Proxy error

After the patch suggested by William, the system keeps going down, same 
behavior, squid-graph service goes to 96% of memory usage, a few minutes 
later the process dissapears but the proxy service goes down, I must say 
that now the services keeps up the double of time that it did before the 
patch was applied.

Thanks again.

Jenaro Centeno Gómez escribió:
> "Even faster falls a than a blind one"
>
> And a few minutes after I send the message the server began to stop 
> responding, I checked at the runing processes with top and there it was, 
> squi-graph with 96% of memory used, proxy service down. So, I made the 
> changes suggested by William, then I restared the server and bingo, 
> problem solved.
>
> I've been checking with top, the squid-graph still gets 96% of memory, 
> but after it does this, the process goes down to 0%.
>
> This is the content of messages log:
> ----------------------------------------------------------------------------------------------------------------------------------------------------------------------
> Dec 22 11:35:00 ipcop fcron[532]: Job /usr/local/bin/timecheck > 
> /dev/null 2>&1 started for user root (pid 535)
> Dec 22 11:35:00 ipcop fcron[533]: Job /usr/local/bin/makegraphs 
>  >/dev/null started for user root (pid 536)
> Dec 22 11:35:00 ipcop fcron[534]: Job [ -f "/var/ipcop/red/active" ] && 
> /usr/local/bin/setddns.pl started for user root (pid 538)
> Dec 22 11:35:06 ipcop kernel: INPUT IN=eth1 OUT= 
> MAC=xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xxSRC=xx.xx.xx.xxDST=x.x.x.x 
(Continue reading)

William Warren | 22 Dec 19:25 2006

Re: Proxy error

after seeing this thread progress this is not a squid leak but leakage 
caused by one of the addons.  Because squid by design wants to cache to 
memory first then to disk on of the addons is causing squid to keep 
cache_memory at an unlimited amount.  This causes the memory exhaustion 
problem.  I would try not using my patch and just running squid in 
transparent mode without these add-ons  and see if this error comes up 
again.  My feeling is it won't.

Jenaro Centeno Gómez wrote:
> "Even faster falls a than a blind one"
> 
> And a few minutes after I send the message the server began to stop 
> responding, I checked at the runing processes with top and there it was, 
> squi-graph with 96% of memory used, proxy service down. So, I made the 
> changes suggested by William, then I restared the server and bingo, 
> problem solved.
> 
> I've been checking with top, the squid-graph still gets 96% of memory, 
> but after it does this, the process goes down to 0%.
> 
> This is the content of messages log:
> ---------------------------------------------------------------------------------------------------------------------------------------------------------------------
> Dec 22 11:35:00 ipcop fcron[532]: Job /usr/local/bin/timecheck > 
> /dev/null 2>&1 started for user root (pid 535)
> Dec 22 11:35:00 ipcop fcron[533]: Job /usr/local/bin/makegraphs 
>  >/dev/null started for user root (pid 536)
> Dec 22 11:35:00 ipcop fcron[534]: Job [ -f "/var/ipcop/red/active" ] && 
> /usr/local/bin/setddns.pl started for user root (pid 538)
> Dec 22 11:35:06 ipcop kernel: INPUT IN=eth1 OUT= 
> MAC=xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xxSRC=xx.xx.xx.xxDST=x.x.x.x 
(Continue reading)

William Warren | 22 Dec 19:29 2006

Re: Proxy error

I run cop+ and copfilter here on 10 firewalls and i don't have the 
exhaustion issues.  I have had to implement my patch for a couple of 256 
megs machines but they have since been upgraded and my patch removed. 
It has to be something with one of the addons you are running.

How big of a squid cache are you setting?

William Warren wrote:
> after seeing this thread progress this is not a squid leak but leakage 
> caused by one of the addons.  Because squid by design wants to cache to 
> memory first then to disk on of the addons is causing squid to keep 
> cache_memory at an unlimited amount.  This causes the memory exhaustion 
> problem.  I would try not using my patch and just running squid in 
> transparent mode without these add-ons  and see if this error comes up 
> again.  My feeling is it won't.
> 
> Jenaro Centeno Gómez wrote:
>> "Even faster falls a than a blind one"
>>
>> And a few minutes after I send the message the server began to stop 
>> responding, I checked at the runing processes with top and there it was, 
>> squi-graph with 96% of memory used, proxy service down. So, I made the 
>> changes suggested by William, then I restared the server and bingo, 
>> problem solved.
>>
>> I've been checking with top, the squid-graph still gets 96% of memory, 
>> but after it does this, the process goes down to 0%.
>>
>> This is the content of messages log:
>> ---------------------------------------------------------------------------------------------------------------------------------------------------------------------
(Continue reading)

Jenaro Centeno Gómez | 22 Dec 20:20 2006
Picon

Re: Proxy error

William,

First, I have removed the add ons and now the system has come stable, at 
least for now, there are no problems. I think that I could try with cop+ 
and copfilter.

On the other hand, I have tried with several sizes for the cache from 50 
megs to 5 gigs, but I still get the same behavior with the add ons 
installed.

Thanks again.

William Warren escribió:
> I run cop+ and copfilter here on 10 firewalls and i don't have the 
> exhaustion issues.  I have had to implement my patch for a couple of 256 
> megs machines but they have since been upgraded and my patch removed. 
> It has to be something with one of the addons you are running.
>
> How big of a squid cache are you setting?
>
>
> William Warren wrote:
>   
>> after seeing this thread progress this is not a squid leak but leakage 
>> caused by one of the addons.  Because squid by design wants to cache to 
>> memory first then to disk on of the addons is causing squid to keep 
>> cache_memory at an unlimited amount.  This causes the memory exhaustion 
>> problem.  I would try not using my patch and just running squid in 
>> transparent mode without these add-ons  and see if this error comes up 
>> again.  My feeling is it won't.
(Continue reading)

Jenaro Centeno Gómez | 22 Dec 20:27 2006
Picon

Re: Proxy error

I keep talking too fast, after add ons were uninstalled the system keeps 
showing squid-graph taking all of the memory, maybe there's something 
left behind by the add ons that is causing this behavior, any other Ideas?

I am going to do a reinstall... :-S.

Jenaro Centeno Gómez escribió:
> William,
>
> First, I have removed the add ons and now the system has come stable, 
> at least for now, there are no problems. I think that I could try with 
> cop+ and copfilter.
>
> On the other hand, I have tried with several sizes for the cache from 
> 50 megs to 5 gigs, but I still get the same behavior with the add ons 
> installed.
>
> Thanks again.
>
> William Warren escribió:
>> I run cop+ and copfilter here on 10 firewalls and i don't have the 
>> exhaustion issues.  I have had to implement my patch for a couple of 
>> 256 megs machines but they have since been upgraded and my patch 
>> removed. It has to be something with one of the addons you are running.
>>
>> How big of a squid cache are you setting?
>>
>>
>> William Warren wrote:
>>  
(Continue reading)

olaf | 22 Dec 21:29 2006
Picon

Re: Proxy error

Jenaro Centeno Gómez wrote:
> I keep talking too fast, after add ons were uninstalled the system keeps 
> showing squid-graph taking all of the memory, maybe there's something 
> left behind by the add ons that is causing this behavior, any other Ideas?
> 
> I am going to do a reinstall... :-S.

you might also want to check your swap memory usage and it's size.

A memory test is also a good idea.

cheers Olaf

--

-- 

A weizen a day helps keep the doctor away.

-------------------------------------------------------------------------
Take Surveys. Earn Cash. Influence the Future of IT
Join SourceForge.net's Techsay panel and you'll get the chance to share your
opinions on IT & business topics through brief surveys - and earn cash
http://www.techsay.com/default.php?page=join.php&p=sourceforge&CID=DEVDEV
_______________________________________________
IPCop-user mailing list
IPCop-user <at> lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/ipcop-user

Gmane