tickets | 8 May 19:42 2012

[Puppet - Bug #14359] (Unreviewed) Puppet Module Install fails to resolve dependencies listed in Modulefile with a hypen (-)

Issue #14359 has been reported by Ryan Coleman.

Bug #14359: Puppet Module Install fails to resolve dependencies listed in Modulefile with a hypen (-)

  • Author: Ryan Coleman
  • Status: Unreviewed
  • Priority: Normal
  • Assignee:
  • Category:
  • Target version:
  • Affected Puppet version:
  • Keywords: moduletool module geordi
  • Branch:

Take for example, puppetlabs-apache has a Modulefile that looks like this:

name 'puppetlabs-apache' version '0.0.3' source 'git://github.com/puppetlabs/puppetlabs-apache.git' author 'puppetlabs' license 'Apache 2.0' summary 'Puppet module for Apache' description 'Module for Apache configuration' project_page 'https://github.com/puppetlabs/puppetlabs-apache' ## Add dependencies, if any: dependency 'puppetlabs-firewall', '>= 0.0.4'

puppetlabs-firewall has a Modulefile that looks like:

name 'puppetlabs-firewall' version '0.0.4' source 'git://github.com/puppetlabs/puppetlabs-firewall.git' author 'puppetlabs' license 'ASL 2.0' summary 'Firewall Module' description 'Manages Firewalls such as iptables' project_page 'http://forge.puppetlabs.com/puppetlabs/firewall'

Trying to install puppetlabs/apache via puppet module install results in this:

[root <at> puppetmaster ~]# puppet module install puppetlabs-apache Preparing to install into /etc/puppetlabs/puppet/modules ... Downloading from http://forge.puppetlabs.com ... Error: Could not install module 'puppetlabs-apache' (latest: v0.0.4) No version of 'puppetlabs-firewall' will satisfy dependencies 'puppetlabs-apache' (v0.0.4) requires 'puppetlabs-firewall' (>= 0.0.4) Use `puppet module install --ignore-dependencies` to install only this module

Changing the dependency line on puppetlabs-apache to dependency ‘puppetlabs/firewall’, ‘>= 0.0.4’ resolves the problem.

You have received this notification because you have either subscribed to it, or are involved in it. To change your notification preferences, please click here: http://projects.puppetlabs.com/my/account

--
You received this message because you are subscribed to the Google Groups "Puppet Bugs" group.
To post to this group, send email to puppet-bugs <at> googlegroups.com.
To unsubscribe from this group, send email to puppet-bugs+unsubscribe <at> googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-bugs?hl=en.

tickets | 9 May 02:17 2012

[Puppet - Bug #14359] (Accepted) Puppet Module Install fails to resolve dependencies listed in Modulefile with a hypen (-)

Issue #14359 has been updated by Daniel Pittman.
  • Category set to modules
  • Status changed from Unreviewed to Accepted
  • Target version set to Telly

Bug #14359: Puppet Module Install fails to resolve dependencies listed in Modulefile with a hypen (-)

  • Author: Ryan Coleman
  • Status: Accepted
  • Priority: Normal
  • Assignee:
  • Category: modules
  • Target version: Telly
  • Affected Puppet version:
  • Keywords: moduletool module geordi
  • Branch:

Take for example, puppetlabs-apache has a Modulefile that looks like this:

name 'puppetlabs-apache' version '0.0.3' source 'git://github.com/puppetlabs/puppetlabs-apache.git' author 'puppetlabs' license 'Apache 2.0' summary 'Puppet module for Apache' description 'Module for Apache configuration' project_page 'https://github.com/puppetlabs/puppetlabs-apache' ## Add dependencies, if any: dependency 'puppetlabs-firewall', '>= 0.0.4'

puppetlabs-firewall has a Modulefile that looks like:

name 'puppetlabs-firewall' version '0.0.4' source 'git://github.com/puppetlabs/puppetlabs-firewall.git' author 'puppetlabs' license 'ASL 2.0' summary 'Firewall Module' description 'Manages Firewalls such as iptables' project_page 'http://forge.puppetlabs.com/puppetlabs/firewall'

Trying to install puppetlabs/apache via puppet module install results in this:

[root <at> puppetmaster ~]# puppet module install puppetlabs-apache Preparing to install into /etc/puppetlabs/puppet/modules ... Downloading from http://forge.puppetlabs.com ... Error: Could not install module 'puppetlabs-apache' (latest: v0.0.4) No version of 'puppetlabs-firewall' will satisfy dependencies 'puppetlabs-apache' (v0.0.4) requires 'puppetlabs-firewall' (>= 0.0.4) Use `puppet module install --ignore-dependencies` to install only this module

Changing the dependency line on puppetlabs-apache to dependency ‘puppetlabs/firewall’, ‘>= 0.0.4’ resolves the problem.

You have received this notification because you have either subscribed to it, or are involved in it. To change your notification preferences, please click here: http://projects.puppetlabs.com/my/account

--
You received this message because you are subscribed to the Google Groups "Puppet Bugs" group.
To post to this group, send email to puppet-bugs <at> googlegroups.com.
To unsubscribe from this group, send email to puppet-bugs+unsubscribe <at> googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-bugs?hl=en.

tickets | 3 Aug 15:45 2012

[Puppet - Bug #14359] Puppet Module Install fails to resolve dependencies listed in Modulefile with a hypen (-)

Issue #14359 has been updated by Ken Barber.
  • Category changed from modules to module tool

Bug #14359: Puppet Module Install fails to resolve dependencies listed in Modulefile with a hypen (-)

  • Author: Ryan Coleman
  • Status: Accepted
  • Priority: Normal
  • Assignee:
  • Category: module tool
  • Target version: 3.x
  • Affected Puppet version:
  • Keywords: moduletool module geordi
  • Branch:

Take for example, puppetlabs-apache has a Modulefile that looks like this:

name 'puppetlabs-apache' version '0.0.3' source 'git://github.com/puppetlabs/puppetlabs-apache.git' author 'puppetlabs' license 'Apache 2.0' summary 'Puppet module for Apache' description 'Module for Apache configuration' project_page 'https://github.com/puppetlabs/puppetlabs-apache' ## Add dependencies, if any: dependency 'puppetlabs-firewall', '>= 0.0.4'

puppetlabs-firewall has a Modulefile that looks like:

name 'puppetlabs-firewall' version '0.0.4' source 'git://github.com/puppetlabs/puppetlabs-firewall.git' author 'puppetlabs' license 'ASL 2.0' summary 'Firewall Module' description 'Manages Firewalls such as iptables' project_page 'http://forge.puppetlabs.com/puppetlabs/firewall'

Trying to install puppetlabs/apache via puppet module install results in this:

[root <at> puppetmaster ~]# puppet module install puppetlabs-apache Preparing to install into /etc/puppetlabs/puppet/modules ... Downloading from http://forge.puppetlabs.com ... Error: Could not install module 'puppetlabs-apache' (latest: v0.0.4) No version of 'puppetlabs-firewall' will satisfy dependencies 'puppetlabs-apache' (v0.0.4) requires 'puppetlabs-firewall' (>= 0.0.4) Use `puppet module install --ignore-dependencies` to install only this module

Changing the dependency line on puppetlabs-apache to dependency ‘puppetlabs/firewall’, ‘>= 0.0.4’ resolves the problem.

You have received this notification because you have either subscribed to it, or are involved in it. To change your notification preferences, please click here: http://projects.puppetlabs.com/my/account

--
You received this message because you are subscribed to the Google Groups "Puppet Bugs" group.
To post to this group, send email to puppet-bugs <at> googlegroups.com.
To unsubscribe from this group, send email to puppet-bugs+unsubscribe <at> googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-bugs?hl=en.


Gmane