Marius Tolzmann | 10 Aug 13:34 2011
Picon

kernel dependency >= 2.6.37 now?


hi..

shouldn't the kernel dependency in the README be raised to >= 2.6.37 due 
to the fact that logind needs /sys/class/tty/tty0/active support which 
was first released with 2.6.37-rc7 if i don't got something wrong?

currently had trouble to get v33 working with kernel 2.6.35.x..

regards, m.

--

-- 
Dipl.-Inf. Marius Tolzmann <marius.tolzmann <at> molgen.mpg.de>
----------------------------------.------------------------------
MPI f. molekulare Genetik         |
Ihnestrasse 63-73, D-14195 Berlin |   ==> MarIuX GNU/Linux <==
Phone: +49 (0)30 8413 1709        |
----------------------------------^------------------------------
God put me on earth to accomplish a certain number of things.
Right now I am so far behind..
    ..I will never die.         <by calvin from calvin&hobbes ;)>
Kay Sievers | 11 Aug 14:28 2011

Re: kernel dependency >= 2.6.37 now?

On Wed, Aug 10, 2011 at 13:34, Marius Tolzmann <tolzmann <at> molgen.mpg.de> wrote:
> shouldn't the kernel dependency in the README be raised to >= 2.6.37 due to
> the fact that logind needs /sys/class/tty/tty0/active support which was
> first released with 2.6.37-rc7 if i don't got something wrong?
>
> currently had trouble to get v33 working with kernel 2.6.35.x..

We need 2.6.39 now. I put that into the README.
3.0 has a few (cosmetic) fixes for kmsg, which are nice to have too.

Thanks,
Kay
Lennart Poettering | 18 Aug 15:42 2011
Picon

Re: kernel dependency >= 2.6.37 now?

On Wed, 10.08.11 13:34, Marius Tolzmann (tolzmann <at> molgen.mpg.de) wrote:

> 
> hi..
> 
> shouldn't the kernel dependency in the README be raised to >= 2.6.37
> due to the fact that logind needs /sys/class/tty/tty0/active support
> which was first released with 2.6.37-rc7 if i don't got something
> wrong?
> 
> currently had trouble to get v33 working with kernel 2.6.35.x..

Only systemd-logind needs /sys/class/tty/tty0/active. If you are not
interested in logind (i.e. embedded uses), you can still run a slightly
older kernel.

Lennart

--

-- 
Lennart Poettering - Red Hat, Inc.
Kay Sievers | 18 Aug 16:06 2011

Re: kernel dependency >= 2.6.37 now?

On Thu, Aug 18, 2011 at 15:42, Lennart Poettering
<lennart <at> poettering.net> wrote:
> On Wed, 10.08.11 13:34, Marius Tolzmann (tolzmann <at> molgen.mpg.de) wrote:
>>
>> shouldn't the kernel dependency in the README be raised to >= 2.6.37
>> due to the fact that logind needs /sys/class/tty/tty0/active support
>> which was first released with 2.6.37-rc7 if i don't got something
>> wrong?
>>
>> currently had trouble to get v33 working with kernel 2.6.35.x..
>
> Only systemd-logind needs /sys/class/tty/tty0/active. If you are not
> interested in logind (i.e. embedded uses), you can still run a slightly
> older kernel.

But keep in mind, that gettys might not get started any more by
default and such issues. That's a pretty easy fix, but might be needed
to make stuff work that otherwise works out-of-the-box.

In some cases, it might just be simpler to backport the needed bits to
older kernels.

In general, people working on the code do not run or test systemd on
older kernels, so you really need to know what you are doing and to
fix eventual issues.

Kay

Gmane