yoni shalom | 15 Apr 23:00 2012
Picon

[Trac-dev] SubversionException "SQLite is required to be compiled and run in thread-safe mode"

Hi, 
after a long while trying to debug this, it seems like php5 is making 
new subversion installs not able to talk to trac repository browser. 

see : http://www.snowbotic.com/archives/61 regarding dav_svn, which 
seems to have a similar problem. 

The problem looks like it relates to php5 and libsvn where php5's 
bundled sqlite library has a version that doesn't work with newer 
subversion repo's, and it gets loaded before the one python tries to 
load dynamically via its swig interface. 

I'm not sure this is actually the case, just that as a fact when I 
disable the php5 module in my apache, the problem goes away. 

Ideas ?

--
You received this message because you are subscribed to the Google Groups "Trac Development" group.
To view this discussion on the web visit https://groups.google.com/d/msg/trac-dev/-/KAZLGoQE64AJ.
To post to this group, send email to trac-dev <at> googlegroups.com.
To unsubscribe from this group, send email to trac-dev+unsubscribe <at> googlegroups.com.
For more options, visit this group at http://groups.google.com/group/trac-dev?hl=en.
victoria | 16 Apr 10:29 2012
Picon

[Trac-dev] Re: SubversionException "SQLite is required to be compiled and run in thread-safe mode"


On Apr 15, 11:00 pm, yoni shalom <silve... <at> gmail.com> wrote:
> Hi,
> after a long while trying to debug this, it seems like php5 is making
> new subversion installs not able to talk to trac repository browser.
>
> see :http://www.snowbotic.com/archives/61regarding dav_svn, which
> seems to have a similar problem.
>
> The problem looks like it relates to php5 and libsvn where php5's
> bundled sqlite library has a version that doesn't work with newer
> subversion repo's, and it gets loaded before the one python tries to
> load dynamically via its swig interface.
>
> I'm not sure this is actually the case, just that as a fact when I
> disable the php5 module in my apache, the problem goes away.
>
> Ideas ?

In BitNami we found that in our BitNami Subversion Stack. The problem
is that Apache is loading the implementation of libsqlite included in
libphp5 which conflicts with subversion.

One (easiest) solution is to load the apache php module after the
mod_dav_svn and mod_authz_svn modules in apache (http://
answers.bitnami.org/questions/1951/sqlite-is-required-to-be-compiled-
and-run-in-thread-safe-mode).

The other solution is to compile apache yourself running the configure
script with the options --with-pdo_sqlite=/path/to/sqlite --with-
sqlite3=/path/to/sqlite

--

-- 
You received this message because you are subscribed to the Google Groups "Trac Development" group.
To post to this group, send email to trac-dev <at> googlegroups.com.
To unsubscribe from this group, send email to trac-dev+unsubscribe <at> googlegroups.com.
For more options, visit this group at http://groups.google.com/group/trac-dev?hl=en.

yoni shalom | 17 Apr 08:21 2012
Picon

[Trac-dev] Re: SubversionException "SQLite is required to be compiled and run in thread-safe mode"

I don't think I'm using mod_dav_svn or mod_authz_svn, and the error happens even if I move  libphp5  to the very end of the module list, 

because of the lazy (dynamically loaded) nature of python dependencies (I'm using WSGI)

So I don't see an option other than either compiling apache by myself, or turning off php.

On Monday, April 16, 2012 11:29:45 AM UTC+3, victoria wrote:


On Apr 15, 11:00 pm, yoni shalom <silve... <at> gmail.com> wrote:
> Hi,
> after a long while trying to debug this, it seems like php5 is making
> new subversion installs not able to talk to trac repository browser.
>
> see :http://www.snowbotic.com/archives/61regarding dav_svn, which
> seems to have a similar problem.
>
> The problem looks like it relates to php5 and libsvn where php5's
> bundled sqlite library has a version that doesn't work with newer
> subversion repo's, and it gets loaded before the one python tries to
> load dynamically via its swig interface.
>
> I'm not sure this is actually the case, just that as a fact when I
> disable the php5 module in my apache, the problem goes away.
>
> Ideas ?

In BitNami we found that in our BitNami Subversion Stack. The problem
is that Apache is loading the implementation of libsqlite included in
libphp5 which conflicts with subversion.

One (easiest) solution is to load the apache php module after the
mod_dav_svn and mod_authz_svn modules in apache (http://
answers.bitnami.org/questions/1951/sqlite-is-required-to-be-compiled-
and-run-in-thread-safe-mode
).

The other solution is to compile apache yourself running the configure
script with the options --with-pdo_sqlite=/path/to/sqlite --with-
sqlite3=/path/to/sqlite


On Monday, April 16, 2012 11:29:45 AM UTC+3, victoria wrote:


On Apr 15, 11:00 pm, yoni shalom <silve... <at> gmail.com> wrote:
> Hi,
> after a long while trying to debug this, it seems like php5 is making
> new subversion installs not able to talk to trac repository browser.
>
> see :http://www.snowbotic.com/archives/61regarding dav_svn, which
> seems to have a similar problem.
>
> The problem looks like it relates to php5 and libsvn where php5's
> bundled sqlite library has a version that doesn't work with newer
> subversion repo's, and it gets loaded before the one python tries to
> load dynamically via its swig interface.
>
> I'm not sure this is actually the case, just that as a fact when I
> disable the php5 module in my apache, the problem goes away.
>
> Ideas ?

In BitNami we found that in our BitNami Subversion Stack. The problem
is that Apache is loading the implementation of libsqlite included in
libphp5 which conflicts with subversion.

One (easiest) solution is to load the apache php module after the
mod_dav_svn and mod_authz_svn modules in apache (http://
answers.bitnami.org/questions/1951/sqlite-is-required-to-be-compiled-
and-run-in-thread-safe-mode
).

The other solution is to compile apache yourself running the configure
script with the options --with-pdo_sqlite=/path/to/sqlite --with-
sqlite3=/path/to/sqlite

--
You received this message because you are subscribed to the Google Groups "Trac Development" group.
To view this discussion on the web visit https://groups.google.com/d/msg/trac-dev/-/G2vDQLv1czgJ.
To post to this group, send email to trac-dev <at> googlegroups.com.
To unsubscribe from this group, send email to trac-dev+unsubscribe <at> googlegroups.com.
For more options, visit this group at http://groups.google.com/group/trac-dev?hl=en.
victoria | 18 Apr 16:08 2012
Picon

[Trac-dev] Re: SubversionException "SQLite is required to be compiled and run in thread-safe mode"

On Apr 17, 8:21 am, yoni shalom <silve... <at> gmail.com> wrote:
> I don't think I'm using mod_dav_svn or mod_authz_svn, and the error happens
> even if I move  libphp5  to the very end of the module list,
> because of the lazy (dynamically loaded) nature of python dependencies (I'm
> using WSGI)
>
> So I don't see an option other than either compiling apache by myself, or
> turning off php.
>

Although in your case the problem is not with mod_dav_svn the same
solution should work for you, compiling PHP with an external sqlite
(threadsafe compiled) should work. If when you disable php works, then
it seems that the issue you are finding is very similar to the one we
found.

Other things you could try/investigate:
- If you are getting the error when you are trying to execute any
specific action (not when starting a apache) you may try to configure
which environment is loaded from your wsgi script (I'm not sure it
will work though)
- Another option that may work could be to compile subversion
statically
- Try BitNami Trac stack :) it uses it own environment (Apache with
mod_wsgi, python 2.6.5, subversion and Trac 0.12 and will not
interfere with your current environment)

> On Monday, April 16, 2012 11:29:45 AM UTC+3, victoria wrote:
>
> > On Apr 15, 11:00 pm, yoni shalom <silve... <at> gmail.com> wrote:
> > > Hi,
> > > after a long while trying to debug this, it seems like php5 is making
> > > new subversion installs not able to talk to trac repository browser.
>
> > > see :http://www.snowbotic.com/archives/61regardingdav_svn, which
> > > seems to have a similar problem.
>
> > > The problem looks like it relates to php5 and libsvn where php5's
> > > bundled sqlite library has a version that doesn't work with newer
> > > subversion repo's, and it gets loaded before the one python tries to
> > > load dynamically via its swig interface.
>
> > > I'm not sure this is actually the case, just that as a fact when I
> > > disable the php5 module in my apache, the problem goes away.
>
> > > Ideas ?
>
> > In BitNami we found that in our BitNami Subversion Stack. The problem
> > is that Apache is loading the implementation of libsqlite included in
> > libphp5 which conflicts with subversion.
>
> > One (easiest) solution is to load the apache php module after the
> > mod_dav_svn and mod_authz_svn modules in apache (http://
> > answers.bitnami.org/questions/1951/sqlite-is-required-to-be-compiled-
> > and-run-in-thread-safe-mode<http://answers.bitnami.org/questions/1951/sqlite-is-required-to-be-co...>).
>
> > The other solution is to compile apache yourself running the configure
> > script with the options --with-pdo_sqlite=/path/to/sqlite --with-
> > sqlite3=/path/to/sqlite
>
> On Monday, April 16, 2012 11:29:45 AM UTC+3, victoria wrote:
>
> > On Apr 15, 11:00 pm, yoni shalom <silve... <at> gmail.com> wrote:
> > > Hi,
> > > after a long while trying to debug this, it seems like php5 is making
> > > new subversion installs not able to talk to trac repository browser.
>
> > > see :http://www.snowbotic.com/archives/61regardingdav_svn, which
> > > seems to have a similar problem.
>
> > > The problem looks like it relates to php5 and libsvn where php5's
> > > bundled sqlite library has a version that doesn't work with newer
> > > subversion repo's, and it gets loaded before the one python tries to
> > > load dynamically via its swig interface.
>
> > > I'm not sure this is actually the case, just that as a fact when I
> > > disable the php5 module in my apache, the problem goes away.
>
> > > Ideas ?
>
> > In BitNami we found that in our BitNami Subversion Stack. The problem
> > is that Apache is loading the implementation of libsqlite included in
> > libphp5 which conflicts with subversion.
>
> > One (easiest) solution is to load the apache php module after the
> > mod_dav_svn and mod_authz_svn modules in apache (http://
> > answers.bitnami.org/questions/1951/sqlite-is-required-to-be-compiled-
> > and-run-in-thread-safe-mode<http://answers.bitnami.org/questions/1951/sqlite-is-required-to-be-co...>).
>
> > The other solution is to compile apache yourself running the configure
> > script with the options --with-pdo_sqlite=/path/to/sqlite --with-
> > sqlite3=/path/to/sqlite

--

-- 
You received this message because you are subscribed to the Google Groups "Trac Development" group.
To post to this group, send email to trac-dev <at> googlegroups.com.
To unsubscribe from this group, send email to trac-dev+unsubscribe <at> googlegroups.com.
For more options, visit this group at http://groups.google.com/group/trac-dev?hl=en.


Gmane