Daniel Choi | 28 Jul 01:06 2011
Picon

elinks seems to be semi-broken on OS X Lion

I installed elinks on OS X Lion, first using Homebrew, but then I
downloaded the 0.11.7 source and ran configure, make and make install.

In both cases, I ran into the same problems when trying to visit some
popular sites. 

If you try to go to yahoo.com and nytimes.com, elinks hangs on "Request
sent" and never finishes.

If you try alltop.com, you get the error "Unable to retrieve
http://alltop.com/: Error reading from socket". 

But google.com loads properly.

I wanted to bring these issues to your attention. 

Thank you for all the answers you given to my questions so far. I love
elinks!

_______________________________________________
elinks-users mailing list
elinks-users <at> linuxfromscratch.org
http://linuxfromscratch.org/mailman/listinfo/elinks-users
Kalle Olavi Niemitalo | 30 Jul 20:04 2011
Picon
Picon

Re: elinks seems to be semi-broken on OS X Lion

Daniel Choi <dhchoi <at> gmail.com> writes:

> If you try alltop.com, you get the error "Unable to retrieve
> http://alltop.com/: Error reading from socket".

I can reproduce this with ELinks 0.11.7 on Mac OS X Lion.
However, ELinks 0.12pre1 and 0.12pre5 appear to work correctly.
Disabling IPv6 support or enabling HTTP compression does not matter.

The incompatibility is apparently not caused by bug 1013
("is_system_error() assumes errno is between 0 and 100000"),
because ELinks 0.12pre1 has that bug and works anyway.
_______________________________________________
elinks-users mailing list
elinks-users <at> linuxfromscratch.org
http://linuxfromscratch.org/mailman/listinfo/elinks-users


Gmane