Chip Bennett | 11 Nov 17:26 2011
Picon

jQuery 1.7: List of Incompatible Third-Party Scripts?

This thread mentions that Nivo Slider is incompatible with jQuery
1.7<http://wordpress.org/support/topic/jquery-17-in-wordpress-33-beta-3>,
which ships with WordPress 3.3 as of Beta 3.

Should we be compiling a list of known jQuery 1.7-incompatible third-party
scripts, to be included in the release notes, etc.? I say "third party"
because I believe that WordPress Plugin/Theme developers have enough
advanced warning to ensure that their Plugins/Themes are compatible -
unless they rely on such third-party scripts as Nivo Slider.

(And if this question is better posed to wp-docs, just let me know!)

Thanks,

Chip
Mika A Epstein | 11 Nov 17:34 2011

Re: jQuery 1.7: List of Incompatible Third-Party Scripts?

Thanks, Chip.

I'm making a list of any I find for my 'Master List' post that I'll toss up in the forums when 3.3 goes live, so if
anyone has known 'Don't work!' with 3.3, post here or email me off list and I'll be sure to include them! 

Any actively developed theme/plugin should be okay, or at least notified.  The ones that haven't been
touched since 2.9 may be ripe for forking, though. :/

On 11 Nov 2011, at 10:26:43AM, Chip Bennett wrote:

> This thread mentions that Nivo Slider is incompatible with jQuery
> 1.7<http://wordpress.org/support/topic/jquery-17-in-wordpress-33-beta-3>,
> which ships with WordPress 3.3 as of Beta 3.
> 
> Should we be compiling a list of known jQuery 1.7-incompatible third-party
> scripts, to be included in the release notes, etc.? I say "third party"
> because I believe that WordPress Plugin/Theme developers have enough
> advanced warning to ensure that their Plugins/Themes are compatible -
> unless they rely on such third-party scripts as Nivo Slider.
> 
> (And if this question is better posed to wp-docs, just let me know!)
> 
> Thanks,
> 
> Chip
> _______________________________________________
> wp-testers mailing list
> wp-testers@...
> http://lists.automattic.com/mailman/listinfo/wp-testers
(Continue reading)

Emil Uzelac | 15 Nov 03:11 2011

Re: jQuery 1.7: List of Incompatible Third-Party Scripts?

Maybe this is not the best way of doing this, but here it is. Chip
mentioned that Nivo Slider is not compatible with 1.7 and the list Mika is
making should definitely benefit, my question is are we going to do similar
for plugins that use TimThumb? such as
http://wordpress.org/extend/plugins/vslider/. Since the proposed 3.3
guidelines<http://make.wordpress.org/themes/2011/11/10/wordpress-3-3-proposed-guidelines-revisions/>(Themes)
will not allow TimThumb usage anymore, should we do the same with
the plugins?

Emil

*----*
*Emil Uzelac* | ThemeID | T: 224-444-0006 | Twitter:  <at> EmilUzelac | E:
emil@... | http://themeid.com
Make everything as simple as possible, but not simpler. - Albert Einstein

On Fri, Nov 11, 2011 at 10:34 AM, Mika A Epstein <ipstenu@...>wrote:

> Thanks, Chip.
>
> I'm making a list of any I find for my 'Master List' post that I'll toss
> up in the forums when 3.3 goes live, so if anyone has known 'Don't work!'
> with 3.3, post here or email me off list and I'll be sure to include them!
>
> Any actively developed theme/plugin should be okay, or at least notified.
>  The ones that haven't been touched since 2.9 may be ripe for forking,
> though. :/
>
> On 11 Nov 2011, at 10:26:43AM, Chip Bennett wrote:
>
(Continue reading)

Chip Bennett | 15 Nov 03:15 2011
Picon

Re: jQuery 1.7: List of Incompatible Third-Party Scripts?

Note that TimThumb is already being blocked by the uploader script; adding
it to the Guidelines is a mere formality at this point.

Chip

On Mon, Nov 14, 2011 at 8:11 PM, Emil Uzelac <emil@...> wrote:

> Maybe this is not the best way of doing this, but here it is. Chip
> mentioned that Nivo Slider is not compatible with 1.7 and the list Mika is
> making should definitely benefit, my question is are we going to do similar
> for plugins that use TimThumb? such as
> http://wordpress.org/extend/plugins/vslider/. Since the proposed 3.3
> guidelines<
> http://make.wordpress.org/themes/2011/11/10/wordpress-3-3-proposed-guidelines-revisions/
> >(Themes)
> will not allow TimThumb usage anymore, should we do the same with
> the plugins?
>
> Emil
>
> *----*
> *Emil Uzelac* | ThemeID | T: 224-444-0006 | Twitter:  <at> EmilUzelac | E:
> emil@... | http://themeid.com
> Make everything as simple as possible, but not simpler. - Albert Einstein
>
>
>
> On Fri, Nov 11, 2011 at 10:34 AM, Mika A Epstein <ipstenu@...
> >wrote:
>
(Continue reading)

Emil Uzelac | 15 Nov 03:16 2011

Re: jQuery 1.7: List of Incompatible Third-Party Scripts?

right, but not the plugins?

*----*
*Emil Uzelac* | ThemeID | T: 224-444-0006 | Twitter:  <at> EmilUzelac | E:
emil@... | http://themeid.com
Make everything as simple as possible, but not simpler. - Albert Einstein

On Mon, Nov 14, 2011 at 8:15 PM, Chip Bennett <chip@...> wrote:

> Note that TimThumb is already being blocked by the uploader script; adding
> it to the Guidelines is a mere formality at this point.
>
> Chip
>
> On Mon, Nov 14, 2011 at 8:11 PM, Emil Uzelac <emil@...> wrote:
>
> > Maybe this is not the best way of doing this, but here it is. Chip
> > mentioned that Nivo Slider is not compatible with 1.7 and the list Mika
> is
> > making should definitely benefit, my question is are we going to do
> similar
> > for plugins that use TimThumb? such as
> > http://wordpress.org/extend/plugins/vslider/. Since the proposed 3.3
> > guidelines<
> >
> http://make.wordpress.org/themes/2011/11/10/wordpress-3-3-proposed-guidelines-revisions/
> > >(Themes)
> > will not allow TimThumb usage anymore, should we do the same with
> > the plugins?
> >
(Continue reading)

Mika A Epstein | 15 Nov 03:32 2011

Re: jQuery 1.7: List of Incompatible Third-Party Scripts?

I'm making a list for 3.3 the core app, NOT the theme stuff.  This is more technical 'It won't work.' or 'This
plugin will break with 3.3.' Chip's link to the theme guidelines aren't the same thing, they're more ... guidelines.

Pirate.

Besides, if I wanted to add a theme to my site with TimThumb, it'll still work, it just won't be HOSTED in the
repo. Different sort of detail ;)

On 14 Nov 2011, at 8:11:31PM, Emil Uzelac wrote:

> Maybe this is not the best way of doing this, but here it is. Chip
> mentioned that Nivo Slider is not compatible with 1.7 and the list Mika is
> making should definitely benefit, my question is are we going to do similar
> for plugins that use TimThumb? such as
> http://wordpress.org/extend/plugins/vslider/. Since the proposed 3.3
> guidelines<http://make.wordpress.org/themes/2011/11/10/wordpress-3-3-proposed-guidelines-revisions/>(Themes)
> will not allow TimThumb usage anymore, should we do the same with
> the plugins?
> 
> Emil
> 
> *----*
> *Emil Uzelac* | ThemeID | T: 224-444-0006 | Twitter:  <at> EmilUzelac | E:
> emil@... | http://themeid.com
> Make everything as simple as possible, but not simpler. - Albert Einstein
> 
> 
> 
> On Fri, Nov 11, 2011 at 10:34 AM, Mika A Epstein <ipstenu@...>wrote:
> 
(Continue reading)

Emil Uzelac | 15 Nov 03:35 2011

Re: jQuery 1.7: List of Incompatible Third-Party Scripts?

Gotcha, thanks!

*----*
*Emil Uzelac* | ThemeID | T: 224-444-0006 | Twitter:  <at> EmilUzelac | E:
emil@... | http://themeid.com
Make everything as simple as possible, but not simpler. - Albert Einstein

On Mon, Nov 14, 2011 at 8:32 PM, Mika A Epstein <ipstenu@...> wrote:

> I'm making a list for 3.3 the core app, NOT the theme stuff.  This is more
> technical 'It won't work.' or 'This plugin will break with 3.3.' Chip's
> link to the theme guidelines aren't the same thing, they're more ...
> guidelines.
>
> Pirate.
>
> Besides, if I wanted to add a theme to my site with TimThumb, it'll still
> work, it just won't be HOSTED in the repo. Different sort of detail ;)
>
>
> On 14 Nov 2011, at 8:11:31PM, Emil Uzelac wrote:
>
> > Maybe this is not the best way of doing this, but here it is. Chip
> > mentioned that Nivo Slider is not compatible with 1.7 and the list Mika
> is
> > making should definitely benefit, my question is are we going to do
> similar
> > for plugins that use TimThumb? such as
> > http://wordpress.org/extend/plugins/vslider/. Since the proposed 3.3
> > guidelines<
(Continue reading)

Alex Stofa | 15 Nov 13:12 2011
Picon

Re: jQuery 1.7: List of Incompatible Third-Party Scripts?

*Cruise* by Alex Stofa  <http://www.smashwords.com/books/view/96859>

A must-read for anybody who has ever dreamed about sailing off to sunnier
climates… or anybody who has even momentarily flirted with the idea of a
summer cruise alone with their lover.

In this fast moving page turner be a voyeur into the bigger than life world
of the charming but glib Mac as he manipulates living ghosts of his past
with the promise of a future with Lynn.

Be the fly on the wall as level headed Lynn, guided by her psychic
childhood friend, is lured into Mac’s dysfunctional world.

Their passion keeps their Mac-Tale romance together. But is passion enough
to stand the test of time?

*Preview Cruise:*

http://www.smashwords.com/books/view/96859

On Mon, Nov 14, 2011 at 9:11 PM, Emil Uzelac <emil@...> wrote:

> Maybe this is not the best way of doing this, but here it is. Chip
> mentioned that Nivo Slider is not compatible with 1.7 and the list Mika is
> making should definitely benefit, my question is are we going to do similar
> for plugins that use TimThumb? such as
> http://wordpress.org/extend/plugins/vslider/. Since the proposed 3.3
> guidelines<
> http://make.wordpress.org/themes/2011/11/10/wordpress-3-3-proposed-guidelines-revisions/
> >(Themes)
(Continue reading)


Gmane