xfq | 3 Nov 02:13 2012
Picon

Sawfish 1.5.3 didn't work on ubuntu 12.10

I installed Sawfish(with sudo apt-get install sawfish) but it's not 
working.  All I see when I start X is the default stipple background: no 
programs, no menus, no pager.  I've tried middle-click and clicking both 
buttons simultaneously, but nothing happened.

I've already read the Sawfish FAQ and user guide, and I've already 
searched the Web, but I still cannot solve this problem.  I have also 
tried to change a mouse, but it didn't make sense.

English is not my native language; please excuse typing errors.  Thanks 
for your consideration.

--

-- 
Sawfish ML

Christopher Roy Bratusek | 3 Nov 10:42 2012

Re: Sawfish 1.5.3 didn't work on ubuntu 12.10

On Saturday 03 November 2012 09:13:00 xfq wrote:
> I installed Sawfish(with sudo apt-get install sawfish) but it's not
> working.  All I see when I start X is the default stipple background: no
> programs, no menus, no pager.  I've tried middle-click and clicking both
> buttons simultaneously, but nothing happened.
> 
> I've already read the Sawfish FAQ and user guide, and I've already
> searched the Web, but I still cannot solve this problem.  I have also
> tried to change a mouse, but it didn't make sense.
> 
> English is not my native language; please excuse typing errors.  Thanks
> for your consideration.

Sawfish packages in Ubuntu are ancient (1.5.3, while 1.9.1 is the latest 
stable version). It might aswell be that they are packaging wrong version of 
rep-gtk with it (Debian once had this problem).

The best choice is to download the sources and install on your own, see: 
http://sawfish.wikia.com/wiki/Compilation_from_source

Regards,
Chris

--

-- 
Sawfish ML

xfq | 3 Nov 09:49 2012
Picon

Re: Sawfish 1.5.3 didn't work on ubuntu 12.10

On 11/03/2012 05:42 PM, Christopher Roy Bratusek wrote:
> On Saturday 03 November 2012 09:13:00 xfq wrote:
>> I installed Sawfish(with sudo apt-get install sawfish) but it's not
>> working.  All I see when I start X is the default stipple background: no
>> programs, no menus, no pager.  I've tried middle-click and clicking both
>> buttons simultaneously, but nothing happened.
>>
>> I've already read the Sawfish FAQ and user guide, and I've already
>> searched the Web, but I still cannot solve this problem.  I have also
>> tried to change a mouse, but it didn't make sense.
>>
>> English is not my native language; please excuse typing errors.  Thanks
>> for your consideration.
>
> Sawfish packages in Ubuntu are ancient (1.5.3, while 1.9.1 is the latest
> stable version). It might aswell be that they are packaging wrong version of
> rep-gtk with it (Debian once had this problem).
>
> The best choice is to download the sources and install on your own, see:
> http://sawfish.wikia.com/wiki/Compilation_from_source
>
> Regards,
> Chris
>
Can I compile it from GIT?

--

-- 
Sawfish ML

(Continue reading)

Christopher Roy Bratusek | 3 Nov 12:01 2012

Re: Sawfish 1.5.3 didn't work on ubuntu 12.10

On Saturday 03 November 2012 16:49:30 xfq wrote:
> On 11/03/2012 05:42 PM, Christopher Roy Bratusek wrote:
> > On Saturday 03 November 2012 09:13:00 xfq wrote:
> >> I installed Sawfish(with sudo apt-get install sawfish) but it's not
> >> working.  All I see when I start X is the default stipple background: no
> >> programs, no menus, no pager.  I've tried middle-click and clicking both
> >> buttons simultaneously, but nothing happened.
> >> 
> >> I've already read the Sawfish FAQ and user guide, and I've already
> >> searched the Web, but I still cannot solve this problem.  I have also
> >> tried to change a mouse, but it didn't make sense.
> >> 
> >> English is not my native language; please excuse typing errors.  Thanks
> >> for your consideration.
> > 
> > Sawfish packages in Ubuntu are ancient (1.5.3, while 1.9.1 is the latest
> > stable version). It might aswell be that they are packaging wrong version
> > of rep-gtk with it (Debian once had this problem).
> > 
> > The best choice is to download the sources and install on your own, see:
> > http://sawfish.wikia.com/wiki/Compilation_from_source
> > 
> > Regards,
> > Chris
> 
> Can I compile it from GIT?

of course, there's also a guide for compiling from GIT:
http://sawfish.wikia.com/wiki/Compilation_from_GIT

(Continue reading)

xfq | 3 Nov 12:14 2012
Picon

Re: Sawfish 1.5.3 didn't work on ubuntu 12.10

On 11/03/2012 07:01 PM, Christopher Roy Bratusek wrote:
> On Saturday 03 November 2012 16:49:30 xfq wrote:
>> On 11/03/2012 05:42 PM, Christopher Roy Bratusek wrote:
>>> On Saturday 03 November 2012 09:13:00 xfq wrote:
>>>> I installed Sawfish(with sudo apt-get install sawfish) but it's not
>>>> working.  All I see when I start X is the default stipple background: no
>>>> programs, no menus, no pager.  I've tried middle-click and clicking both
>>>> buttons simultaneously, but nothing happened.
>>>>
>>>> I've already read the Sawfish FAQ and user guide, and I've already
>>>> searched the Web, but I still cannot solve this problem.  I have also
>>>> tried to change a mouse, but it didn't make sense.
>>>>
>>>> English is not my native language; please excuse typing errors.  Thanks
>>>> for your consideration.
>>>
>>> Sawfish packages in Ubuntu are ancient (1.5.3, while 1.9.1 is the latest
>>> stable version). It might aswell be that they are packaging wrong version
>>> of rep-gtk with it (Debian once had this problem).
>>>
>>> The best choice is to download the sources and install on your own, see:
>>> http://sawfish.wikia.com/wiki/Compilation_from_source
>>>
>>> Regards,
>>> Chris
>>
>> Can I compile it from GIT?
>
> of course, there's also a guide for compiling from GIT:
> http://sawfish.wikia.com/wiki/Compilation_from_GIT
(Continue reading)

Mogei Wang | 3 Nov 10:31 2012
Picon

Re: Sawfish 1.5.3 didn't work on ubuntu 12.10

I used sawfish 1.5.3 on ubuntu 12.04 ( lubuntu in detail ) for quite a
few days. It worked well. I think it can run on your machine, too.

Maybe you can try to build a very simple config file ~/.sawfishrc

You can also try to reboot your system, launch the gnome-classic
desktop, then pkill the default window manager, and launch sawfish.

Hope that helps

m.w.

On Sat, Nov 3, 2012 at 9:13 AM, xfq <xfq.free <at> gmail.com> wrote:
> I installed Sawfish(with sudo apt-get install sawfish) but it's not working.
> All I see when I start X is the default stipple background: no programs, no
> menus, no pager.  I've tried middle-click and clicking both buttons
> simultaneously, but nothing happened.
>
> I've already read the Sawfish FAQ and user guide, and I've already searched
> the Web, but I still cannot solve this problem.  I have also tried to change
> a mouse, but it didn't make sense.
>
> English is not my native language; please excuse typing errors.  Thanks for
> your consideration.
>
> --
> Sawfish ML
>

--

-- 
(Continue reading)


Gmane