Diego Queiroz | 1 May 01:53 2011
Picon

Python version?

Is there some consensus about what version of Python LyX scripts should be compatible?


I mean, may I propose some change in "configure.py", for example, that is only Python 2.6+ compatible or it should be compatible with previous versions?
If so, what's the version?


Regards,
---
Diego Queiroz

Pavel Sanda | 2 May 00:58 2011

Re: Python version?

Diego Queiroz wrote:
> Is there some consensus about what version of Python LyX scripts should be
> compatible?

consensus is that we dont support python 3. so 2.6 code should be fine.

pavel

Guenter Milde | 2 May 11:11 2011
Picon

Re: Python version?

On 2011-05-01, Pavel Sanda wrote:
> Diego Queiroz wrote:
>> Is there some consensus about what version of Python LyX scripts should be
>> compatible?

> consensus is that we dont support python 3. so 2.6 code should be fine.

I would prefer to keep compatibility also with Python 2.5 if there are no
big gains from dropping this.

Günter

José Matos | 2 May 15:09 2011

Re: Python version?

On Monday 02 May 2011 10:11:18 Guenter Milde wrote:
> I would prefer to keep compatibility also with Python 2.5 if there are no
> big gains from dropping this.
> 
> Günter

Last I have checked configure.py was the culprit, all the other scripts are 
compatible with python 2.5.

If you notice any problem it should be possible to fix them quickly.

--

-- 
José Abílio


Gmane