Jeff Kowalczyk | 11 May 02:35 2011
Picon

file-error

I use el-get org-mode recipe, but I see the same behavior with a typical
org-mode config from init.el.

On org-mode git master start with emacs bzr trunk (emacs 24), org errors on load:

File mode specification error: (file-error "Cannot open load file" "lisp/org")
progn: Cannot open load file: lisp/org

Any idea what file mode specification in this context would be? The unix file
mode is normal:

[master]~/.emacs.d/el-get $ ls -al org-mode/lisp/org.el*
-rw-r--r-- 1 myuser users 774897 May 10 16:45 org-mode/lisp/org.el
-rw-r--r-- 1 myuser users 688684 May 10 16:45 org-mode/lisp/org.elc

Thanks for any suggestions,

Jeff

Nick Dokos | 11 May 05:13 2011
Picon

Re: file-error

Jeff Kowalczyk <jtk <at> yahoo.com> wrote:

> I use el-get org-mode recipe, but I see the same behavior with a typical
> org-mode config from init.el.
> 
> On org-mode git master start with emacs bzr trunk (emacs 24), org errors on load:
> 
> File mode specification error: (file-error "Cannot open load file" "lisp/org")
> progn: Cannot open load file: lisp/org
> 
> Any idea what file mode specification in this context would be? The unix file
> mode is normal:
> 
> [master]~/.emacs.d/el-get $ ls -al org-mode/lisp/org.el*
> -rw-r--r-- 1 myuser users 774897 May 10 16:45 org-mode/lisp/org.el
> -rw-r--r-- 1 myuser users 688684 May 10 16:45 org-mode/lisp/org.elc
> 
> Thanks for any suggestions,
> 

We need a backtrace: see section 1.4, "Feedback", in the Orgmode manual.
But clearly, this is not an orgmode error: emacs just cannot find the file
to load (for whatever reason - the backtrace will make clear what the reason
is, but it is probably an incorrect load-path or an incorrect file spec).

Nick

Jeff Kowalczyk | 11 May 16:27 2011
Picon

Re: file-error

Nick Dokos <nicholas.dokos <at> hp.com> writes:
> We need a backtrace: see section 1.4, "Feedback", in the Orgmode manual.
> But clearly, this is not an orgmode error: emacs just cannot find the file
> to load (for whatever reason - the backtrace will make clear what the reason
> is, but it is probably an incorrect load-path or an incorrect file spec).

After several attempts, I have not been able to get a traceback that shows much
useful information:

M-x toggle-debug-on-error, scratch buffer, (org-reload) C-x C-e

Debugger entered--Lisp error: (file-error "Cannot open load file" "lisp/org")
  (org-reload)
  eval((org-reload) nil)
  eval-last-sexp-1(nil)
  eval-last-sexp(nil)
  call-interactively(eval-last-sexp nil nil)

I have relieved el-get from org-mode duties temporarily to debug, and here's the
current section in ~/.emacs.d/init.el, no extra customizations to Org:

;; org-mode install
(add-to-list 'load-path "~/.emacs.d/el-get/org-mode/lisp")
(add-to-list 'load-path "~/.emacs.d/el-get/org-mode/contrib/lisp")
(add-to-list 'auto-mode-alist '("\\.org\\'" . org-mode))
(require 'org-install)

The file path is valid:

$ ls -al ~/.emacs.d/el-get/org-mode/lisp | head
(Continue reading)

Jeff Kowalczyk | 11 May 17:25 2011
Picon

Re: file-error


Nick Dokos <nicholas.dokos <at> hp.com> wrote:
> Try
> 
> (add-to-list 'load-path "~/.emacs.d/el-get/org-mode")
> 
> It is failing on "lisp/org" so that might fix it: it would
> be nice to know *who* is looking for "lisp/org" however - 
> is it org-reload?
> 
> Nick

Thanks Nick, your suggestion worked. It makes a lot more sense now. I think this
is a recent change, I didn't have that org-mode root directory in load-path
previously, and org git worked fine.

Thanks again,
Jeff


Gmane