Saeed Mirzamohamadi | 31 Aug 08:19 2013
Picon

iscsiadm login failed

Hi
I'm trying to connect my open-iscsi initiator to target, but failed to login with the command "sudo iscsiadm -m node --login". Here is my error:

Logging in to [iface: default, target: iqn.2003-01.org.linux-iscsi.ubuntu.i686:sn.1fe6a7cbc123, portal: 192.168.157.161,3260]
Logging in to [iface: default, target: iqn.2003-01.org.linux-iscsi.ubuntu.i686:sn.d0a998675819, portal: 192.168.157.160,3260]
iscsiadm: Could not login to [iface: default, target: iqn.2003-01.org.linux-iscsi.ubuntu.i686:sn.1fe6a7cbc123, portal: 192.168.157.161,3260]: 
iscsiadm: initiator reported error (19 - encountered non-retryable iSCSI login failure)
iscsiadm: Could not login to [iface: default, target: iqn.2003-01.org.linux-iscsi.ubuntu.i686:sn.d0a998675819, portal: 192.168.157.160,3260]: 
iscsiadm: initiator reported error (8 - connection timed out)

I'm using instructions in the following link:

iscsiadm discovery is OK too.

and my target is LIO. It's fine and my targetcli shows this:
o- / ..................................................................... [...]
  o- backstores .......................................................... [...]
  | o- fileio ............................................... [0 Storage Object]
  | o- iblock ............................................... [0 Storage Object]
  | o- pscsi ................................................ [0 Storage Object]
  | o- rd_dr ................................................ [0 Storage Object]
  | o- rd_mcp ............................................... [1 Storage Object]
  |   o- saeedRAM .......................................... [ramdisk activated]
  o- iscsi .......................................................... [1 Target]
  | o- iqn.2003-01.org.linux-iscsi.ubuntu.i686:sn.1fe6a7cbc123 ......... [1 TPG]
  |   o- tpgt1 ....................................................... [enabled]
  |     o- acls ........................................................ [1 ACL]
  |     | o- iqn.1993-08.org.debian:01:3db9b7d39af .............. [1 Mapped LUN]
  |     |   o- mapped_lun0 ......................................... [lun0 (rw)]
  |     o- luns ........................................................ [1 LUN]
  |     | o- lun0 .................................. [rd_mcp/saeedRAM (ramdisk)]
  |     o- portals .................................................. [1 Portal]
  |       o- 192.168.157.161:3260 ......................................... [OK]
  o- loopback ....................................................... [0 Target]
  o- tcm_fc ......................................................... [0 Target]

What might be the problem? I have searched a lot but didn't find anything beneficial.

Additionally I'm using both initiator and target in same computer.
My system: Linux ubuntu 12.04 LTS.

Thanks in advance!

--
You received this message because you are subscribed to the Google Groups "open-iscsi" group.
To unsubscribe from this group and stop receiving emails from it, send an email to open-iscsi+unsubscribe-/JYPxA39Uh5TLH3MbocFF+G/Ez6ZCGd0@public.gmane.org
To post to this group, send email to open-iscsi-/JYPxA39Uh5TLH3MbocFF+G/Ez6ZCGd0@public.gmane.org
Visit this group at http://groups.google.com/group/open-iscsi.
For more options, visit https://groups.google.com/groups/opt_out.
Saeed Mirzamohamadi | 29 Aug 19:06 2013
Picon

iscsiadm login failed

Hi open-iscsi members
I'm trying to connect my open-iscsi initiator to target, but failed to login with the command "sudo iscsiadm -m node --login". Here is my error:

Logging in to [iface: default, target: iqn.2003-01.org.linux-iscsi.ubuntu.i686:sn.1fe6a7cbc123, portal: 192.168.157.161,3260]
Logging in to [iface: default, target: iqn.2003-01.org.linux-iscsi.ubuntu.i686:sn.d0a998675819, portal: 192.168.157.160,3260]
iscsiadm: Could not login to [iface: default, target: iqn.2003-01.org.linux-iscsi.ubuntu.i686:sn.1fe6a7cbc123, portal: 192.168.157.161,3260]: 
iscsiadm: initiator reported error (19 - encountered non-retryable iSCSI login failure)
iscsiadm: Could not login to [iface: default, target: iqn.2003-01.org.linux-iscsi.ubuntu.i686:sn.d0a998675819, portal: 192.168.157.160,3260]: 
iscsiadm: initiator reported error (8 - connection timed out)

I'm using instructions in the following link:
Additionally, I'm using both initiator and target in same computer.
My system: Linux ubuntu 12.04 LTS.

iscsiadm discovery is OK too.

and my target is LIO. It works fine and my targetcli shows this:
o- / ..................................................................... [...]
  o- backstores .......................................................... [...]
  | o- fileio ............................................... [0 Storage Object]
  | o- iblock ............................................... [0 Storage Object]
  | o- pscsi ................................................ [0 Storage Object]
  | o- rd_dr ................................................ [0 Storage Object]
  | o- rd_mcp ............................................... [1 Storage Object]
  |   o- saeedRAM .......................................... [ramdisk activated]
  o- iscsi .......................................................... [1 Target]
  | o- iqn.2003-01.org.linux-iscsi.ubuntu.i686:sn.1fe6a7cbc123 ......... [1 TPG]
  |   o- tpgt1 ....................................................... [enabled]
  |     o- acls ........................................................ [1 ACL]
  |     | o- iqn.1993-08.org.debian:01:3db9b7d39af .............. [1 Mapped LUN]
  |     |   o- mapped_lun0 ......................................... [lun0 (rw)]
  |     o- luns ........................................................ [1 LUN]
  |     | o- lun0 .................................. [rd_mcp/saeedRAM (ramdisk)]
  |     o- portals .................................................. [1 Portal]
  |       o- 192.168.157.161:3260 ......................................... [OK]
  o- loopback ....................................................... [0 Target]
  o- tcm_fc ......................................................... [0 Target]

What might be the problem? I have searched a lot but didn't find anything beneficial.
Any help or suggestion would be greatly appreciated.

Thanks in advance!

--
You received this message because you are subscribed to the Google Groups "open-iscsi" group.
To unsubscribe from this group and stop receiving emails from it, send an email to open-iscsi+unsubscribe-/JYPxA39Uh5TLH3MbocFF+G/Ez6ZCGd0@public.gmane.org
To post to this group, send email to open-iscsi-/JYPxA39Uh5TLH3MbocFF+G/Ez6ZCGd0@public.gmane.org
Visit this group at http://groups.google.com/group/open-iscsi.
For more options, visit https://groups.google.com/groups/opt_out.
Nicholas A. Bellinger | 4 Sep 00:05 2013

Re: iscsiadm login failed

Hi Saeed,

On Fri, 2013-08-30 at 23:19 -0700, Saeed Mirzamohamadi wrote:
> Hi
> I'm trying to connect my open-iscsi initiator to target, but failed
> to login with the command "sudo iscsiadm -m node --login". Here is my
> error:
> 
> 
> Logging in to [iface: default, target:
> iqn.2003-01.org.linux-iscsi.ubuntu.i686:sn.1fe6a7cbc123, portal:
> 192.168.157.161,3260]
> Logging in to [iface: default, target:
> iqn.2003-01.org.linux-iscsi.ubuntu.i686:sn.d0a998675819, portal:
> 192.168.157.160,3260]
> iscsiadm: Could not login to [iface: default, target:
> iqn.2003-01.org.linux-iscsi.ubuntu.i686:sn.1fe6a7cbc123, portal:
> 192.168.157.161,3260]: 
> iscsiadm: initiator reported error (19 - encountered non-retryable
> iSCSI login failure)
> iscsiadm: Could not login to [iface: default, target:
> iqn.2003-01.org.linux-iscsi.ubuntu.i686:sn.d0a998675819, portal:
> 192.168.157.160,3260]: 
> iscsiadm: initiator reported error (8 - connection timed out)
> 
> 

I'm guessing that you've not setup CHAP authentication properly for the
initiator NodeACL listed below, or disabled authentication enforcement
via:

   set attribute authentication=0

from within TPG context.  You might want to have a look at:

http://www.linux-iscsi.org/wiki/ISCSI#Define_access_rights

--nab

> I'm using instructions in the following link:
> https://help.ubuntu.com/lts/serverguide/iscsi-initiator.html
> 
> 
> 
> iscsiadm discovery is OK too.
> 
> 
> and my target is LIO. It's fine and my targetcli shows this:
> o- / ..................................................................... [...]
>   o-
> backstores ..........................................................
> [...]
>   | o- fileio ............................................... [0
> Storage Object]
>   | o- iblock ............................................... [0
> Storage Object]
>   | o- pscsi ................................................ [0
> Storage Object]
>   | o- rd_dr ................................................ [0
> Storage Object]
>   | o- rd_mcp ............................................... [1
> Storage Object]
>   |   o- saeedRAM .......................................... [ramdisk
> activated]
>   o-
> iscsi .......................................................... [1
> Target]
>   | o-
> iqn.2003-01.org.linux-iscsi.ubuntu.i686:sn.1fe6a7cbc123 ......... [1
> TPG]
>   |   o- tpgt1 .......................................................
> [enabled]
>   |     o-
> acls ........................................................ [1 ACL]
>   |     | o- iqn.1993-08.org.debian:01:3db9b7d39af .............. [1
> Mapped LUN]
>   |     |   o-
> mapped_lun0 ......................................... [lun0 (rw)]
>   |     o-
> luns ........................................................ [1 LUN]
>   |     | o- lun0 .................................. [rd_mcp/saeedRAM
> (ramdisk)]
>   |     o- portals ..................................................
> [1 Portal]
>   |       o-
> 192.168.157.161:3260 ......................................... [OK]
>   o- loopback .......................................................
> [0 Target]
>   o- tcm_fc .........................................................
> [0 Target]
> 
> 
> What might be the problem? I have searched a lot but didn't find
> anything beneficial.
> 
> 
> Additionally I'm using both initiator and target in same computer.
> My system: Linux ubuntu 12.04 LTS.
> 
> 
> Thanks in advance!
> 
> 
> -- 
> You received this message because you are subscribed to the Google
> Groups "open-iscsi" group.
> To unsubscribe from this group and stop receiving emails from it, send
> an email to open-iscsi+unsubscribe@...
> To post to this group, send email to open-iscsi@...
> Visit this group at http://groups.google.com/group/open-iscsi.
> For more options, visit https://groups.google.com/groups/opt_out.

--

-- 
You received this message because you are subscribed to the Google Groups "open-iscsi" group.
To unsubscribe from this group and stop receiving emails from it, send an email to open-iscsi+unsubscribe@...
To post to this group, send email to open-iscsi@...
Visit this group at http://groups.google.com/group/open-iscsi.
For more options, visit https://groups.google.com/groups/opt_out.


Gmane