Jakub Hrozek | 18 Oct 20:19 2012
Picon

[PATCH] Require ar in configure.ac

See attached patch. I tested it on both F-18 and RHEL-5 (but nothing in
between, hopefully that's OK).
From da0c4f823313be9ff8cba9dd0463b17f3b5641df Mon Sep 17 00:00:00 2001
From: Jakub Hrozek <jhrozek@...>
Date: Mon, 15 Oct 2012 15:33:00 +0200
Subject: [PATCH] Require ar in configure.ac

This seems to be a change in recent autotools. I was getting a lot of
messages such as:

/usr/share/automake-1.12/am/ltlibrary.am: warning: 'libipa_hbac.la':
linking libtool libraries using a non-POSIX
/usr/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR'
in 'configure.ac'
---
 configure.ac | 2 ++
 1 file changed, 2 insertions(+)

diff --git a/configure.ac b/configure.ac
index 9ee5844f789dc75221f96f0d46b4b7716419c95e..471c7ac6826d4a895e058dba4c1f62f3e552fea3 100644
--- a/configure.ac
+++ b/configure.ac
 <at>  <at>  -16,6 +16,8  <at>  <at>  AC_CONFIG_AUX_DIR([build])

 AM_INIT_AUTOMAKE([-Wall foreign subdir-objects tar-pax])
 AM_PROG_CC_C_O
+m4_pattern_allow([AM_PROG_AR])
+AM_PROG_AR
(Continue reading)

Stephen Gallagher | 18 Oct 20:40 2012
Picon

Re: [PATCH] Require ar in configure.ac

On Thu 18 Oct 2012 02:19:13 PM EDT, Jakub Hrozek wrote:
> See attached patch. I tested it on both F-18 and RHEL-5 (but nothing in
> between, hopefully that's OK).
>

Ack
_______________________________________________
sssd-devel mailing list
sssd-devel <at> lists.fedorahosted.org
https://lists.fedorahosted.org/mailman/listinfo/sssd-devel
Jakub Hrozek | 23 Oct 15:42 2012
Picon

Re: [PATCH] Require ar in configure.ac

On Thu, Oct 18, 2012 at 02:40:43PM -0400, Stephen Gallagher wrote:
> On Thu 18 Oct 2012 02:19:13 PM EDT, Jakub Hrozek wrote:
> >See attached patch. I tested it on both F-18 and RHEL-5 (but nothing in
> >between, hopefully that's OK).
> >
> 
> Ack

Pushed to master.
_______________________________________________
sssd-devel mailing list
sssd-devel <at> lists.fedorahosted.org
https://lists.fedorahosted.org/mailman/listinfo/sssd-devel

Gmane