Josiah Boothby | 1 Sep 23:02 2010
Picon

Chokoq

I've gotten a few emails regarding the fact that as of a few days ago,
Choqok 0.6.6 no longer works because of changes Twitter has made to
authorization. I have tested beta2 and was not able to make it work
for me: it worked fine (after deleting the choqokrc file) when first
loaded, but subsequent attempts to load the program required me to
enter my username and password -- which were rejected. I have not yet
had an opportunity to test beta3 (0.9.90), though I have received an
updated slackbuild for it.

I will not be able to test this until later today, but if anybody else
would like to test it to make sure it's acceptable, I have attached
the updated slackbuild. N.B., this new version depends on qoauth and
qjson, both available on SBo.

--Josiah
Attachment (choqok.SlackBuild.gz): application/x-gzip, 1414 bytes
I've gotten a few emails regarding the fact that as of a few days ago,
Choqok 0.6.6 no longer works because of changes Twitter has made to
authorization. I have tested beta2 and was not able to make it work
for me: it worked fine (after deleting the choqokrc file) when first
loaded, but subsequent attempts to load the program required me to
enter my username and password -- which were rejected. I have not yet
had an opportunity to test beta3 (0.9.90), though I have received an
updated slackbuild for it.

I will not be able to test this until later today, but if anybody else
would like to test it to make sure it's acceptable, I have attached
the updated slackbuild. N.B., this new version depends on qoauth and
(Continue reading)

Willy Sudiarto Raharjo | 1 Sep 23:43 2010
Picon

Re: Chokoq

> I've gotten a few emails regarding the fact that as of a few days ago,
> Choqok 0.6.6 no longer works because of changes Twitter has made to
> authorization. I have tested beta2 and was not able to make it work
> for me: it worked fine (after deleting the choqokrc file) when first
> loaded, but subsequent attempts to load the program required me to
> enter my username and password -- which were rejected. I have not yet
> had an opportunity to test beta3 (0.9.90), though I have received an
> updated slackbuild for it.
>
> I will not be able to test this until later today, but if anybody else
> would like to test it to make sure it's acceptable, I have attached
> the updated slackbuild. N.B., this new version depends on qoauth and
> qjson, both available on SBo.

I tested using beta3 version and it works using the old SlackBuilds,
but i have to install the new dependencies like you mentioned (qoauth
and qjson)

In order to make it work, you must re-authenticate your username using
OAuth and make sure it's integrated to KWallet or your credentials
will be lost and you will have to re-authenticate again.

--

-- 
Willy Sudiarto Raharjo
Registered Linux User : 336579
Web : http://www.informatix.or.id/willy
Blog : http://willysr.blogspot.com http://slackblogs.blogspot.com
Josiah Boothby | 2 Sep 02:53 2010
Picon

Re: Chokoq

> I tested using beta3 version and it works using the old SlackBuilds,
> but i have to install the new dependencies like you mentioned (qoauth
> and qjson)
>
> In order to make it work, you must re-authenticate your username using
> OAuth and make sure it's integrated to KWallet or your credentials
> will be lost and you will have to re-authenticate again.

It looks like beta3 works! I get an annoying warning each time the
program loads because I don't use kwallet, hopefully that is solved
with the release of 1.0. I'll submit an updated slackbuild.

--Josiah
Willy Sudiarto Raharjo | 2 Sep 03:01 2010
Picon

Re: Chokoq

> It looks like beta3 works! I get an annoying warning each time the
> program loads because I don't use kwallet, hopefully that is solved
> with the release of 1.0. I'll submit an updated slackbuild.

I used to experience the same annoying warning, but after i integrate
it to KWallet, it disappeared :)

--

-- 
Willy Sudiarto Raharjo
Registered Linux User : 336579
Web : http://www.informatix.or.id/willy
Blog : http://willysr.blogspot.com http://slackblogs.blogspot.com
Josiah Boothby | 2 Sep 03:14 2010
Picon

Re: Chokoq

On Wed, Sep 1, 2010 at 18:01, Willy Sudiarto Raharjo
<willysr@...> wrote:
>> It looks like beta3 works! I get an annoying warning each time the
>> program loads because I don't use kwallet, hopefully that is solved
>> with the release of 1.0. I'll submit an updated slackbuild.
>
> I used to experience the same annoying warning, but after i integrate
> it to KWallet, it disappeared :)

I'm generally disinclined to use KWallet for one program and one
program only. Maybe if I was using Konqueror as my primary browser as
well as KMail and Kopete.

That all said, someone else has submitted an updated slackbuild, so
I'm unable to submit my newest version. I don't know what it looks
like, but if anybody would like to try what I've come up with, feel
free to email me and I'll send you the updated choqok.tar.gz

--Josiah
Willy Sudiarto Raharjo | 2 Sep 03:24 2010
Picon

Re: Chokoq

> I'm generally disinclined to use KWallet for one program and one
> program only. Maybe if I was using Konqueror as my primary browser as
> well as KMail and Kopete.
>
> That all said, someone else has submitted an updated slackbuild, so
> I'm unable to submit my newest version. I don't know what it looks
> like, but if anybody would like to try what I've come up with, feel
> free to email me and I'll send you the updated choqok.tar.gz

Strange
If you are the maintainer, the admins would have rejected the package
if you haven't release your maintainer position
please ask one of the admin to remove the submitted package so that
you can submit yours

--

-- 
Willy Sudiarto Raharjo
Registered Linux User : 336579
Web : http://www.informatix.or.id/willy
Blog : http://willysr.blogspot.com http://slackblogs.blogspot.com
Josiah Boothby | 2 Sep 03:30 2010
Picon

Re: Chokoq

> Strange
> If you are the maintainer, the admins would have rejected the package
> if you haven't release your maintainer position
> please ask one of the admin to remove the submitted package so that
> you can submit yours

I may, though I have to admit that I'm willing to cede maintainership
if someone else would like to take over. I'm only the maintainer
because I was the first person to upload a script ;)
Willy Sudiarto Raharjo | 2 Sep 03:35 2010
Picon

Re: Chokoq

> I may, though I have to admit that I'm willing to cede maintainership
> if someone else would like to take over. I'm only the maintainer
> because I was the first person to upload a script ;)

I'm willing to be the next maintainer as i'm using it now to replace
Echofon who has dropped support for Linux

--

-- 
Willy Sudiarto Raharjo
Registered Linux User : 336579
Web : http://www.informatix.or.id/willy
Blog : http://willysr.blogspot.com http://slackblogs.blogspot.com
Erik Hanson | 2 Sep 04:10 2010

Re: Chokoq

On Thu, 2 Sep 2010 08:35:26 +0700
Willy Sudiarto Raharjo <willysr@...> wrote:

> > I may, though I have to admit that I'm willing to cede
> > maintainership if someone else would like to take over. I'm only
> > the maintainer because I was the first person to upload a script ;)
> 
> I'm willing to be the next maintainer as i'm using it now to replace
> Echofon who has dropped support for Linux
> 

For the time being, 1.9.6.4 still works, and you can downgrade at the
mozilla add-ons page for Echofon. I've been trying to replace it with
Pino (which is very light/fast) lately but they still have some work
to do.

https://addons.mozilla.org/en-US/firefox/addon/5081/versions/
http://slackbuilds.org/repository/13.1/network/pino/

--

-- 
Erik Hanson
On Thu, 2 Sep 2010 08:35:26 +0700
Willy Sudiarto Raharjo <willysr@...> wrote:

> > I may, though I have to admit that I'm willing to cede
> > maintainership if someone else would like to take over. I'm only
> > the maintainer because I was the first person to upload a script ;)
> 
(Continue reading)

Willy Sudiarto Raharjo | 2 Sep 04:15 2010
Picon

Re: Chokoq

> For the time being, 1.9.6.4 still works, and you can downgrade at the
> mozilla add-ons page for Echofon. I've been trying to replace it with
> Pino (which is very light/fast) lately but they still have some work
> to do.
>
> https://addons.mozilla.org/en-US/firefox/addon/5081/versions/
> http://slackbuilds.org/repository/13.1/network/pino/

Hm... 1.9.6.4 use basic auth right?
Twitter has completely stopped support for Basic Auth, which makes
1.9.6.4 shouldn't work any longer
i'm curious how can it be still working

--

-- 
Willy Sudiarto Raharjo
Registered Linux User : 336579
Web : http://www.informatix.or.id/willy
Blog : http://willysr.blogspot.com http://slackblogs.blogspot.com
Erik Hanson | 2 Sep 04:30 2010

Re: Chokoq

On Thu, 2 Sep 2010 09:15:59 +0700
Willy Sudiarto Raharjo <willysr@...> wrote:

> > For the time being, 1.9.6.4 still works, and you can downgrade at
> > the mozilla add-ons page for Echofon. I've been trying to replace
> > it with Pino (which is very light/fast) lately but they still have
> > some work to do.
> >
> > https://addons.mozilla.org/en-US/firefox/addon/5081/versions/
> > http://slackbuilds.org/repository/13.1/network/pino/
> 
> Hm... 1.9.6.4 use basic auth right?
> Twitter has completely stopped support for Basic Auth, which makes
> 1.9.6.4 shouldn't work any longer
> i'm curious how can it be still working
> 

I don't know the auth details but it is definitely still working here.
Many complaints to  <at> echofon were replied with the advice to downgrade
to 1.9.6.4 until they've worked out a solution.

http://blog.echofon.com/2010/08/basic-auth-support-discontinue-on.html

--

-- 
Erik Hanson
On Thu, 2 Sep 2010 09:15:59 +0700
Willy Sudiarto Raharjo <willysr@...> wrote:

(Continue reading)

Willy Sudiarto Raharjo | 2 Sep 04:33 2010
Picon

Re: Chokoq

> I don't know the auth details but it is definitely still working here.
> Many complaints to  <at> echofon were replied with the advice to downgrade
> to 1.9.6.4 until they've worked out a solution.
>
> http://blog.echofon.com/2010/08/basic-auth-support-discontinue-on.html

Yes, i have just tried to install 1.9.6.4 and it's working. Strange enough :)
But i guess it's only temporary until Twitter completely blocked Basic
Auth, so i'm switching to Choqok and or QTwitter or perhaps Pino

--

-- 
Willy Sudiarto Raharjo
Registered Linux User : 336579
Web : http://www.informatix.or.id/willy
Blog : http://willysr.blogspot.com http://slackblogs.blogspot.com
David Woodfall | 2 Sep 05:57 2010
Picon

Re: Chokoq

On (18:30 01/09/10), Josiah Boothby <josiahb@...> put forth
the proposition:
>> Strange
>> If you are the maintainer, the admins would have rejected the package
>> if you haven't release your maintainer position
>> please ask one of the admin to remove the submitted package so that
>> you can submit yours
>
>I may, though I have to admit that I'm willing to cede maintainership
>if someone else would like to take over. I'm only the maintainer
>because I was the first person to upload a script ;)

Hi Josiah, as per your email to me I took maintainership and uploaded
the new version. Let me know if this is no longer your wish and I will
get an admin to delete it.

David

>_______________________________________________
>SlackBuilds-users mailing list
>SlackBuilds-users@...
>http://lists.slackbuilds.org/mailman/listinfo/slackbuilds-users
>Archives - http://lists.slackbuilds.org/pipermail/slackbuilds-users/
>FAQ - http://slackbuilds.org/faq/

--

-- 
Don't look back, the lemmings are gaining on you.
On (18:30 01/09/10), Josiah Boothby <josiahb@...> put forth
(Continue reading)

Willy Sudiarto Raharjo | 2 Sep 06:04 2010
Picon

Re: Chokoq

> Hi Josiah, as per your email to me I took maintainership and uploaded
> the new version. Let me know if this is no longer your wish and I will
> get an admin to delete it.

I think since David has agreed to take in charge of Choqok, i will not
submit any update and leave it to David then :)

--

-- 
Willy Sudiarto Raharjo
Registered Linux User : 336579
Web : http://www.informatix.or.id/willy
Blog : http://willysr.blogspot.com http://slackblogs.blogspot.com
Josiah Boothby | 2 Sep 06:06 2010
Picon

Re: Chokoq

> >I may, though I have to admit that I'm willing to cede maintainership
> >if someone else would like to take over. I'm only the maintainer
> >because I was the first person to upload a script ;)
> 
> Hi Josiah, as per your email to me I took maintainership and uploaded
> the new version. Let me know if this is no longer your wish and I will
> get an admin to delete it.

This is certainly fine by me, though you and Willy may have to have a
duel over it. 

Oops, Willy responded faster than I could. No duels!

--Josiah

Gmane