jamesgilmour | 8 Aug 07:24 2011

Installing gnucash 2.4.5----

 Hi,
	I'm trying to install gnucash but it doesn't get past the
	bottom of this page.
	I had no problem with gnucash 2.2.9 and then tried the upgrade.
	I followed the dependency compilation instructions without
	apparent difficulty and elected to include 'webkit' and libdb,
	also ok.

        Here is the last screen of the 'gnucash'build process before it
        stops.
 	Can you help?

 after-statement -O2 -march=i486 -mtune=i686 -Wall -Wunused
 -Wmissing-prototypes -Wmissing-declarations  -Wno-unused   -o gnucash
 gnucash-bin.o  ../../src/libqof/qof/libgnc-qof.la ../../src/core-utils/libgnc-core-utils.la
../../src/engine/libgncmod-engine.la ../../src/gnome/libgnc-gnome.la
../../src/gnome-utils/libgncmod-gnome-utils.la ../../src/app-utils/libgncmod-app-utils.la ../../src/gnc-module/libgnc-module.la
 -pthread  -lguile -lltdl -lgmp -lcrypt -lm -lltdl -pthread
 -Wl,--export-dynamic -lgobject-2.0 -lgthread-2.0 -lgmodule-2.0 -lrt
 -lglib-2.0   -pthread -lgnomeui-2 -lSM -lICE -lbonoboui-2 -lgnomevfs-2
 -lgnomecanvas-2 -lgnome-2 -lpopt -lbonobo-2 -lbonobo-activation
 -lORBit-2 -lart_lgpl_2 -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0
 -lpangoft2-1.0 -lpangocairo-1.0 -lgdk_pixbuf-2.0 -lm -lcairo
 -lpango-1.0 -lfreetype -lfontconfig -lgconf-2 -lgmodule-2.0
 -lgobject-2.0 -lgthread-2.0 -lrt -lglib-2.0   -pthread -lgtk-x11-2.0
 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lpangocairo-1.0
 -lgdk_pixbuf-2.0 -lm -lcairo -lpango-1.0 -lfreetype -lfontconfig
 -lgobject-2.0 -lgmodule-2.0 -lgthread-2.0 -lrt -lglib-2.0   -lm  -lm
 libtool: link: gcc -Wdeclaration-after-statement -O2 -march=i486
 -mtune=i686 -Wall -Wunused -Wmissing-prototypes -Wmissing-declarations
(Continue reading)

Ozan Türkyılmaz | 8 Aug 13:33 2011
Picon

Re: Installing gnucash 2.4.5----

remove old version and re try the build. It's a known problem without
a real solution.

2011/8/8 jamesgilmour <jh-gilmour <at> bigpond.com>:
>  Hi,
>        I'm trying to install gnucash but it doesn't get past the
>        bottom of this page.
>        I had no problem with gnucash 2.2.9 and then tried the upgrade.
>        I followed the dependency compilation instructions without
>        apparent difficulty and elected to include 'webkit' and libdb,
>        also ok.
>
>        Here is the last screen of the 'gnucash'build process before it
>        stops.
>        Can you help?
>
>  after-statement -O2 -march=i486 -mtune=i686 -Wall -Wunused
>  -Wmissing-prototypes -Wmissing-declarations  -Wno-unused   -o gnucash
>  gnucash-bin.o  ../../src/libqof/qof/libgnc-qof.la
../../src/core-utils/libgnc-core-utils.la ../../src/engine/libgncmod-engine.la
../../src/gnome/libgnc-gnome.la ../../src/gnome-utils/libgncmod-gnome-utils.la
../../src/app-utils/libgncmod-app-utils.la ../../src/gnc-module/libgnc-module.la
>  -pthread  -lguile -lltdl -lgmp -lcrypt -lm -lltdl -pthread
>  -Wl,--export-dynamic -lgobject-2.0 -lgthread-2.0 -lgmodule-2.0 -lrt
>  -lglib-2.0   -pthread -lgnomeui-2 -lSM -lICE -lbonoboui-2 -lgnomevfs-2
>  -lgnomecanvas-2 -lgnome-2 -lpopt -lbonobo-2 -lbonobo-activation
>  -lORBit-2 -lart_lgpl_2 -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0
>  -lpangoft2-1.0 -lpangocairo-1.0 -lgdk_pixbuf-2.0 -lm -lcairo
>  -lpango-1.0 -lfreetype -lfontconfig -lgconf-2 -lgmodule-2.0
>  -lgobject-2.0 -lgthread-2.0 -lrt -lglib-2.0   -pthread -lgtk-x11-2.0
(Continue reading)

Donald Allen | 8 Aug 13:54 2011
Picon

Re: Installing gnucash 2.4.5----



2011/8/8 Ozan Türkyılmaz <ozan.turkyilmaz-Re5JQEeQqe8AvxtiuMwx3w@public.gmane.org>
remove old version and re try the build. It's a known problem without
a real solution.

Yes, that's certainly good advice. I think this is inherent in the extremely complex method used to build gnucash from source. I ran into similar problems trying to build one of the 2.4 series from source with 2.2.9 installed. The advice I got from Derek Atkins, one of the gnucash gurus, was to either remove the old version or configure with a --prefix != /usr/local. The former would seem to apply in this case.

2011/8/8 jamesgilmour <jh-gilmour-bzGI/hKkdgRBDgjK7y7TUQ@public.gmane.org>:
>  Hi,
>        I'm trying to install gnucash but it doesn't get past the
>        bottom of this page.
>        I had no problem with gnucash 2.2.9 and then tried the upgrade.
>        I followed the dependency compilation instructions without
>        apparent difficulty and elected to include 'webkit' and libdb,
>        also ok.
>
>        Here is the last screen of the 'gnucash'build process before it
>        stops.
>        Can you help?
>
>  after-statement -O2 -march=i486 -mtune=i686 -Wall -Wunused
>  -Wmissing-prototypes -Wmissing-declarations  -Wno-unused   -o gnucash
>  gnucash-bin.o  ../../src/libqof/qof/libgnc-qof.la ../../src/core-utils/libgnc-core-utils.la ../../src/engine/libgncmod-engine.la ../../src/gnome/libgnc-gnome.la ../../src/gnome-utils/libgncmod-gnome-utils.la ../../src/app-utils/libgncmod-app-utils.la ../../src/gnc-module/libgnc-module.la
>  -pthread  -lguile -lltdl -lgmp -lcrypt -lm -lltdl -pthread
>  -Wl,--export-dynamic -lgobject-2.0 -lgthread-2.0 -lgmodule-2.0 -lrt
>  -lglib-2.0   -pthread -lgnomeui-2 -lSM -lICE -lbonoboui-2 -lgnomevfs-2
>  -lgnomecanvas-2 -lgnome-2 -lpopt -lbonobo-2 -lbonobo-activation
>  -lORBit-2 -lart_lgpl_2 -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0
>  -lpangoft2-1.0 -lpangocairo-1.0 -lgdk_pixbuf-2.0 -lm -lcairo
>  -lpango-1.0 -lfreetype -lfontconfig -lgconf-2 -lgmodule-2.0
>  -lgobject-2.0 -lgthread-2.0 -lrt -lglib-2.0   -pthread -lgtk-x11-2.0
>  -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lpangocairo-1.0
>  -lgdk_pixbuf-2.0 -lm -lcairo -lpango-1.0 -lfreetype -lfontconfig
>  -lgobject-2.0 -lgmodule-2.0 -lgthread-2.0 -lrt -lglib-2.0   -lm  -lm
>  libtool: link: gcc -Wdeclaration-after-statement -O2 -march=i486
>  -mtune=i686 -Wall -Wunused -Wmissing-prototypes -Wmissing-declarations
>  -Wno-unused -o .libs/gnucash gnucash-bin.o -pthread -pthread
>  -Wl,--export-dynamic -pthread
>  -pthread  ../../src/libqof/qof/.libs/libgnc-qof.so ../../src/core-utils/.libs/libgnc-core-utils.so ../../src/engine/.libs/libgncmod-engine.so ../../src/gnome/.libs/libgnc-gnome.so ../../src/gnome-utils/.libs/libgncmod-gnome-utils.so ../../src/app-utils/.libs/libgncmod-app-utils.so ../../src/gnc-module/.libs/libgnc-module.so /usr/lib/libguile.so /usr/lib/libgmp.so
>  -lcrypt /usr/lib/libltdl.so /usr/lib/libgnomeui-2.so /usr/lib/libSM.so /usr/lib/libICE.so /usr/lib/libbonoboui-2.so /usr/lib/libgnomevfs-2.so /usr/lib/libgnomecanvas-2.so /usr/lib/libgnome-2.so /usr/lib/libpopt.so /usr/lib/libbonobo-2.so /usr/lib/libbonobo-activation.so /usr/lib/libORBit-2.so /usr/lib/libart_lgpl_2.so /usr/lib/libgconf-2.so /usr/lib/libgtk-x11-2.0.so /usr/lib/libgdk-x11-2.0.so /usr/lib/libatk-1.0.so /usr/lib/libgio-2.0.so /usr/lib/libpangoft2-1.0.so /usr/lib/libpangocairo-1.0.so /usr/lib/libgdk_pixbuf-2.0.so /usr/lib/libcairo.so /usr/lib/libpango-1.0.so /usr/lib/libfreetype.so /usr/lib/libfontconfig.so /usr/lib/libgobject-2.0.so /usr/lib/libgmodule-2.0.so /usr/lib/libgthread-2.0.so
>  -lrt /usr/lib/libglib-2.0.so -lm -pthread -Wl,-rpath
>  -Wl,/usr/lib/gnucash /usr/lib/gnucash/libgncmod-report-gnome.so:
>  undefined reference to
>  `gnc_html_export' /usr/lib/gnucash/libgncmod-report-gnome.so:
>  undefined reference to
>  `gnc_html_copy' /usr/lib/gnucash/libgncmod-report-gnome.so: undefined
>  reference to `gnc_html_new' collect2: ld returned 1 exit status
>  make[4]: *** [gnucash] Error 1 make[4]: Leaving directory
>  `/tmp/SBo/gnucash-2.4.5/src/bin' make[3]: *** [all-recursive] Error 1
>  make[3]: Leaving directory `/tmp/SBo/gnucash-2.4.5/src/bin' make[2]:
>  *** [all-recursive] Error 1 make[2]: Leaving directory
>  `/tmp/SBo/gnucash-2.4.5/src' make[1]: *** [all-recursive] Error 1
>  make[1]: Leaving directory `/tmp/SBo/gnucash-2.4.5' make: *** [all]
>
>
>
>
>  Error 2 gnucash: Would you like to continue processing the rest of the
>  build queue or would you like to abort?  If this failed package is a
>  dependency of another package in the queue then it may not make sense
>  to continue. (Y)es to continue, (N)o to abort, (R)etry the build?:
>  README                     gnucash-2.4.5.tar.bz2
>  gnucash.SlackBuild.build   gnucash.info
>  gnucash.info.sbopkg doinst.sh
>  gnucash.SlackBuild         gnucash.SlackBuild.sbopkg
>  gnucash.info.build         slack-desc
>
>
>  James Gilmour.
> _______________________________________________
> SlackBuilds-users mailing list
> SlackBuilds-users <at> slackbuilds.org
> http://lists.slackbuilds.org/mailman/listinfo/slackbuilds-users
> Archives - http://lists.slackbuilds.org/pipermail/slackbuilds-users/
> FAQ - http://slackbuilds.org/faq/
>
>



--
Ozan, BSc, BEng

<div>
<br><br><div class="gmail_quote">2011/8/8 Ozan T&uuml;rky&#305;lmaz <span dir="ltr">&lt;<a href="mailto:ozan.turkyilmaz@...">ozan.turkyilmaz@...</a>&gt;</span><br><blockquote class="gmail_quote">
remove old version and re try the build. It's a known problem without<br>
a real solution.<br>
</blockquote>
<div>
<br>Yes, that's certainly good advice. I think this is inherent in the extremely complex method used to build gnucash from source. I ran into similar problems trying to build one of the 2.4 series from source with 2.2.9 installed. The advice I got from Derek Atkins, one of the gnucash gurus, was to either remove the old version or configure with a --prefix != /usr/local. The former would seem to apply in this case. <br>
</div>
<blockquote class="gmail_quote">
<br>
2011/8/8 jamesgilmour &lt;<a href="mailto:jh-gilmour@...">jh-gilmour@...</a>&gt;:<br><div>
<div></div>
<div class="h5">&gt; &nbsp;Hi,<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp;I'm trying to install gnucash but it doesn't get past the<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp;bottom of this page.<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp;I had no problem with gnucash 2.2.9 and then tried the upgrade.<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp;I followed the dependency compilation instructions without<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp;apparent difficulty and elected to include 'webkit' and libdb,<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp;also ok.<br>
&gt;<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp;Here is the last screen of the 'gnucash'build process before it<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp;stops.<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp;Can you help?<br>
&gt;<br>
&gt; &nbsp;after-statement -O2 -march=i486 -mtune=i686 -Wall -Wunused<br>
&gt; &nbsp;-Wmissing-prototypes -Wmissing-declarations &nbsp;-Wno-unused &nbsp; -o gnucash<br>
&gt; &nbsp;gnucash-bin.o &nbsp;../../src/libqof/qof/≤a href="http://libgnc-qof.la" target="_blank">libgnc-qof.la</a> ../../src/core-utils/<a href="http://libgnc-core-utils.la" target="_blank">libgnc-core-utils.la</a> ../../src/engine/≤a href="http://libgncmod-engine.la" target="_blank">libgncmod-engine.la</a> ../../src/gnome/≤a href="http://libgnc-gnome.la" target="_blank">libgnc-gnome.la</a> ../../src/gnome-utils/<a href="http://libgncmod-gnome-utils.la" target="_blank">libgncmod-gnome-utils.la</a> ../../src/app-utils/<a href="http://libgncmod-app-utils.la" target="_blank">libgncmod-app-utils.la</a> ../../src/gnc-module/<a href="http://libgnc-module.la" target="_blank">libgnc-module.la</a><br>

&gt; &nbsp;-pthread &nbsp;-lguile -lltdl -lgmp -lcrypt -lm -lltdl -pthread<br>
&gt; &nbsp;-Wl,--export-dynamic -lgobject-2.0 -lgthread-2.0 -lgmodule-2.0 -lrt<br>
&gt; &nbsp;-lglib-2.0 &nbsp; -pthread -lgnomeui-2 -lSM -lICE -lbonoboui-2 -lgnomevfs-2<br>
&gt; &nbsp;-lgnomecanvas-2 -lgnome-2 -lpopt -lbonobo-2 -lbonobo-activation<br>
&gt; &nbsp;-lORBit-2 -lart_lgpl_2 -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0<br>
&gt; &nbsp;-lpangoft2-1.0 -lpangocairo-1.0 -lgdk_pixbuf-2.0 -lm -lcairo<br>
&gt; &nbsp;-lpango-1.0 -lfreetype -lfontconfig -lgconf-2 -lgmodule-2.0<br>
&gt; &nbsp;-lgobject-2.0 -lgthread-2.0 -lrt -lglib-2.0 &nbsp; -pthread -lgtk-x11-2.0<br>
&gt; &nbsp;-lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lpangocairo-1.0<br>
&gt; &nbsp;-lgdk_pixbuf-2.0 -lm -lcairo -lpango-1.0 -lfreetype -lfontconfig<br>
&gt; &nbsp;-lgobject-2.0 -lgmodule-2.0 -lgthread-2.0 -lrt -lglib-2.0 &nbsp; -lm &nbsp;-lm<br>
&gt; &nbsp;libtool: link: gcc -Wdeclaration-after-statement -O2 -march=i486<br>
&gt; &nbsp;-mtune=i686 -Wall -Wunused -Wmissing-prototypes -Wmissing-declarations<br>
&gt; &nbsp;-Wno-unused -o .libs/gnucash gnucash-bin.o -pthread -pthread<br>
&gt; &nbsp;-Wl,--export-dynamic -pthread<br>
&gt; &nbsp;-pthread &nbsp;../../src/libqof/qof/.libs/libgnc-qof.so ../../src/core-utils/.libs/libgnc-core-utils.so ../../src/engine/.libs/libgncmod-engine.so ../../src/gnome/.libs/libgnc-gnome.so ../../src/gnome-utils/.libs/libgncmod-gnome-utils.so ../../src/app-utils/.libs/libgncmod-app-utils.so ../../src/gnc-module/.libs/libgnc-module.so /usr/lib/libguile.so /usr/lib/libgmp.so<br>

&gt; &nbsp;-lcrypt /usr/lib/libltdl.so /usr/lib/libgnomeui-2.so /usr/lib/libSM.so /usr/lib/libICE.so /usr/lib/libbonoboui-2.so /usr/lib/libgnomevfs-2.so /usr/lib/libgnomecanvas-2.so /usr/lib/libgnome-2.so /usr/lib/libpopt.so /usr/lib/libbonobo-2.so /usr/lib/libbonobo-activation.so /usr/lib/libORBit-2.so /usr/lib/libart_lgpl_2.so /usr/lib/libgconf-2.so /usr/lib/≤a href="http://libgtk-x11-2.0.so" target="_blank">libgtk-x11-2.0.so</a> /usr/lib/≤a href="http://libgdk-x11-2.0.so" target="_blank">libgdk-x11-2.0.so</a> /usr/lib/≤a href="http://libatk-1.0.so" target="_blank">libatk-1.0.so</a> /usr/lib/≤a href="http://libgio-2.0.so" target="_blank">libgio-2.0.so</a> /usr/lib/≤a href="http://libpangoft2-1.0.so" target="_blank">libpangoft2-1.0.so</a> /usr/lib/≤a href="http://libpangocairo-1.0.so" target="_blank">libpangocairo-1.0.so</a> /usr/lib/≤a href="http://libgdk_pixbuf-2.0.so" target="_blank">libgdk_pixbuf-2.0.so</a> /usr/lib/libcairo.so /usr/lib/≤a href="http://libpango-1.0.so" target="_blank">libpango-1.0.so</a> /usr/lib/libfreetype.so /usr/lib/libfontconfig.so /usr/lib/≤a href="http://libgobject-2.0.so" target="_blank">libgobject-2.0.so</a> /usr/lib/≤a href="http://libgmodule-2.0.so" target="_blank">libgmodule-2.0.so</a> /usr/lib/≤a href="http://libgthread-2.0.so" target="_blank">libgthread-2.0.so</a><br>

&gt; &nbsp;-lrt /usr/lib/≤a href="http://libglib-2.0.so" target="_blank">libglib-2.0.so</a> -lm -pthread -Wl,-rpath<br>
&gt; &nbsp;-Wl,/usr/lib/gnucash /usr/lib/gnucash/libgncmod-report-gnome.so:<br>
&gt; &nbsp;undefined reference to<br>
&gt; &nbsp;`gnc_html_export' /usr/lib/gnucash/libgncmod-report-gnome.so:<br>
&gt; &nbsp;undefined reference to<br>
&gt; &nbsp;`gnc_html_copy' /usr/lib/gnucash/libgncmod-report-gnome.so: undefined<br>
&gt; &nbsp;reference to `gnc_html_new' collect2: ld returned 1 exit status<br>
&gt; &nbsp;make[4]: *** [gnucash] Error 1 make[4]: Leaving directory<br>
&gt; &nbsp;`/tmp/SBo/gnucash-2.4.5/src/bin' make[3]: *** [all-recursive] Error 1<br>
&gt; &nbsp;make[3]: Leaving directory `/tmp/SBo/gnucash-2.4.5/src/bin' make[2]:<br>
&gt; &nbsp;*** [all-recursive] Error 1 make[2]: Leaving directory<br>
&gt; &nbsp;`/tmp/SBo/gnucash-2.4.5/src' make[1]: *** [all-recursive] Error 1<br>
&gt; &nbsp;make[1]: Leaving directory `/tmp/SBo/gnucash-2.4.5' make: *** [all]<br>
&gt;<br>
&gt;<br>
&gt;<br>
&gt;<br>
&gt; &nbsp;Error 2 gnucash: Would you like to continue processing the rest of the<br>
&gt; &nbsp;build queue or would you like to abort? &nbsp;If this failed package is a<br>
&gt; &nbsp;dependency of another package in the queue then it may not make sense<br>
&gt; &nbsp;to continue. (Y)es to continue, (N)o to abort, (R)etry the build?:<br>
&gt; &nbsp;README &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; gnucash-2.4.5.tar.bz2<br>
&gt; &nbsp;gnucash.SlackBuild.build &nbsp; <a href="http://gnucash.info" target="_blank">gnucash.info</a><br>
&gt; &nbsp;gnucash.info.sbopkg doinst.sh<br>
&gt; &nbsp;gnucash.SlackBuild &nbsp; &nbsp; &nbsp; &nbsp; gnucash.SlackBuild.sbopkg<br>
&gt; &nbsp;gnucash.info.build &nbsp; &nbsp; &nbsp; &nbsp; slack-desc<br>
&gt;<br>
&gt;<br>
&gt; &nbsp;James Gilmour.<br>
&gt; _______________________________________________<br>
&gt; SlackBuilds-users mailing list<br>
&gt; <a href="mailto:SlackBuilds-users@...">SlackBuilds-users <at> slackbuilds.org</a><br>
&gt; <a href="http://lists.slackbuilds.org/mailman/listinfo/slackbuilds-users" target="_blank">http://lists.slackbuilds.org/mailman/listinfo/slackbuilds-users</a><br>
&gt; Archives - <a href="http://lists.slackbuilds.org/pipermail/slackbuilds-users/" target="_blank">http://lists.slackbuilds.org/pipermail/slackbuilds-users/</a><br>
&gt; FAQ - <a href="http://slackbuilds.org/faq/" target="_blank">http://slackbuilds.org/faq/</a><br>
&gt;<br>
&gt;<br><br><br><br>
</div>
</div>--<br>
Ozan, BSc, BEng<br><div>
<div></div>
<div class="h5">_______________________________________________<br>
SlackBuilds-users mailing list<br><a href="mailto:SlackBuilds-users@...">SlackBuilds-users <at> slackbuilds.org</a><br><a href="http://lists.slackbuilds.org/mailman/listinfo/slackbuilds-users" target="_blank">http://lists.slackbuilds.org/mailman/listinfo/slackbuilds-users</a><br>
Archives - <a href="http://lists.slackbuilds.org/pipermail/slackbuilds-users/" target="_blank">http://lists.slackbuilds.org/pipermail/slackbuilds-users/</a><br>
FAQ - <a href="http://slackbuilds.org/faq/" target="_blank">http://slackbuilds.org/faq/</a><br><br>
</div>
</div>
</blockquote>
</div>
<br>
</div>

Gmane