Yorjing Tsai | 13 Oct 13:45 2012
Picon

XShmQueryVersion failed

Hi,
  When I open xfreerdp-server, I encounter "XShmQueryVersion failed", like this: 
http://www.mail-archive.com/freerdp-devel <at> lists.sourceforge.net/msg01858.html

  I also put --no-auth option in freerdp client, but it still occurs error.

  My environment is in Ubuntu 12.04 and xfreerdp-server in a physical machine.

  I think there are some problems in my XhmQueryVersion in version.

  Can anyone who have run xfreerdp-server successfully provides me your testing 
environment, such as linux version and libxext-dev(XShm) version for me?

  Thank you for your help very much

------------------------------------------------------------------------------
Don't let slow site performance ruin your business. Deploy New Relic APM
Deploy New Relic app performance management and know exactly
what is happening inside your Ruby, Python, PHP, Java, and .NET app
Try New Relic at no cost today and get our sweet Data Nerd shirt too!
http://p.sf.net/sfu/newrelic-dev2dev
Yorjing Tsai | 13 Oct 13:51 2012
Picon

Re: XShmQueryVersion failed

Yorjing Tsai <yorjing <at> gmail.com> writes:
> 
> Hi,
>   When I open xfreerdp-server, I encounter "XShmQueryVersion failed", like 
this: 
> http://www.mail-archive.com/freerdp-devellists.sourceforge.net/msg01858.html

Sorry,the link is unavailable.
Update link above http://osdir.com/ml/freerdp-devel-remote-desktop-
protocol/2012-03/msg00037.html

------------------------------------------------------------------------------
Don't let slow site performance ruin your business. Deploy New Relic APM
Deploy New Relic app performance management and know exactly
what is happening inside your Ruby, Python, PHP, Java, and .NET app
Try New Relic at no cost today and get our sweet Data Nerd shirt too!
http://p.sf.net/sfu/newrelic-dev2dev
Marc-André Moreau | 13 Oct 14:00 2012
Picon

Re: XShmQueryVersion failed

You need an X11 with the XSHM extension working, otherwise go in the code
and turn off the flag use_xschm (in server/X11/xf_peer.c)

On Sat, Oct 13, 2012 at 7:45 AM, Yorjing Tsai <yorjing <at> gmail.com> wrote:

> Hi,
>   When I open xfreerdp-server, I encounter "XShmQueryVersion failed", like
> this:
>
> http://www.mail-archive.com/freerdp-devel <at> lists.sourceforge.net/msg01858.html
>
>   I also put --no-auth option in freerdp client, but it still occurs error.
>
>   My environment is in Ubuntu 12.04 and xfreerdp-server in a physical
> machine.
>
>   I think there are some problems in my XhmQueryVersion in version.
>
>   Can anyone who have run xfreerdp-server successfully provides me your
> testing
> environment, such as linux version and libxext-dev(XShm) version for me?
>
>   Thank you for your help very much
>
>
>
> ------------------------------------------------------------------------------
> Don't let slow site performance ruin your business. Deploy New Relic APM
> Deploy New Relic app performance management and know exactly
> what is happening inside your Ruby, Python, PHP, Java, and .NET app
(Continue reading)

Yorjing Tsai | 14 Oct 17:22 2012
Picon

Re: XShmQueryVersion failed


Marc-André Moreau <marcandre.moreau <at> gmail.com> writes:

> 
> You need an X11 with the XSHM extension working, otherwise go in the code
> and turn off the flag use_xschm (in server/X11/xf_peer.c)
> 
Thank you for your help.
But when my xfreerdp client remote access xfreerdp-server,
the image from xfreerdp-server is still dark,
and I guess there is no transmission for image from xfreerdp-server to xfreerdp.

However, the keyboard input and mouse input can transmit to xfreerdp-server, but 
it's slowly.
I don't know much about this problem.
Does not the machine of xfreerdp-server support remotefx?
The GPU of my server are AMD HD 6620G 512MB and AMD Radeon HD 6470M ,1GB.
AMD Radeon HD 6470M supports DirectX 11.

What condictions do the machine of xfreerdp-server support remotefx?
Can anyone help me?
Thank you very much.

> On Sat, Oct 13, 2012 at 7:45 AM, Yorjing Tsai <yorjing <at> gmail.com> wrote:
> 
> > Hi,
> >   When I open xfreerdp-server, I encounter "XShmQueryVersion failed", like
> > this:
> >
> > http://www.mail-archive.com/freerdp-devel <at> 
(Continue reading)


Gmane