Deon | 31 Jul 18:44 2011
Picon

Re: Shrew Soft 2.17 unable to install Win64 AMD Phenom X4 NVidia NForce

Well, I have found the fix for Shrew Soft
 
The default number of services and protocols that can be attached to an adapter is 8. Windows 7 64-bit can support up to 14 of these.
 
I had to change this registry setting:
HKLM\System\CurrentControlSet\Control\Network\MaxNumFilters
 
The default value was 8. I changed to 10 then restarted the ShrewSoft client and it installed with no errors.
 
From: Deon
Sent: Saturday, July 30, 2011 10:55 AM
Subject: Shrew Soft 2.17 unable to install Win64 AMD Phenom X4 NVidia NForce
 
The install fails twice – during the vfilter.inf process (“couldn’t install the network component”)  and the virtualnet.inf process (“InstallSelectedDriver failed code 0x00000006”).
 
I’ve completed the manual uninstall routine found in another message thread; even have gone as a far as scanning the registry after the reboot for any remaining items pointing to “shrew”, “vfilter”, and “virtualnet”. I rerun the install and the same things happens again. After the failed install, I tried to manually install the protocol filter into the properties of the network card. That results in a message that says “Unable to find any drivers for this device”.
 
I’ve seen other messages pertaining to similar problems but have not yet found an answer that fixes my issue. Any one have any suggestions?
 
Thanks in advance.
_______________________________________________
vpn-help mailing list
vpn-help@...
http://lists.shrew.net/mailman/listinfo/vpn-help
Kevin VPN | 30 Aug 03:42 2011

Re: Shrew Soft 2.17 unable to install Win64 AMD Phenom X4 NVidia NForce

On 07/31/2011 12:44 PM, Deon wrote:
> Well, I have found the fix for Shrew Soft
 >
> The default number of services and protocols that can be attached to an
> adapter is 8. Windows 7 64-bit can support up to 14 of these.
 >
> I had to change this registry setting:
> HKLM\System\CurrentControlSet\Control\Network\MaxNumFilters

> The default value was 8. I changed to 10 then restarted the ShrewSoft
> client and it installed with no errors.
 >
> *From:* Deon <mailto:deoncranford <at> carolina.rr.com>
> *Sent:* Saturday, July 30, 2011 10:55 AM
> *To:* vpn-help <at> lists.shrew.net <mailto:vpn-help <at> lists.shrew.net>
> *Subject:* Shrew Soft 2.17 unable to install Win64 AMD Phenom X4 NVidia
> NForce
 >
> The install fails twice – during the vfilter.inf process (“couldn’t
> install the network component”) and the virtualnet.inf process
> (“InstallSelectedDriver failed code 0x00000006”).
 >
> I’ve completed the manual uninstall routine found in another message
> thread; even have gone as a far as scanning the registry after the
> reboot for any remaining items pointing to “shrew”, “vfilter”, and
> “virtualnet”. I rerun the install and the same things happens again.
> After the failed install, I tried to manually install the protocol
> filter into the properties of the network card. That results in a
> message that says “Unable to find any drivers for this device”.
 >
> I’ve seen other messages pertaining to similar problems but have not yet
> found an answer that fixes my issue. Any one have any suggestions?
> Thanks in advance.
>

Deon, thanks for posting a follow-up.  This is really useful and may 
help some others on the list that have inexplicable problems installing 
Shrew.
_______________________________________________
vpn-help mailing list
vpn-help <at> lists.shrew.net
http://lists.shrew.net/mailman/listinfo/vpn-help

Gmane