jones34 | 28 Feb 20:56 2011
Picon

Upgraded to 2.2 & broke hibernate 3.6 using JPA in Intellij Idea

I updated to 2.2 and started immediately getting hibernate exceptions
on the first attempt to use the database (see below) in my development
environment Intellij Idea 10.

I suspect that updating stomps something in my classpath or just
reorders the class path in a way that makes hibernate fail. Has anyone
seen this?

Does anyone know which jars/classes might be conflicting?

thanks.

Caused by: javax.persistence.PersistenceException: [PersistenceUnit:
vingenius] Unable to configure EntityManagerFactory
	at
org.hibernate.ejb.Ejb3Configuration.configure(Ejb3Configuration.java:
374)
	at
org.hibernate.ejb.HibernatePersistence.createEntityManagerFactory(HibernatePersistence.java:
56)
	at
javax.persistence.Persistence.createEntityManagerFactory(Persistence.java:
78)
	at
javax.persistence.Persistence.createEntityManagerFactory(Persistence.java:
54)
	at us.vingeni.vingenius.server.db.DAO.<clinit>(DAO.java:29)
	... 32 more
Caused by: org.hibernate.HibernateException: Unable to get the default
Bean Validation factory
(Continue reading)

jones34 | 28 Feb 22:05 2011
Picon

Re: Upgraded to 2.2 & broke hibernate 3.6 using JPA in Intellij Idea

It seems like 2.2 (or the upgrade process) triggers in hibernate the
hallucination that I wanted to use bean validation (maybe it's just
the presence of javax.validation in the gwt servlet-dep jar, although
it was present in 2.1 as well).

If you don't want to use hibernate bean validation, you can add this
line to your hibernate persistence.xml file:

      <validation-mode>NONE</validation-mode>

And all is well again.

On Feb 28, 2:56 pm, jones34 <ljw1...@...> wrote:
> I updated to 2.2 and started immediately getting hibernate exceptions
> on the first attempt to use the database (see below) in my development
> environment Intellij Idea 10.
>
> I suspect that updating stomps something in my classpath or just
> reorders the class path in a way that makes hibernate fail. Has anyone
> seen this?
>
> Does anyone know which jars/classes might be conflicting?
>
> thanks.
>
> Caused by: javax.persistence.PersistenceException: [PersistenceUnit:
> vingenius] Unable to configure EntityManagerFactory
>         at
> org.hibernate.ejb.Ejb3Configuration.configure(Ejb3Configuration.java:
> 374)
(Continue reading)


Gmane