John Hay | 18 Oct 09:39 2011
Picon

freebsd-9.0 smartmontools and ada devices

Hi Guys,

I have upgraded my desktop from 8.2-stable to 9.0-RC1 (from source), using
a GENERIC kernel. I have installed the smartmontools-5.41_3 package from
a mirror and found that smartmontools does not like the ada devices anymore.
Previously (8.2) I had a GENERIC kernel, with ahci loaded in loader.conf.
There an older smartmontools (5.40) worked without a problem on the ada
devices.

The output of smartctl looks like this:

#############################
dolphin# smartctl -a /dev/ada0
smartctl 5.41 2011-06-09 r3365 [FreeBSD 9.0-RC1 amd64] (local build)
Copyright (C) 2002-11 by Bruce Allen, http://smartmontools.sourceforge.net

error sending CAMIOCOMMAND ioctl: Inappropriate ioctl for device
Unable to get CAM device list
/dev/ada0: Unable to detect device type
Smartctl: please specify device type with the -d option.

Use smartctl -h to get a usage summary

#############################

Has anybody seen it?

John
--

-- 
John Hay -- jhay <at> meraka.csir.co.za / jhay <at> FreeBSD.org
(Continue reading)

John Hay | 18 Oct 11:02 2011
Picon

Re: freebsd-9.0 smartmontools and ada devices

On Tue, Oct 18, 2011 at 09:39:24AM +0200, John Hay wrote:
> Hi Guys,
> 
> I have upgraded my desktop from 8.2-stable to 9.0-RC1 (from source), using
> a GENERIC kernel. I have installed the smartmontools-5.41_3 package from
> a mirror and found that smartmontools does not like the ada devices anymore.
> Previously (8.2) I had a GENERIC kernel, with ahci loaded in loader.conf.
> There an older smartmontools (5.40) worked without a problem on the ada
> devices.
> 
> The output of smartctl looks like this:
> 
> #############################
> dolphin# smartctl -a /dev/ada0
> smartctl 5.41 2011-06-09 r3365 [FreeBSD 9.0-RC1 amd64] (local build)
> Copyright (C) 2002-11 by Bruce Allen, http://smartmontools.sourceforge.net
> 
> error sending CAMIOCOMMAND ioctl: Inappropriate ioctl for device
> Unable to get CAM device list
> /dev/ada0: Unable to detect device type
> Smartctl: please specify device type with the -d option.
> 
> Use smartctl -h to get a usage summary
> 
> #############################

Just to follow up on myself. :-( I have build smartmontools from ports and
even though it is the same version, it works. So for me the package
amd64/packages-9-current/All/smartmontools-5.41_3.tbz did not work, but the
port does.
(Continue reading)

Kostik Belousov | 18 Oct 11:25 2011
Picon

Re: freebsd-9.0 smartmontools and ada devices

On Tue, Oct 18, 2011 at 11:02:42AM +0200, John Hay wrote:
> On Tue, Oct 18, 2011 at 09:39:24AM +0200, John Hay wrote:
> > Hi Guys,
> > 
> > I have upgraded my desktop from 8.2-stable to 9.0-RC1 (from source), using
> > a GENERIC kernel. I have installed the smartmontools-5.41_3 package from
> > a mirror and found that smartmontools does not like the ada devices anymore.
> > Previously (8.2) I had a GENERIC kernel, with ahci loaded in loader.conf.
> > There an older smartmontools (5.40) worked without a problem on the ada
> > devices.
> > 
> > The output of smartctl looks like this:
> > 
> > #############################
> > dolphin# smartctl -a /dev/ada0
> > smartctl 5.41 2011-06-09 r3365 [FreeBSD 9.0-RC1 amd64] (local build)
> > Copyright (C) 2002-11 by Bruce Allen, http://smartmontools.sourceforge.net
> > 
> > error sending CAMIOCOMMAND ioctl: Inappropriate ioctl for device
> > Unable to get CAM device list
> > /dev/ada0: Unable to detect device type
> > Smartctl: please specify device type with the -d option.
> > 
> > Use smartctl -h to get a usage summary
> > 
> > #############################
> 
> Just to follow up on myself. :-( I have build smartmontools from ports and
> even though it is the same version, it works. So for me the package
> amd64/packages-9-current/All/smartmontools-5.41_3.tbz did not work, but the
(Continue reading)

Oliver Heesakkers | 18 Oct 11:18 2011

Re: freebsd-9.0 smartmontools and ada devices

Op di 18 okt 2011 09:39:24 schreef John Hay:
> Hi Guys,
> 
> I have upgraded my desktop from 8.2-stable to 9.0-RC1 (from source), using
> a GENERIC kernel. I have installed the smartmontools-5.41_3 package from
> a mirror and found that smartmontools does not like the ada devices anymore.
> Previously (8.2) I had a GENERIC kernel, with ahci loaded in loader.conf.
> There an older smartmontools (5.40) worked without a problem on the ada
> devices.
> 
> The output of smartctl looks like this:
> 
> #############################
> dolphin# smartctl -a /dev/ada0
> smartctl 5.41 2011-06-09 r3365 [FreeBSD 9.0-RC1 amd64] (local build)
> Copyright (C) 2002-11 by Bruce Allen, http://smartmontools.sourceforge.net
> 
> error sending CAMIOCOMMAND ioctl: Inappropriate ioctl for device
> Unable to get CAM device list
> /dev/ada0: Unable to detect device type
> Smartctl: please specify device type with the -d option.
> 
> Use smartctl -h to get a usage summary
> 
> #############################
> 
> Has anybody seen it?
> 

Yes, but rebuilding smartmontools fixed it for me.
(Continue reading)


Gmane