b. f. | 7 Oct 09:46 2011

audio/cdparanoia broken on -CURRENT, and probably on 9.0

Just a note to say that recent changes on -CURRENT (r225950, meaning
that it is probably broken on 9.0 after r226067) have broken
audio/cdparanoia, and it should be fixed or marked as BROKEN there.  I
haven't filed a PR, or attempted to patch it yet -- I think that it
would be worthwhile to look into moving to 10.2, which has a large
number of improvements, although suffering from some Linuxisms.

Regards,
                b.

===>   cdparanoia-3.9.8_9 depends on executable: gmake - found
===>  Configuring for cdparanoia-3.9.8_9
creating cache ./config.cache
checking host system type... Invalid configuration
`amd64-portbld-freebsd9.9': machine `amd64-portbld' not recognized

checking for ranlib... ranlib
checking for ar... ar
checking for install... /usr/bin/install -c -o root -g wheel
checking how to run the C preprocessor... cpp
checking for ANSI C header files... yes
checking size of short... 2
checking size of int... 4
checking size of long... 8
checking size of long long... 8
checking for int16_t... yes
checking for int32_t... yes
checking for u_int16_t... yes
checking for u_int32_t... yes
checking for linux/sbpcd.h... no
(Continue reading)

Kenneth D. Merry | 7 Oct 14:11 2011
Picon

Re: audio/cdparanoia broken on -CURRENT, and probably on 9.0

On Fri, Oct 07, 2011 at 03:46:22 -0400, b. f. wrote:
> Just a note to say that recent changes on -CURRENT (r225950, meaning
> that it is probably broken on 9.0 after r226067) have broken
> audio/cdparanoia, and it should be fixed or marked as BROKEN there.  I
> haven't filed a PR, or attempted to patch it yet -- I think that it
> would be worthwhile to look into moving to 10.2, which has a large
> number of improvements, although suffering from some Linuxisms.

This will be easy to patch, using one of two methods:

 - change struct scsi_sense_data to struct scsi_sense_data_fixed
or, better yet:
 - use scsi_extract_sense_len(), which will work for fixed or descriptor
   sense.

> Regards,
>                 b.
> 
> 
> ===>   cdparanoia-3.9.8_9 depends on executable: gmake - found
> ===>  Configuring for cdparanoia-3.9.8_9
> creating cache ./config.cache
> checking host system type... Invalid configuration
> `amd64-portbld-freebsd9.9': machine `amd64-portbld' not recognized
> 
> checking for ranlib... ranlib
> checking for ar... ar
> checking for install... /usr/bin/install -c -o root -g wheel
> checking how to run the C preprocessor... cpp
> checking for ANSI C header files... yes
(Continue reading)

grarpamp | 7 Oct 20:29 2011
Picon

audio/cdparanoia broken on -CURRENT, and probably on 9.0

> I think that it would be worthwhile to look into moving to 10.2,
> which has a large number of improvements, although suffering
> from some Linuxisms.

My efforts at an update failed due to my own failings :)
So just a ditto on the suggestion to move to 10.2 and
avoiding BROKEN. You may also want to look over their
r32289 and mailing list. Either way, some of us with
larger rip projects would luv u, heh :)
_______________________________________________
freebsd-multimedia <at> freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-multimedia
To unsubscribe, send any mail to "freebsd-multimedia-unsubscribe <at> freebsd.org"


Gmane